1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst Haarp + oscam + mgcamd -> Booteinstellungen?

Dieses Thema im Forum "Enigma2" wurde erstellt von mar72der, 9. Dezember 2011.

  1. mar72der
    Offline

    mar72der Ist gelegentlich hier

    Registriert:
    4. Oktober 2011
    Beiträge:
    59
    Zustimmungen:
    11
    Punkte für Erfolge:
    0
    Hallo zusammen,

    ich habe folgende Herausforderung:
    Ich möchte Oscam(4158) und mgcamd(138) parallel betreiben. Warum? Bei der Mod Version habe ich Freezer bei den HD+ Serndern auf der V13. EMM´s blocken hilft da auch nicht, da das Problem wohl an der DVBApi liegt.

    Wenn ich die cams hintereinander über telnet starte Funktioniert alles reibungslos. OsCam liest die Karte und MgCamd greift drauf zu und die Ösis rennen per Keks.

    Nun hatte ich folgenden plan:
    in der /var/config/rc.user habe ich folgenden Eintrag vorgenommen:
    #!/bin/sh
    #Users can add link to own scripts in this file
    /var/emu/oscam -c /var/keys &

    Und im Image die mgcamd gestartet.

    Beim Booten scheint die Oscam jedoch nicht zu starten (komme nicht auf´s WebIf und per telnet ist der Prozess nicht zu sehen).

    Wer hat ne Idee / Lösung für mich?

    VG
    mar72der
     
    Zuletzt bearbeitet: 11. Dezember 2011
    #1
  2. phantom

    Nervigen User Advertisement

  3. mar72der
    Offline

    mar72der Ist gelegentlich hier

    Registriert:
    4. Oktober 2011
    Beiträge:
    59
    Zustimmungen:
    11
    Punkte für Erfolge:
    0
    AW: Haarp + oscam + mgcamd -> Booteinstellungen?

    Zwischenstand:
    Habe mir ne start.sh und ne end.sh gebastelt siehe spoiler
    start.sh:
    #!/bin/sh
    /var/emu/oscam -c /var/keys &
    sleep 15
    /var/emu/mgcamd &

    end.sh
    #!/bin/sh
    killall -9 oscam
    killall -9 mgcamd

    klappt über Telnet wunderbar. Wie kann ich die scripte nun ins menü einbauen?
    Packe ich sie in emu, startet der Pingu nicht. Das gleiche gilt, wenn ich die start.sh in die rc.user einbaue.

    Wie kriege ich die Dateien in Unter die Erweiterungen (rote Taste)?

    VG
    mar72der
     
    Zuletzt bearbeitet: 9. Dezember 2011
    #2
  4. mar72der
    Offline

    mar72der Ist gelegentlich hier

    Registriert:
    4. Oktober 2011
    Beiträge:
    59
    Zustimmungen:
    11
    Punkte für Erfolge:
    0
    AW: Haarp + oscam + mgcamd -> Booteinstellungen?

    Update:
    Wenn wích das script über Dreamexplorer starte, wird das script ausgeführt. Leider in einer Console, welche sich nicht schließen lässt...Irgendwer eine Idee???
    Habe das gleiche Problem mit der selbstgebastelten py Datei

    from Plugins.Plugin import PluginDescriptor
    from Components.ActionMap import ActionMap
    from Screens.Console import Console

    cmd = "/usr/script/start.sh"

    def main(session, **kwargs):
    session.open(Console,_("Start V13"),[cmd])

    def Plugins(**kwargs):
    return [PluginDescriptor(name="V13 starten", description=_("OSCam und MGCamd starten"), where = PluginDescriptor.WHERE_PLUGINMENU, fnc=main),
    PluginDescriptor(name="V13 starten", description=_("OSCam und MGCamd starten"), where = PluginDescriptor.WHERE_EXTENSIONSMENU, fnc=main)]

    Ich bin doch wohl nicht allein mit dem Wunsch/ Problem oder??

    VG
    Mar72der
     
    #3
  5. mar72der
    Offline

    mar72der Ist gelegentlich hier

    Registriert:
    4. Oktober 2011
    Beiträge:
    59
    Zustimmungen:
    11
    Punkte für Erfolge:
    0
    Hat niemand eine Idee???

    Zwischenstand /update

    start.sh sieht wie folgt aus:
    #!/bin/sh
    killall -9 oscam
    killall -9 mgcamd
    /var/emu/oscam -c /var/keys &
    sleep 15
    /var/emu/mgcamd &
    und mein Plugin so:
    from Plugins.Plugin import PluginDescriptor
    import os
    def main(session, **kwargs):
    os.system("/usr/script/start.sh")

    def Plugins(**kwargs):
    return [PluginDescriptor(name = "Re-start V13 v2", description = "Mg und oscam start", where =[PluginDescriptor.WHERE_PLUGINMENU, PluginDescriptor.WHERE_EXTENSIONSMENU],fnc=main)]

    Rufe ich die start.sh über telnet auf, geht alles einwandfrei. Beim Start über das Plugin nicht? Soll heißen, bild wird hell, dann erscheint spätesten beim zappen der Spinner und nichts geht mehr.

    Bin am verzweifeln!

    VG
    mar72der
     
    #4
  6. mar72der
    Offline

    mar72der Ist gelegentlich hier

    Registriert:
    4. Oktober 2011
    Beiträge:
    59
    Zustimmungen:
    11
    Punkte für Erfolge:
    0
    Scriptfehler???

    Vielleicht kann ja jemand hierbei helfen???

    So sieht meine start.sh aus:
    #!/bin/sh
    echo "Beende Oscam & MgCamd"
    killall -9 oscam
    killall -9 mgcamd
    echo "SoftCams beendet"
    echo "starte oscam"
    /var/emu/oscam -c /var/keys &
    echo "oscam gestartet...15 Sekunden warten"
    sleep 15
    echo "starte MgCamd"
    /var/emu/mgcamd &
    sleep 8
    echo "fertig"

    Um die Ausgaben zu minimieren, habe ich log der mgcamd und oscam deaktiviert.

    führe ich sie über Telnet aus, läuft das script durch. Starte ich es von der Box aus (Dreamexplorer) werden die Cams zwar (neu)gestartet und es wird helle, jedoch wird lt. Console das script nicht beendet?!?

    Führe ich dann das Script erneut über telnet aus, erscheint am TV in der Console "Ausführung beendet".

    Wo liegt der Fehler?

    VG
    mar72der

    P.S: Warum ich immer einen neuen Post mach? damit man sieht, das ich mich wirklich bemühe.
     
    #5
  7. mar72der
    Offline

    mar72der Ist gelegentlich hier

    Registriert:
    4. Oktober 2011
    Beiträge:
    59
    Zustimmungen:
    11
    Punkte für Erfolge:
    0
    AW: Scriptfehler???

    LÖsung gefunden, kann geschlossen werden.
     
    #6
  8. Blasser
    Offline

    Blasser Board Guru

    Registriert:
    16. Oktober 2010
    Beiträge:
    1.344
    Zustimmungen:
    874
    Punkte für Erfolge:
    113
    AW: Haarp + oscam + mgcamd -> Booteinstellungen?

    Dann poste doch bitte noch die Lösung, damit alle was davon haben...
     
    #7
    Pilot gefällt das.
  9. mar72der
    Offline

    mar72der Ist gelegentlich hier

    Registriert:
    4. Oktober 2011
    Beiträge:
    59
    Zustimmungen:
    11
    Punkte für Erfolge:
    0
    AW: Haarp + oscam + mgcamd -> Booteinstellungen?

    Wie starte ich beide EMU? Wichtig ist, das alles schon vorher getestet wurde (Telnet)und oscam und mgcamd auch so benannt sind! Dann neues Verzeichniss im PlugIn Ordner erstellen und die Dateien aus der Anlage einfügen (CHMOD 777 nicht vergessen)

    Nach Neustart des Pingu habt ihr ein neues PlugIn, mt dem Beide Emu per script gestartet werden.

    Wichtig beim Haarp: Im Emu Manager voher alle Softcams deaktivieren.

    Das Schript stammt aus dem EmuManager vom Neuprolux und wurde nur leicht angepasst. Ich suche jetzt nur noch die Möglichkeit das PlugIn bei Start der Box automatisch ausführen zu lassen.....ohne das die Box sich verabschiedet.

    VG
    mar72der

    Den Anhang 47502 betrachten
     
    #8
    tamabi, Pilot und Blasser gefällt das.
  10. newbie110
    Offline

    newbie110 Ist oft hier

    Registriert:
    27. Dezember 2010
    Beiträge:
    127
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    AW: Haarp + oscam + mgcamd -> Booteinstellungen?

    Danke! Sehr gut
     
    #9
  11. tamabi
    Offline

    tamabi Freak

    Registriert:
    30. November 2008
    Beiträge:
    235
    Zustimmungen:
    60
    Punkte für Erfolge:
    0
    AW: Haarp + oscam + mgcamd -> Booteinstellungen?

    Sehr gut, aber warum möchtest Du die OSCAM und die MGCAMD starten? Wofür brauchst Du das? Was hast Du damit vor?
    Ich würde verstehen wenn Du die Oscam und die Camd3 starten möchtest, weil dann brauchst Du nicht die OscamYmod zu nehmen um Austria zu erhellen. Dann könnte man die Camd Keys verwenden. Achso, und Frezzer mit der V13 intern kann ich nicht bestätigen, also nicht wenn die Oscam richtig konfiguriert ist.
    Und dass könnte dann so aussehen:

    /var/emu/camd3.902 /var/keys/camd3.config >/dev/null &
    sleep 5
    /var/emu/oscam -c /var/keys>/dev/null &

    Achso, das Thema müsste dann auch "Haarp+oscamymod+mgcamd->Booteinstellung?" heißen ;-)
     
    Zuletzt bearbeitet: 10. Oktober 2012
    #10

Diese Seite empfehlen