1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

FritzBox7141 für HD+ mit nonstick-Image + Easymouse2 + Oscam + acamd - Probleme

Dieses Thema im Forum "Fritzbox Archiv" wurde erstellt von humaxdsl, 22. Juli 2011.

  1. humaxdsl
    Offline

    humaxdsl Ist oft hier

    Registriert:
    8. Mai 2011
    Beiträge:
    187
    Zustimmungen:
    9
    Punkte für Erfolge:
    18
    Hallo zusammen,
    bin noch neu im Home-Sharing-Bereich und brauche trotz langer Recherche hier im Forum nun doch mal eure Hilfe. Ich habe eine 7141 für lau und günstig eine easymouse2 bekommen. Wollte mir das Geld für Stick und Hub sparen und habe daher erstmal mit einem nonstick-image experimentiert, um zunächst nur hd+ ans laufen zu bekommen.
    Fritz-Box 7141 ist gefreetz (cs_server_7141_7170_04.80freetz-devel.de_20110602-172238.image) und oscam (oscam-svn5475-mips-freet) über die Funktion OSCAM-Binary eingespielt. Die Easymouse2 (alle Schalter unten) hängt mit der HD+Karte (bereits aktiviert, Typ HD02, Chip nach unten in Easymouse) direkt am USB-Port der FritzBox. Hier stellt sich auch schon die erste Frage. Die FritzBox erkennt den Reader nicht als USB-Gerät. Muss sie dass nicht, damit OScam sie ansprechen kann?
    In den Einstellungen von OScam habe ich zudem „USB-Comport aktivieren "angehakt" und bei Modul "PL 2303" gewählt. OScam selbst habe ich anhand der hier geposteten Musterkonfiguration für die HD02-Karte konfiguriert. Nachfolgend nun meine angepasste Konfiguration mit und die entsprechenden Fragen dazu.
    PHP:
    [global]
    nice                 = -1
    WaitForCards        
    1
    ClientTimeout       
    10
    LogFile             
    = /flash/freetz/logs/oscam.log
    maxlogsize          
    2000
    Level               
    15
    CacheDelay          
    120
    PreferLocalCards    
    1
    FallbackTimeout     
    2
    Sleep               
    0
    saveinithistory     
    1

    [webif]
    httpport            84
    httprefresh         
    10
    httpallowed         
    192.168.0.0-192.168.255.255
    httphideidleclients 
    1
    httpreadonly        
    0

    [newcamd]
    key = 0102030405060708091011121314
    # HD+ - NewCamd-Port
    port 34000@1843:003411
    Da ich ja keinen USB-Stick angeschlossen habe, muss ich den Pfad ja entsprechend anpassen. Stimmt der den so?
    Wie komme ich an die Log-Datei von OScam? Die liegt ja jetzt direkt auf dem internen Speicher der FritzBox, oder? Ohne Log-Datei kann ich ja sonst nicht nach möglichen Fehlern suchen. Oder reicht das im im freetz dargestellte log aus?

    Die Oscam.server sieht wie folgt aus:

    PHP:
    -------------------------------------------------------------------------------------
    # HD+ HD-02
    -------------------------------------------------------------------------------------
    [
    reader]
    label                         HD-Plus
    device                        
    = /dev/ttyUSB0
    Protocol                      
    mouse
    detect                        
    cd
    enable                        
    1
    #smargopatch                   = 1
    services                      HD-Plus-HD-02
    CAID                          
    1843
    ident                         
    1843:003411
    emmcache                      
    1,3,2
    group                         
    1
    mhz                           
    368
    cardmhz                       
    368
    rsakey                     
    BF35XXD5
    boxkey                     
    A7XX7C
    -----------------------------------------------------------------
    Stimmt der Pfad für meine Easymouse2 so?

    Die oscam.user, oscam.services und oscam.provid habe ich unverändert (passwort und username natürlich angepasst) aus der Musterkonfiguration übernommen. Was ist eigentlich mit übrigen Konfigurationdateien z.B. der oscam.ird? Da steht bei mir bis jetzt natürlich nichts drin.

    Wenn ich OSCam im Freetz WebIF starte zeigt es folgendes LOG:
    PHP:
    mknod: /dev/ttyUSB0File exists 
    mknod
    : /dev/ttyUSB1File exists 
    mknod
    : /dev/ttyUSB2File exists 
    Starte OSCam 
    ... USB-Serial Module geladen Configs erstellt OSCam gestartet
    Sieht doch eigentlich gut aus, oder?

    Starte ich OSCam im Freetz WebIF allerdings neu, sieht das Log etwas anders aus.

    PHP:
    killallcan't kill pid 3147: No such process mknod: /dev/ttyUSB0: File  exists mknod: /dev/ttyUSB1: File exists mknod: /dev/ttyUSB2: File exists  Beende OSCam ... USB-Serial Module entladen, falls nicht blockiert  Starte OSCam ... USB-Serial Module geladen Configs erstellt OSCam  gestarte
    Hinzu kommt, dass die Lampen des Readers nur kurz leuchten, wenn die Box startet. Ist das OK so?

    Soweit zu OScam. Bin mal davon ausgegangen, dass ich alles richtig gemacht habe [​IMG]

    Ich möchte zunächst mal DVB-Viewer (neueste Version) auf einem der PC (Win7) als ersten Client anbinden und habe daher Ascam (version 0.6.2.0) im Plugin-Order. Die cardclient.conf sieht wie folgt aus
    PHP:
    newcamd:<IP.meiner.Fritz.Box>:34000:1/1843/003411:username:passwort:0102030405060708091011121314

    Die smartcard.conf ist momentan leer und die ACamd_PMT.txt sieht wie folgt aus:
    PHP:
    I:04:0D05:00000000:ORF # Ignore, because ORF via EMU

    Habe bei Acamd "Cardreader Com1" auf enable gesetzt. OK?


    Hier nun das Protokoll von Acamd:


    PHP:
    23:40:14.662ACamd v0.6.2.0
    23
    :40:15.316FFdecsa mode...
    23:40:15.316systemsregistering CA system Cardclientpri -15ident 1000
    23
    :40:15.316structloadersregistering loader cardclient config
    23
    :40:15.316cardclientsregistering cardclient Newcamd
    23
    :40:15.316cardclientsregistering cardclient Newcamd2
    23
    :40:15.316cardclientsregistering cardclient CCcamN
    23
    :40:15.316cardclientsregistering cardclient Radegast
    23
    :40:15.316cardclientsregistering cardclient Camd35
    23
    :40:15.316structloadersregistering loader smartcard data
    23
    :40:15.316systemsregistering CA system SC-Irdetopri -10ident 1001
    23
    :40:15.316featureusing feature SMARTCARD
    23
    :40:15.316registering Irdeto smartcard (id 49726474)
    23:40:15.316systemsregistering CA system SC-Secapri -10ident 1002
    23
    :40:15.316registering Seca smartcard (id 53656361)
    23:40:15.316systemsregistering CA system SC-Viaccesspri -10ident 1003
    23
    :40:15.316registering Viaccess smartcard (id 56696173)
    23:40:15.316systemsregistering CA system SC-Conaxpri -10ident 1004
    23
    :40:15.316registering Conax smartcard (id 436f6e78)
    23:40:15.316systemsregistering CA system SC-Cryptoworkspri -10ident 1005
    23
    :40:15.316registering Cryptoworks smartcard (id 4372576f)
    23:40:15.316systemsregistering CA system SC-Nagrapri -10ident 1006
    23
    :40:15.316registering Nagra smartcard (id 4e616772)
    23:40:15.316systemsregistering CA system SC-NDSpri -10ident 1007
    23
    :40:15.316registering NDS smartcard (id 56694732)
    23:40:15.322Monitor listen on port 50493
    23
    :40:15.367I:IgnoreCAID 0D05 with Provider 00000000 for Conf 004 
    23
    :40:15.367B:BetatunnelCAID:1833 with Provider:00000000 to CAID:1702 with Provider:00000000
    23
    :40:15.367Engine [DVB Viewer Pro]
    23:40:15.367loading smartcard data from C:\Program Files\DVBViewer\Plugins\smartcard.conf
    23
    :40:15.368loaded 0 smartcard data from C:\Program Files\DVBViewer\Plugins\smartcard.conf
    23
    :40:15.368loading cardclient config from C:\Program Files\DVBViewer\Plugins\cardclient.conf
    23
    :40:15.368now using protocol version 525 (cdLen=8)
    23:40:15.368hostname=<192.168.178.2port=34000 emm=1 emmCaids 1843/3411
    23
    :40:15.368Newcamdusername=username password=passwort key=0102030405060708091011121314 providers=none
    23
    :40:15.368client 'Newcamd' ready
    23
    :40:15.368: ** registered systems:
    23:40:15.368: ** SC-NDS            (pri -10)
    23:40:15.368: ** SC-Nagra          (pri -10)
    23:40:15.368: ** SC-Cryptoworks    (pri -10)
    23:40:15.368: ** SC-Conax          (pri -10)
    23:40:15.368: ** SC-Viaccess       (pri -10)
    23:40:15.368: ** SC-Seca           (pri -10)
    23:40:15.368: ** SC-Irdeto         (pri -10)
    23:40:15.368: ** Cardclient        (pri -15)
    23:40:15.368COM1open serial port
    23
    :40:15.369COM1set serial options9600,SM_8O1
    23
    :40:15.369smartcardsadded serial port COM1 as port 0 (normal CDnormal RESETCLOCK 3571200)
    23:40:15.3690: new card inserted
    23
    :40:15.369COM1set serial options9600,SM_8O1
    23
    :40:15.3690reseting card
    23
    :40:17.119Trying Irdeto (T=14)
    23:40:17.119COM1set serial options5760,SM_8O1
    23
    :40:17.1190reseting card
    23
    :40:17.316
    23:40:17.316Ch600 ZDFinfokanal 
    23
    :40:17.316Programm crcD5BA3C1A
    23
    :40:17.318PMTACamd_PMT.txtsearchnot found PMT=0258 (AND SID=6D6B)
    23:40:17.3180x0258 0x6D6B 0x0000 0x00000000 0x0000 0x0000 11111110
    23
    :40:17.318: Exit, no channel dataposible no [PMT Scan] or [PMT not found]...
    23:40:18.8690reset/atr error
    23
    :40:18.8690can't initialise new card, ignoring port until card reinserted


    Da gibt es für mich wohl noch einiges anzupassen, oder?
    Viel Text, viele Bilder. Ich hoffe ich kann trotzdem auf eure Hilfe zählen. [​IMG]
     
    Zuletzt bearbeitet: 22. Juli 2011
    #1

Diese Seite empfehlen