1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst Fritz!Box 7170 XS TB 2.5 04.87 Oscam hängt beim starten der HD02

Dieses Thema im Forum "Fritzbox Talk" wurde erstellt von FiRuS, 26. September 2013.

  1. FiRuS
    Offline

    FiRuS Ist gelegentlich hier

    Registriert:
    5. Januar 2012
    Beiträge:
    46
    Zustimmungen:
    4
    Punkte für Erfolge:
    0
    Hi Leute,

    nach langer Zeit würde ich gerne mal wieder eure Hilfe in Anspruch nehmen. In Sachen freetz oscam usw. bin ich kein Newbie. Habe einige Jahre Erfahrungen damit. Also Materie ist kein Neuland. Trotzdem komm ich an einer Stelle nicht weiter.

    Ich hab meine 7170 nach 1,5 Jahren mal wieder auf einen neuen Stand gebracht.
    Dazu habe ich das XS TB 2.5 7170_04.87 genommen mit uSTOR Files TBflex 2.5-012 cs.

    Als Oscam läuft die v1.20 unstable r8786

    Soweit alles gut. Hab nen König Hub dran, zwei Smargos mit je HD02 und S02
    Smargos stehen beide auf Autoswitch, Normal, 0, 0

    Sky läuft perfekt. Alles sauber.
    Nur die HD02 bekomme ich nicht hin. Ich weiß nicht ob ich was übersehen habe, oder nen Denkfehler drin ist. Ich hab schon dutzende Konfigänderungen probiert, auch den Wechsel der Karten in den Smargos. Ich bekomms nicht hin.

    Zuerst einmal das oscam.log damit ihr seht wovon ich spreche. Die S02 habe ich zur besseren Fehlersuche erstmal auf "0" gesetzt.
    Das eigentliche Problem: Nach "HD_+ [smartreader] detect native nagra card" hängt sich die Oscam auf.

    Wäre Klasse wenn ihr mal drüber schaut und mir nen Tipp geben könnten.
    Tausend Dank

    FiRuS

    oscam.log
    -------------------------------------------------------------------------------
    >> OSCam << cardserver started at Thu Sep 26 12:42:15 2013
    -------------------------------------------------------------------------------
    2013/09/26 12:42:15 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build r8786 (mipsel-linux-uclibc-ssl-libusb)
    2013/09/26 12:42:15 0 s creating pidfile /tmp/.oscam/oscam.pid with pid 1812
    2013/09/26 12:42:16 0 s services reloaded: 0 services freed, 2 services loaded, rejected 0
    2013/09/26 12:42:16 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2013/09/26 12:42:16 0 s signal handling initialized
    2013/09/26 12:42:16 0 s 217 service-id's loaded in 38ms
    2013/09/26 12:42:16 0 s 217 tier-id's loaded
    2013/09/26 12:42:16 0 s 13 provid's loaded
    2013/09/26 12:42:16 0 s 22 lengths for caid guessing loaded
    2013/09/26 12:42:16 0 s monitor: initialized (fd=6, port=988)
    2013/09/26 12:42:16 0 s camd35: initialized (fd=7, port=13000)
    2013/09/26 12:42:16 0 s HD_+ [smartreader] creating thread for device Serial:Reader 48XXXXX
    2013/09/26 12:42:16 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2013/09/26 12:42:16 0 s waiting for local card init
    2013/09/26 12:42:16 674928 r HD_+ [smartreader] Using 0x01/0x82 as endpoint for smartreader hardware detection
    2013/09/26 12:42:16 681F58 h webif: decompressed 53329 bytes back into 153368 bytes
    2013/09/26 12:42:16 681F58 h HTTP Server running. ip=0.0.0.0 port=83
    2013/09/26 12:42:16 674928 r Found reader with serial Reader 48XXXXX at 001:005
    2013/09/26 12:42:16 674928 r Found smartreader device Serial:Reader 48XXXXX
    2013/09/26 12:42:16 674928 r HD_+ [smartreader] Reader initialized (device=Serial:Reader 48XXXXX, detect=cd, mhz=368, cardmhz=368)
    2013/09/26 12:42:17 674928 r HD_+ [smartreader] card detected
    2013/09/26 12:42:21 674928 r HD_+ [smartreader] ATR: 3F XX XX XX XX
    2013/09/26 12:42:21 674928 r HD_+ [smartreader] Init card protocol T1, FI=9, F=512, D=16, N=255
    2013/09/26 12:42:21 674928 r HD_+ [smartreader] Calculated work ETU is 8.70 us
    2013/09/26 12:42:21 674928 r HD_+ [smartreader] ATR Fsmax is: 5 MHz, clocking card to wanted user cardspeed of 3.69 MHz (specified in reader->mhz)
    2013/09/26 12:42:21 674928 r HD_+ [smartreader] Card responded ok for ifsd request of 160
    2013/09/26 12:42:22 674928 r HD_+ [smartreader] detect native nagra card
    Danach ist die Oscam Tot. WebIF geht nicht mehr und auch im Log kommt nichts mehr!


    oscam.conf
    [global]
    logfile = /var/log/oscam.log
    disablelog = 0
    disableuserfile = 0
    usrfileflag = 0
    clienttimeout = 5000
    fallbacktimeout = 2000
    clientmaxidle = 120
    cachedelay = 120
    bindwait = 120
    netprio = 0
    clientdyndns = 0
    resolvedelay = 30
    unlockparental = 0
    nice = -1
    serialreadertimeout = 1500
    maxlogsize = 1000
    waitforcards = 1
    preferlocalcards = 1
    saveinithistory = 1
    readerrestartseconds = 5

    [monitor]
    port = 988
    nocrypt = 192.168.0.0-192.168.255.255
    aulow = 120
    hideclient_to = 30
    monlevel = 1
    appendchaninfo = 0

    [webif]
    httpport = 83
    httpcss = /var/media/ftp/uStor01/service/oscam/style.css
    httprefresh = 10
    httpallowed = 192.168.0.0-192.168.255.255
    httphideidleclients = 1
    httpreadonly = 0

    [cs357x]
    port = 13000

    oscam.server
    [reader]
    label = Sky Deutschland
    enable = 0
    protocol = smartreader
    detect = CD
    device = Serial:Reader 17XXXXX
    services = Sky Deutschland
    group = 1
    CAID = 1702,1833
    mhz = 600
    cardmhz = 600
    emmcache = 1,3,2

    [reader]
    label = HD +
    enable = 1
    protocol = smartreader
    detect = CD
    device = Serial:Reader 48XXXXX
    services = HD +
    group = 1
    rsakey = BXXXXXXXXXX
    boxkey = AXXXXXXXXXXXXX
    CAID = 1843
    mhz = 368
    cardmhz = 368
    emmcache = 1,3,2
     
    Zuletzt bearbeitet: 26. September 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. Pomm
    Online

    Pomm Guest

    AW: Fritz!Box 7170 XS TB 2.5 04.87 Oscam hängt beim starten der HD02

    Hab das selbe Problem seitdem ich auf neue die neue Version XS 7170 XS TB 2.5 04.87 mit aktuellem Oscam gewechselt habe. Habe das Problem per "Handscript" gelöst, indem ich die Karten beim Neustart nicht im Kartenleser stecke, sondern erst später einfüge. Dann läuft der Server fehlerfrei. Keine saubere Lösung, aber funktioniert.
     
    #2
  4. FiRuS
    Offline

    FiRuS Ist gelegentlich hier

    Registriert:
    5. Januar 2012
    Beiträge:
    46
    Zustimmungen:
    4
    Punkte für Erfolge:
    0
    AW: Fritz!Box 7170 XS TB 2.5 04.87 Oscam hängt beim starten der HD02

    Hi Pomm.

    Hm okay. Gut das ich nicht ganz alleine bin, mit meinem Problem. Steht Oscam bei dir dann auch, beim starten der HD02 bei "detect native nagra card"?

    Wenn ich dich richtig verstehe ziehst du die Karten ab, startest die Box oder Oscam neu und steckst die Karten erst wieder rein, wenn Oscam läuft?

    THX
    FiRuS

    Vom iPhone gesendet
     
    #3
  5. Pomm
    Online

    Pomm Guest

    AW: Fritz!Box 7170 XS TB 2.5 04.87 Oscam hängt beim starten der HD02

    Bekomme die selbe Meldung, manchmal findet er nicht einmal den Kartenleser.
    und ja, ich entferne die Karten, startest die Box neu und steckst die Karten erst wieder rein, wenn Oscam läuft !
     
    #4
  6. FiRuS
    Offline

    FiRuS Ist gelegentlich hier

    Registriert:
    5. Januar 2012
    Beiträge:
    46
    Zustimmungen:
    4
    Punkte für Erfolge:
    0
    AW: Fritz!Box 7170 XS TB 2.5 04.87 Oscam hängt beim starten der HD02

    So mal gerade getestet.
    Das war es bei mir leider nicht, danke trotzdem

    Sobald ich die HD02 in den Smargo stecke, kommen noch 4-5 Log Zeilen (siehe oben) und dann als letztes detect nativ nagra card.
    Dann hängt sich Oscam auf. Da ich ja schon einige Oscam Versionen getestet habe, werd ich wohl doch mal das Image wechseln müssen.

    Zudem habe ich gerade gemerkt, dass nach ca 4-6 Std S02 ohne die HD02 ein "usb bulk write failed" auftritt.

    Oder gibts noch Tipps?
     
    #5
  7. Gismotro
    Offline

    Gismotro Moderator Digital Eliteboard Team

    Registriert:
    22. Februar 2012
    Beiträge:
    7.056
    Zustimmungen:
    4.010
    Punkte für Erfolge:
    113
    Ort:
    Freetztown
    AW: Fritz!Box 7170 XS TB 2.5 04.87 Oscam hängt beim starten der HD02

    Ich hab keine. Sorry.
     
    #6
  8. Gismotro
    Offline

    Gismotro Moderator Digital Eliteboard Team

    Registriert:
    22. Februar 2012
    Beiträge:
    7.056
    Zustimmungen:
    4.010
    Punkte für Erfolge:
    113
    Ort:
    Freetztown
    AW: Fritz!Box 7170 XS TB 2.5 04.87 Oscam hängt beim starten der HD02

    Sag mal, kommst Du in OSCAM-WebIF ?
     
    #7
  9. FiRuS
    Offline

    FiRuS Ist gelegentlich hier

    Registriert:
    5. Januar 2012
    Beiträge:
    46
    Zustimmungen:
    4
    Punkte für Erfolge:
    0
    Das Oscam WebIF läuft solange, wie ich die HD02 nicht gesteckt habe. Sobald ich die HD02 einstecke kommen noch ein paar Meldungen bis detect native nagra card und dann ist Schluss mit Oscam. WebIF ist dann tot. Freetz läuft noch, aber Oscam ist komplett hängen geblieben.

    Bei usb bulk write..... komm ich noch ins Oscam WebIF. Dan hilft kein Oscam neustart sondern nur nen Reboot. Dann läuft die S02 wieder.
    Aber HD02.... keine Chance.

    Werde wohl mal Easymouse 2 als Reader testen.
    THX

    So ich hab jetzt die Smargos durch Easymouse 2 getauscht.
    Aber es bleibt gleich. Ich versteh die Welt nicht mehr.
    Ich hab auch zum testen gerade eine andere HD02 eingesteckt.
    Die Karte wird erkannt. Ebenso wie in den Logs von mir oben.

    Aber nach detect native nagra card ist Schluss. Oscam hängt sich auf. Nur bei der HD02.

    Ich versteh das nicht. Hat jemand noch ne Idee, was ich machen kann.

    Hab auch schon nen anderen USb Port probiert. Auch den beiden Easymouse miteinander getauscht. Sky läuft 1A.
    Sobald ich die HD02 einstecke, ist Schluss.

    Hilfeeeee!!!!

    THX FiRuS

    Läuft!!!!

    Es muss an der Oscam Version gelegen haben. Sonst wüsste ich nicht. Ich habe zwar schon ein paar Oscams probiert, aber immer hat sich die Oscam aufgehangen. Hab ja die v 1.20 r8786 drauf gehabt.

    Nun probiere ich als Test mal die 1.20 8066 -> und siehe da. Es läuft.

    Jetzt hab ich noch ein paar Tuning fragen an die Profis. Wär cool wenn da noch jemand drüber schauen könnte.

    1.) Welches Oscam release könnt ihr empfehlen?
    2.) Für eine HD02, welche Werte sind für mhz und cardmhz am besten? 357/357 oder 357/368 oder 368/368? (Easymouse2)
    3.)Bei der HD02 und der S02 kommt im Log ein Warnung: Card returned error on setting ifsd value to 160 -> Kann ich die ignorieren? Find da im Netz nichts zu.
    4.) Brauche ich ecmwhitelidt für die HD02. Da ließt man ja solches und solches.

    Danke für eure Mühe

    THX
    FiRuS
     
    Zuletzt von einem Moderator bearbeitet: 28. September 2013
    #8
  10. FiRuS
    Offline

    FiRuS Ist gelegentlich hier

    Registriert:
    5. Januar 2012
    Beiträge:
    46
    Zustimmungen:
    4
    Punkte für Erfolge:
    0
    AW: Fritz!Box 7170 XS TB 2.5 04.87 Oscam hängt beim starten der HD02

    Weiter geht das Rätsel raten:
    Jetzt läuft es zwar. Aber im Schnitt nur 2-4 Stunden. Dann geht von einer Abfrage zur anderen die Zeit von 500ms auf 5700ms mit nem Timeout
    Dann hilft nur ein Neustart.
    Jemand ne Idee für ne Lösung?

    Hab bis auf den USB Hub und die 7170 schon alles getauscht.. :(
     
    #9

Diese Seite empfehlen