1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

freetz - oscam Fehler: usb bulk write failed : ret = -7

Dieses Thema im Forum "Fritzbox Archiv" wurde erstellt von negeos, 5. März 2011.

  1. negeos
    Offline

    negeos Ist oft hier

    Registriert:
    19. Januar 2011
    Beiträge:
    114
    Zustimmungen:
    22
    Punkte für Erfolge:
    18
    Ort:
    Hoch im Süden
    Hallo!

    Ich habe geplant, meinen CS von einer NAS auf eine Freetzbox zu wechseln, da ich auf der NAS nicht die aktuelle Version von cccam laufen lassen kann und oscam mindestens 1x pro Tag abschmiert. (naja und weil's mit fritzbox geht und ich's ausprobieren wollte)

    Nun hab ich freetz-devel-6575M auf der Fritze, cccam auf 2.2.1 aktualisiert und oscam auf 1.0.0-unstable_svn build #4788.

    Vorher hatte ich nur oscam im Gebrauch und wollte nun gerne parallel cccam und oscam laufen lassen (hab's bisher ned hinbekommen, die Sky-HD Sender unter oscam zu öffnen. Unter cccam ging's problemlos,... aber anderes Thema).

    Auf der Freetz will's leider auch nicht so, wie ich will: die P02-Karte läuft problemlos, die HD+ wird unter cccam nicht erkannt. Beide Karten sind ein einem Smargo. Unter oscam kommt die Fehlermeldung aus'm Betreff, die -so hab ich's gelesen- heisst, dass der Kernel des Images zu alt ist - bekannter bug wohl. Was kann ich denn jetzt tun, um beide Karten in der Freetz zu sharen?

    Den smargo für die hd+ hab ich schon in verschiedenen Einstellungen laufen lassen, der Reader wird erkannt, die Karte nicht :(

    Ich hoffe, mir kann da jemand weiterhelfen. Bin für jeden Tipp dankbar.

    Gruß
    negeos
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. märklin
    Offline

    märklin Guest

    AW: freetz - oscam Fehler: usb bulk write failed : ret = -7

    läuft den bei dir schon Chroot ?
    weil du die CCcam getauscht hast ?
    und wie sehen deine Konfigurationen aus
     
    #2
  4. negeos
    Offline

    negeos Ist oft hier

    Registriert:
    19. Januar 2011
    Beiträge:
    114
    Zustimmungen:
    22
    Punkte für Erfolge:
    18
    Ort:
    Hoch im Süden
    Hallo Prof.Linux

    Die chroot-Umgebung läuft. CCcam 2.2.1 wird auch gestartet und zeigt die P02 richtig, die NDS garnicht an.

    An den Configs habe ich erst einmal nur wenig gemacht um mögliche Fehlerquellen auszuschließen. Vielleicht ja zuviel rausgelassen?

    cccam.cfg:
    oscam.server:
    oscam.conf
    Code:
    [global]
    logfile = /var/media/ftp/uStor01/logs/oscam.log
    disablelog = 0
    disableuserfile = 0
    usrfileflag = 0
    clienttimeout = 5000
    fallbacktimeout = 2500
    clientmaxidle = 120
    cachedelay = 120
    bindwait = 120
    netprio = 0
    clientdyndns = 0
    resolvedelay = 30
    unlockparental = 0
    nice = -1
    serialreadertimeout = 1500
    maxlogsize = 2480
    waitforcards = 1
    preferlocalcards = 0
    saveinithistory = 1
    readerrestartseconds = 5
    resolvegethostbyname = 0
    
    [monitor]
    port = 988
    aulow = 120
    hideclient_to = 0
    monlevel = 4
    appendchaninfo = 1
    
    # protocols
    #[camd35]
    #Port = 3333
    
    [newcamd]
    key = 0102030405060708091011121314
    port = 34000@1830:003411
    keepalive = 1
    mgclient = 0
    
    [cccam]
    port                          = 12666
    reshare                       = 5
    ignorereshare                 = 1
    version                       = 2.1.4
    updateinterval                = 300
    minimizecards                 = 1
    
    [webif]
    httpport                      = 999
    httpcss                       = /var/media/ftp/uStor01//cs/oscam//proflinux_ddcstyle.css
    httprefresh                   = 10
    httpallowed                   = 127.0.0.1,192.168.177.1-192.168.178.255
    httphideidleclients           = 0
    httpreadonly                  = 0
    httpsavefullcfg               = 0
    Dass cccam in oscam und cccam.cfg den gleichen Port hat, liegt daran, dass ich derzeit nur teste. Also entweder cccam oder oscam gestartet hab.

    Zur chroot nochwas: Da ich gerade erst 'ne Woche mit der Freetz rumbastel, hab ich hier evtl. was falsch gemacht, obwohl's in den Howtos ja ausführlich steht:

    1. USB-Stick als ext2 formatiert (unter ubuntu, keinen Volumename vergeben)
    2. CHROOT.RootFS.Freetz.7170.sh raufkopiert und ausgeführt (Besonderheit: in der sh musste in jeder Zeile die Endemarke entfernt werden)
    3. per scp die Dateien aus der uStor01.rar (in der DEB_7170_04.80... enthalten) auf den Stick kopiert (so dass auf dem Stick die Ordnerstruktur cs,logs,tools,watchdog entsteht). cccam 2.2.1 läuft, oscam an sich auch.

    Unter tools finde ich ja auch das srptool.

    Ist es richtig, dass dieses Tool nur in der chroot-Umgebung funktioniert? Wenn ich es direkt in der login-shell starte kommt "./srptool: can't load library 'libstdc++.so.6'". In der chroot geht's, er zeigt mir die Werte vom Smargo an.
     
    #3
  5. negeos
    Offline

    negeos Ist oft hier

    Registriert:
    19. Januar 2011
    Beiträge:
    114
    Zustimmungen:
    22
    Punkte für Erfolge:
    18
    Ort:
    Hoch im Süden
    AW: freetz - oscam Fehler: usb bulk write failed : ret = -7

    *threadstups*
    Ist das usb-Problem denn bei sonst niemandem aufgetreten? Hab's bisher immer noch nicht hinbekommen :( Oder fehlen noch Infos meinerseits?

    Hier mal die Ausgangslage:
    Fritzbox 7170 (1und1)
    freetz-devel-6575M
    2x smargo V 1.3
    cccam auf 2.2.1
    oscam 1.0.0-unstable_svn build #4788
    Karten: P02 + NDS (TC)

    Gruß negeos
     
    #4
  6. märklin
    Offline

    märklin Guest

    AW: freetz - oscam Fehler: usb bulk write failed : ret = -7

    hi...habe noch NIX davon gehört das es mit Smargo 1.3 auf der Fritte funzt

    du mußt device = 001:011 über den USB zuordnen

    device = /dev/ttyUSB0
    device = /dev/ttyUSB1
    device = /dev/ttyUSB2

    usw.....wenn du das Überhaupt meinst :dfingers:
     
    #5
  7. negeos
    Offline

    negeos Ist oft hier

    Registriert:
    19. Januar 2011
    Beiträge:
    114
    Zustimmungen:
    22
    Punkte für Erfolge:
    18
    Ort:
    Hoch im Süden
    AW: freetz - oscam Fehler: usb bulk write failed : ret = -7

    Hi.

    Also wenn ich das USB-Deivce über /dev/ttyUSBX angebe, meckert oscam, dass das USB-Device im Format 000:000 angegeben werden muss ?!

    Hab gerade nochmal hier rumgesucht: Es haben doch einige Leute oscam mit smargo auf der Fritzbox laufen.

    Dann muss es doch irgendwie gehen. Evtl hab ich die falsche oscam-Version? Es muss ja eine mit smartreader-Unterstützung sein. Die genannten hab ich im 'oscam-forum' gefunden.

    Vielleicht könnt mir ja jemand eine mit Smargo an der Fritze funktionierende oscam linken?

    Dank und Gruß
    negeos
     
    #6
  8. Superhansi
    Offline

    Superhansi Spezialist

    Registriert:
    26. Februar 2008
    Beiträge:
    666
    Zustimmungen:
    505
    Punkte für Erfolge:
    0
    Ort:
    mittendrin
    AW: freetz - oscam Fehler: usb bulk write failed : ret = -7

    Es ist schon so wie prof.linux gesagt hat, ein smargo mit Firmware 1.03 funzt nicht im smartreader-Protokoll.
    Da mußt du als Protokoll "mouse" nehmen und "smargopatch = 1" setzen.
    Hierbei brauchst du kein OScam mit smartreader-Unterstützung.
    So hatte ich meine smargos auch am laufen (7170).

    OScam mit smartreader-Unterstützung braucht du wenn den smargo mit smartreader-Protokoll laufen lassen willst.
    Dann muß die Firmware vom smargo min. 1.04 sein.
    "device_out_endpoint = 0x82" ist nur für smartreader-Protokoll, dann muß "smargopatch = 1" raus.

    Für eine der beiden Varianten mußt du dich entscheiden, du kannst nicht einfach alles in die oscam.server reinschreiben und hoffen, daß das richtige genommen wird.

    Wobei ich bis jetzt noch nicht gehört habe, daß auf einer 7170 das smartreader-Protokoll funzt.
    Auf einer 7170 ist der Linux-Kernel 2.6.13 und der hat, soviel ich weiß, keine smartreader-Unterstützung.
    Wenn es bei jemanden funzt kann er sich ja melden.

    Mit diesem Reader hat mein smargo (1.03) die HD+ gelesen:
    [reader]
    label = 1_smargo
    enable = 1
    protocol = mouse
    device = /dev/ttyUSB0
    services = hdplus
    smargopatch = 1
    fallback = 1
    caid = 1830
    rsakey = BF35......DD5
    boxkey = A76...37C
    detect = cd
    mhz = 358
    cardmhz = 358
    ident = 1830:000000,003411,008011
    group = 2
    emmcache = 1,3,0
    lb_weight = 100
    smargo: fixed 3,68 normal ....weiteres weiß ich nicht mehr.

    Bin froh die smargos endlich los zu sein und ordentliche Reader (Apollo) zu haben.


    Gruß Superhansi
     
    #7
    negeos gefällt das.
  9. negeos
    Offline

    negeos Ist oft hier

    Registriert:
    19. Januar 2011
    Beiträge:
    114
    Zustimmungen:
    22
    Punkte für Erfolge:
    18
    Ort:
    Hoch im Süden
    Vielen Dank für die Infos, Superhansi.

    Bin jetzt schon etwas weiter. Mit den von Dir genannten Einstellungen kommt bei der NDS-Karte zumindest ein ATR, allerdings dann "unsupported card". Bei der P02 schaut's änlich aus, TEL, S/N etc wird angezeigt, allerdings keine CHIDs ausgelesen => "unsupported card".

    Liegt das jetzt nur am Smargo? An der NAS funktionierten die Smargos ohne Probs (Allerdings konnte ich da die aktuellste cccam nicht installieren, deshalb der Versuch mit freetz). cccam2.2.1 zeigt mit den Einstellungen die P02 korrekt an. Leider die NDS (TC) nicht. Habe auch schon die Freetz-Version aktualisiert (freetz-devel-6655M ist nu drauf).

    Wenn ich das in den Threads richtig verfolgt habe, kann's nu am Smargo liegen (weil die einfach xx sind) oder auch am USB-Hub. Hab da irgendein NT angeschlossen. Das original scheint in den Tiefen der Technik-Kiste verschollen zu sein :JC_hmmm: Ist das soweit richtig?

    Oder kann's auch noch andere Ursachen geben? Ansonsten würd ich mich halt mal nach Apollo-Readern umschauen.

    Dank und Gruß
    negeos
     
    #8
  10. märklin
    Offline

    märklin Guest

    AW: freetz - oscam Fehler: usb bulk write failed : ret = -7

    Versuch mal smargo bei der 7170

    auto
    dream
    1
    0
     
    #9
  11. Superhansi
    Offline

    Superhansi Spezialist

    Registriert:
    26. Februar 2008
    Beiträge:
    666
    Zustimmungen:
    505
    Punkte für Erfolge:
    0
    Ort:
    mittendrin
    AW: freetz - oscam Fehler: usb bulk write failed : ret = -7

    Ich weiß nicht ob es wirklich zu 100% an deinem smargo liegt. Wenn man sich mal im Board umschaut hat es bei vielen Usern geholfen sich einen andernen Reader zu kaufen.
    Es gibt aber auch User bei denen der smargo bestens funzt.
    Teste einfach mal die ganzen smargo-Einstellungen durch.
    Wenn du das Risiko eingehen willst, kannst du den smargo auch auf 1.05 updaten (siehe Datenbase).
    Viele User berichten, daß es mit der 1.05 besser läuft. Das update ist nicht offiziell und soll schon smargo's (fake) zerstört haben.
    Am besten läuft der smargo scheinbar im smartreader-Modus.

    Apollo-Reader gibts bei OB-Elektronik, ist der Web-shop von Apollo.
    Die laufen aber, soviel ich, weiß nicht mit CCcam.
    Oder probier mal ne Easymouse2.

    Ich habe gerade gesehen, du nutzt eine ziemlich neue OScam-Version.
    Mit den neuen Versionen, über svn4746, sind verstärkt Probleme aufgetreten.
    Probier mal eine bis svn4746 aus.


    Gruß Superhansi
     
    #10
    westost und negeos gefällt das.
  12. negeos
    Offline

    negeos Ist oft hier

    Registriert:
    19. Januar 2011
    Beiträge:
    114
    Zustimmungen:
    22
    Punkte für Erfolge:
    18
    Ort:
    Hoch im Süden
    AW: freetz - oscam Fehler: usb bulk write failed : ret = -7

    Danke @Superhansi und Prof.Linux.
    Das werde ich heut abend mal versuchen. Jetzt habe ich erstmal nur cccam auf der freetz laufen und 'ne N-Line zum alten oscam. Auf jeden Fall läuft cccam stabiler, als die oscam auf der NAS. Sobald ich eure Hinweise umgesetzt habe, melde ich mich...

    Hab das Gefühl, dass es dank eurer Hilfe endlich laufen wird, wie es soll .-)

    Gruß
     
    #11
  13. mapelt
    Offline

    mapelt Newbie

    Registriert:
    7. März 2011
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Der USB Fernanschluss darf nicht aktiv sein für "Andere (z.B. Scanner)" Geräte. Ich habe ewig gesucht warum der SMARGO erkannt wird, aber die Karte nicht antwortet.
     
    #12
  14. ramazotti
    Offline

    ramazotti VIP

    Registriert:
    30. Januar 2010
    Beiträge:
    700
    Zustimmungen:
    227
    Punkte für Erfolge:
    0
    Beruf:
    IT-Admnistrator
    Ort:
    OSTDEUTSCHLAND
    AW: freetz - oscam Fehler: usb bulk write failed : ret = -7

    änder in der oscam.server in DIESE

    X anpassen !!!
     
    #13
  15. negeos
    Offline

    negeos Ist oft hier

    Registriert:
    19. Januar 2011
    Beiträge:
    114
    Zustimmungen:
    22
    Punkte für Erfolge:
    18
    Ort:
    Hoch im Süden
    AW: freetz - oscam Fehler: usb bulk write failed : ret = -7

    Sodele,

    hab am Wochenende nochmal alle Einstellungen überprüft, am Smargo diverse Einstellungen ausprobiert. Die Fritzbox war auch richtig eingestellt (USB Fernanschluss aus) Leider alles ohne Erfolg. Die 1.4er und 1.5er Firmware hab ich auch probiert. Auch mit der 1.5er FW erkennt der Smargo die NDS-Karte nicht. Zurück in der NAS wird die Karte mit gleichem Smargo sofort erkannt, naja, zumindest halbwegs.
    kA, ob das wichtig ist, aber auch wenn es läuft, wird als Basisjahr 1997 und als Typ "VideoGuard Unknown Card" angezeigt.

    Ein zumindest langer ATR wurde mal abgesendet. Zwischendurch auch mal nur 3 byte, dann wieder richtig. Es kommt dann (sinngemäß) Error reading card, Unknown card, falling back to deprecated mode, error reading card, failed to initialize card. Das war's dann. Karte raus und rein, dann geht's wieder von vorne los.

    Ach: Auf der NAS läuft die oscam 1.00-svn #3466. @Superhansi: Das werde ich noch probieren. Eine ältere Version hatte ich noch nicht versucht. Werde dann wieder hier Rückmeldung geben.

    Gruß und Danke @all
    negeos
     
    #14

Diese Seite empfehlen