1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst Freetz Easymouse /dev/ttyUSB0 wird nicht erkannt [FB 7320]

Dieses Thema im Forum "Fritzbox Talk" wurde erstellt von michael861, 30. März 2013.

  1. michael861
    Offline

    michael861 Freak

    Registriert:
    3. Februar 2010
    Beiträge:
    235
    Zustimmungen:
    44
    Punkte für Erfolge:
    28
    Ort:
    daheim
    Hallo!

    Habe eine Fritz!Box 7320 mit diesen Eigenschaften:
    Code:
    Freetz: freetz-devel-10302M
    Toolbox: 2.5
    Oscam:

    Code:
    [SIZE=2][FONT=arial]OSCAM 1.20-unstable_svn build r8557
    Reader: e[SIZE=2]asymouse2
    [/SIZE][/FONT][/SIZE]



    USB-Anschlüsse:
    An der Rückseite ist der USB-Stick angeschlossen.
    An der Seite ist die Easymouse2 mit einer HD+ (weiß) angeschlossen.

    Wenn die Oscam startet, dann findet Sie den Reader nicht.

    Readerconfig:
    Code:
    [reader]
    label = easymouse_hdplus
    enable = 1
    protocol = mouse
    device = /dev/ttyUSB0 #hab auch schon /dev/ttyUSB1 ausprobiert
    services = hdplus
    caid = 1830
    rsakey = B**5
    boxkey = A**C
    ecmwhitelist = 1830:92
    detect = cd
    mhz = 368
    cardmhz = 368
    group = 1
    emmcache = 1,3,2
    lb_weight = 30[SIZE=2][FONT=arial][SIZE=2][/[SIZE=2]code][/SIZE][/SIZE][/FONT][/SIZE]


    Fehlermeldung in der Oscam:
    [code]
    1970/01/01 01:01:18 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build r8557 (mips-linux-uclibc-ssl-libusb-static)
    1970/01/01 01:01:18 0 s creating pidfile /tmp/.oscam/oscam.pid with pid 2938
    1970/01/01 01:01:18 0 s The current system time is smaller than the build date (Mar 16 2013). Waiting up to 60 seconds for time to correct
    2013/03/30 16:15:20 0 s services reloaded: 0 services freed, 3 services loaded, rejected 0
    2013/03/30 16:15:20 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2013/03/30 16:15:20 0 s signal handling initialized
    2013/03/30 16:15:20 0 s 116 service-id's loaded in 16ms
    2013/03/30 16:15:20 0 s 116 tier-id's loaded
    2013/03/30 16:15:20 0 s 3 provid's loaded
    2013/03/30 16:15:20 0 s 22 lengths for caid guessing loaded
    2013/03/30 16:15:20 0 s monitor: initialized (fd=5, port=988)
    2013/03/30 16:15:20 0 s cccam: initialized (fd=6, port=40000)
    2013/03/30 16:15:20 0 s easymouse_hdplus [mouse] creating thread for device /dev/ttyUSB0
    2013/03/30 16:15:20 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2013/03/30 16:15:20 0 s waiting for local card init
    2013/03/30 16:15:20 4E3EA8 h webif: decompressed 52670 bytes back into 150580 bytes
    2013/03/30 16:15:20 4E3EA8 h HTTP Server listening on port 16001
    2013/03/30 16:15:20 4DA110 r easymouse_hdplus [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=6 No such device or address)
    2013/03/30 16:15:20 4DA110 r easymouse_hdplus [mouse] Cannot open device: /dev/ttyUSB0[/code]
    Was mache ich falsch?

    Danke schon mal!

    Gruß Michael861

     
    Zuletzt von einem Moderator bearbeitet: 30. März 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. Gazor
    Offline

    Gazor Ist oft hier

    Registriert:
    16. August 2012
    Beiträge:
    182
    Zustimmungen:
    98
    Punkte für Erfolge:
    0
    AW: Freetz Easymouse /dev/ttyUSB0 wird nicht erkannt [FB 7320]

    Hast Du den FTDI-Treiber aktiviert?
     
    #2
  4. michael861
    Offline

    michael861 Freak

    Registriert:
    3. Februar 2010
    Beiträge:
    235
    Zustimmungen:
    44
    Punkte für Erfolge:
    28
    Ort:
    daheim
    AW: Freetz Easymouse /dev/ttyUSB0 wird nicht erkannt [FB 7320]

    Hallo!

    So, das wars, der FTDI-Treiber war nicht aktiviert.
    Problem 1 gelöst.
    Diese Lösung hat nun Problem 2 ersichtlich gemacht :-(

    Und zwar "not fund".
    Ich habe den Reader mit den oben gennanten configs hinterlegt.
    Hab sowohl mit 368 mhz, als auch mit 600 mhz getestet (dies natürlich auch am Reader geändert und die Box neu gestartet).
    Die Karte wird ganz normal eingelesen, jedoch bei Senderzugriff "not found".
    Was mache ich falsch?

    Reader ist die Easymouse2 (ohne Gehäuse), und angeschlossen ist sie via USB an der FB
    Client ist via Oscam (cccam) dran.

    Irgendwas mache ich falsch, nur was?

    Danke schon mal für eure Hilfe und frohe Ostern!

    Gruß Michael861
     
    #3
  5. Gazor
    Offline

    Gazor Ist oft hier

    Registriert:
    16. August 2012
    Beiträge:
    182
    Zustimmungen:
    98
    Punkte für Erfolge:
    0
    AW: Freetz Easymouse /dev/ttyUSB0 wird nicht erkannt [FB 7320]

    Hast Du auch die oscam.services im config-Ordner angepasst?
     
    #4
  6. michael861
    Offline

    michael861 Freak

    Registriert:
    3. Februar 2010
    Beiträge:
    235
    Zustimmungen:
    44
    Punkte für Erfolge:
    28
    Ort:
    daheim
    AW: Freetz Easymouse /dev/ttyUSB0 wird nicht erkannt [FB 7320]

    Hallo!

    die "Services" ist jetzt auch gepflegt, die Anfrage kommt durch "1830:xxxx...", jedoch mit der Antwort "not found"

    Hier nochmal die Oscam.server:
    [reader]
    label = easymouse_hdplus
    protocol = mouse
    device = /dev/ttyUSB0
    caid = 1830
    boxkey = A...C
    rsakey = B...5
    ecmwhitelist = 1830:92
    detect = cd
    mhz = 368
    cardmhz = 368
    group = 1
    emmcache = 1,3,2
    #lb_weight = 30

    Danke nochmal!

    Gruß Michael861
     
    Zuletzt von einem Moderator bearbeitet: 1. April 2013
    #5
  7. fun7
    Offline

    fun7 Super Elite User Supporter

    Registriert:
    13. März 2013
    Beiträge:
    2.913
    Zustimmungen:
    1.805
    Punkte für Erfolge:
    113
    AW: Freetz Easymouse /dev/ttyUSB0 wird nicht erkannt [FB 7320]

    Karte updaten!
     
    #6
  8. michael861
    Offline

    michael861 Freak

    Registriert:
    3. Februar 2010
    Beiträge:
    235
    Zustimmungen:
    44
    Punkte für Erfolge:
    28
    Ort:
    daheim
    AW: Freetz Easymouse /dev/ttyUSB0 wird nicht erkannt [FB 7320]

    Hallo!

    Danke, und wie? Alle clients haben oscam.
    Was muss ich umstellen?
     
    #7
  9. Gazor
    Offline

    Gazor Ist oft hier

    Registriert:
    16. August 2012
    Beiträge:
    182
    Zustimmungen:
    98
    Punkte für Erfolge:
    0
    AW: Freetz Easymouse /dev/ttyUSB0 wird nicht erkannt [FB 7320]

    Poste mal Deine configs vom server bzw. eines clients.
     
    #8
  10. michael861
    Offline

    michael861 Freak

    Registriert:
    3. Februar 2010
    Beiträge:
    235
    Zustimmungen:
    44
    Punkte für Erfolge:
    28
    Ort:
    daheim
    Hallo!

    Ok, dann fange ich mal an.

    Vielleicht noch ein paar Worte zu meiner Server-Konstellation:
    Server 1:
    Fritzbox 7270 v2 mit König-Hub (passiv) und zwei Easymouse2-Readern (1x S02 und 1x ORF-ICE).
    Läuft stabil, weshalb ich einen Server 2 aufbauen will, an dem die HD01-Karte läuft
    Server 2:
    Fritzbox 7320 (dient u.a. noch als Repeater). USB hinten USB-Stick USB Seite Easymouse2-Reader mit Hd01 (weiß).
    Diese Karte ist schon mal gelaufen, etwa 2 Monate...

    Client 1 (der soll Updates machen, ist meine Box...):
    Octagon 1008 mit E2 und "Don't cry" Image. Oscam läuft und ORF und Sk* laufen.

    So, hier die Configs:

    Oscam.config (Server1)
    [global]
    logfile = /var/media/ftp/FREETZ_USB/logs/oscam.log
    disablelog = 0
    disableuserfile = 0
    usrfileflag = 0
    clienttimeout = 5000
    fallbacktimeout = 2000
    clientmaxidle = 120
    cachedelay = 120
    bindwait = 120
    netprio = 0
    clientdyndns = 0
    resolvedelay = 30
    unlockparental = 0
    nice = -1
    serialreadertimeout = 1500
    maxlogsize = 1000
    waitforcards = 1
    preferlocalcards = 1
    saveinithistory = 1
    readerrestartseconds = 5
    readerautoloadbalance = 0
    readerautoloadbalance/save = 0

    [monitor]
    port = 988
    nocrypt = 192.168.0.0-192.168.255.255
    aulow = 120
    hideclient/to = 30
    monlevel = 1
    appendchaninfo = 0

    [cccam]
    port = 40000
    reshare = 2
    version = 2.2.1
    updateinterval = 0

    [webif]
    httpport = 16001
    httphelplang = de
    httpuser = admin
    httppwd = passwort
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255
    #httpcss = /var/media/ftp/FREETZ_USB/service/oscam/style.css
    #httprefresh = 10
    #httphideidleclients = 1
    #httpreadonly = 0

    Oscam.server (Server1):
    [reader]
    label = easymouse_skyde
    protocol = mouse
    device = /dev/ttyUSB0
    caid = 1702,1833
    boxkey = 1...8
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 1
    emmcache = 1,3,2
    blockemm-unknown = 1
    lb_mode = 0

    [reader]
    label = easymouse_orf
    protocol = mouse
    device = /dev/ttyUSB1
    caid = 0D95
    ecmwhitelist = 0D95@000004:B8,F0
    detect = cd
    mhz = 368
    cardmhz = 368
    group = 2
    emmcache = 1,3,2
    blockemm-unknown = 1

    [reader]
    label = easymouse_hdplus_remote
    protocol = cccam
    device = 192.168.1.1xx,40000 #IP-Adresse ist schon richtig...
    user = hdplususer
    password = hdpluspwd
    group = 3
    caid = 1830,1843

    Oscam.user (Server1)
    [account]
    user = user
    pwd = passwort
    hostname = 192.168.1.116
    uniq = 1
    au = easymouse_skyde,easymouse_hdplus_remote
    betatunnel = 1833.FFFF:1702
    group = 1,2,3

    Oscam.config (Server2)=>der mit der HD01
    [global]
    logfile = /var/media/ftp/FREETZ_USB/logs/oscam.log
    disablelog = 0
    disableuserfile = 0
    usrfileflag = 0
    clienttimeout = 5000
    fallbacktimeout = 2000
    clientmaxidle = 120
    cachedelay = 120
    bindwait = 120
    netprio = 0
    clientdyndns = 0
    resolvedelay = 30
    unlockparental = 0
    nice = -1
    serialreadertimeout = 1500
    maxlogsize = 1000
    waitforcards = 1
    preferlocalcards = 1
    saveinithistory = 1
    readerrestartseconds = 5
    readerautoloadbalance = 0
    readerautoloadbalance/save = 0

    [monitor]
    port = 988
    nocrypt = 192.168.0.0-192.168.255.255
    aulow = 120
    hideclient/to = 30
    monlevel = 1
    appendchaninfo = 0

    [cccam]
    port = 40000
    reshare = 2
    version = 2.2.1
    updateinterval = 0

    [webif]
    httpport = 16001
    httphelplang = de
    httpuser = admin
    httppwd = passwort
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255
    #httpcss = /var/media/ftp/FREETZ_USB/service/oscam/style.css
    #httprefresh = 10
    #httphideidleclients = 1
    #httpreadonly = 0

    Oscam.server (Server2)
    [reader]
    label = easymouse_hdplus
    protocol = mouse
    device = /dev/ttyUSB0
    caid = 1830
    boxkey = A...C
    rsakey = B...5
    ecmwhitelist = 1830:92
    detect = cd
    mhz = 368
    cardmhz = 368
    group = 1
    emmcache = 1,3,2
    #lb_weight = 30

    Oscam.user (Server2)
    [account]
    user = hdplususer
    pwd = hdpluspwd
    #hostname = 192.168.1.1xx #will ich später einschalten, damit nur Server1 auf den Remote zugreifen kann...
    uniq = 1
    au = easymouse_hdplus
    group = 1

    Oscam.config (User1)=> der via Server1 u.A. auch die HD01-Karte erhalten soll
    [global]
    Nice = -1
    ClientTimeout = 7
    FallbackTimeout=3
    ClientMaxIdle=120
    CacheDelay = 120
    BindWait = 5
    WaitForCards = 0
    PreferLocalCards = 1
    LogFile = stdout
    saveinithistory = 1
    readerrestartseconds = 5
    maxlogsize = 200

    [monitor]
    nocrypt = 127.0.0.1,192.168.0.0-192.168.255.255
    appendchaninfo = 1

    [dvbapi]
    enabled = 1
    au = 1
    boxtype = ufs910
    user = dvbapi
    pmt_mode = 0
    ###### for E2 set pmt_mode = 0 ###########
    ###### for Titan set pmt_mode = 4 ###########


    [webif]
    httpport = 16001
    httphelplang = de
    httpuser = admin
    httppwd = passwort
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255

    Oscam.server (User1)
    [reader]
    label = cccam-reader
    protocol = cccam
    device = 192.168.1.1xx,40000
    user = user
    password = passwort
    caid = 1702,0D95,1833,1830
    group = 1
    emmcache = 1,1,2
    cccversion = 2.0.11
    cccmaxhops = 5
    auprovid = 000004

    Oscam.user (User1)
    [account]
    user = dvbapi
    pwd = dvbapi
    au = 1
    betatunnel = 1833.FFFF:1702
    group = 1

    Hoffe das sind alle nötigen Infos.

    Jetzt noch ein paar Fragen:
    -Was muss ich tun, damit die Oscam nach einer erfolglosen Anfrage nicht gleich aufgibt, sondern AU's schickt?
    -Wie bringe ich die Oscam dazu, dass die Anfragen richtig adressiert werden?
    ->Teilweise kommt es vor, dass zuerst die S02 und dann die HD01 bzw. ORF-ICE angefragt wird...

    Vielen Dank für eure Hilfe!

    Gruß Michael861

    @edit:

    Hab jetzt zusätzlich die "Oscam.services" überarbeitet (sowohl auf Server1, Server2 als auch User1):
    #services

    [sky_de]
    caid = 1702,1833
    provid = 000000
    srvid = 0025,2EFE,4461,4462,000C,000D,000E,0010,0013,0015,0016,0017,0018,001A,001B,001C,001D,00F1,0022,0024,002A,0032,0034,00A8,0206,0077,0072,006A,006B,006F,0070,0071,0081,0082,0083,0084,0076,007C,006C,0074,0069,6FB8,007B,007D,006E,007E,007F,0021,0023,0025,0026,0027,0037,0038,0039,003A,07FF,2EFE,3335,4461,4462,6FF1,7001,700A,0008,0009,000A,000B,0014,0019,0029,002B,0203,0204,006A,006B,006E,006F,0083,001E,0035,00DD,00DE,00F1,00FD,0107,0111,011B,0125,012F,0139,0143,014D,016B,0175,00DF,00FC,0106,0110,011A,0124,012E,0138,0142,014C,0156,0160,0069,0072,0077,007A,0081,006C

    [hd_plus]
    caid = 1830
    provid = 000000
    srvid = 1519,277E,5273,5274,EF10,EF11,EF14,EF15,EF74,EF75,EF76,EF77,2E9B,151A,157F

    [orf_ice]
    caid = 0D95
    provid = 000004
    srvid = 132F,1330,32C9,32CA,32CB,32CC,32CD,32CE,32CF,32D0,32D1,32D2,32D3,32D4,332D,3332,33A5,33A7,4E27

    Jedem Reader hab ich auch einen eindeutigen Service zugeordnet.

    Bei der ORF-ICE, als auch bei den Sky_de-Kanälen funktioniert das wunderbar.
    Jedoch kommt beim Zugriff auf HD-Plus folgende Meldung (nur auf der User1, auf Server1 und Server2 kommt nichts):
    2013/04/01 13:47:08 2B79D4C8 c dvbapi (1830&000000/EF74/92:BD0E): rejected group (122 ms) (of 0 avail 0) - 1830:EF74 unknown (no matching reader)

    Hallo!

    Sorry, jetzt gehts!

    Hab die Services so abgeändert:
    [hd_plus]
    caid = 1830
    provid = 000000,003411,008011
    srvid = 1519,277E,5273,5274,EF10,EF11,EF14,EF15,EF74,EF75,EF76,EF77,2E9B,151A,157F

    Problem gelöst!

    Danke!

    Gruß Michael861
     
    Zuletzt von einem Moderator bearbeitet: 1. April 2013
    #9
  11. Gazor
    Offline

    Gazor Ist oft hier

    Registriert:
    16. August 2012
    Beiträge:
    182
    Zustimmungen:
    98
    Punkte für Erfolge:
    0
    AW: Freetz Easymouse /dev/ttyUSB0 wird nicht erkannt [FB 7320]

    Super, freut mich dass es jetzt klappt.
     
    #10

Diese Seite empfehlen