1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk Fragen zum Cache

Dieses Thema im Forum "OScam Archiv" wurde erstellt von Best-Of-Me, 1. Juni 2012.

  1. Best-Of-Me
    Offline

    Best-Of-Me Spezialist

    Registriert:
    22. Dezember 2010
    Beiträge:
    633
    Zustimmungen:
    73
    Punkte für Erfolge:
    28
    Hallo zusammen,

    ich nutze die Oscam im Loadbalancer. Ich habe jeweils 2x i12 (UM) und 2xs02 (S*y Sat). Mir ist aufgefallen, dass OsCam aus dem Cache nicht wesentlich schneller antwortet, als wenn es erst aus der Karte auslesen und beantwortet.. Hier mal zur Verdeutlichung:

    2012/06/01 11:42:28 B6D89350 c user01 (1722&000000/0000/2F47/93:F905): found (810 ms) by i12_02 (3 of 4) - ProSieben
    2012/06/01 11:42:28 B7054D20 c user02 (1722&000000/0000/2F47/93:F905): cache2 (804 ms) by i12_02 (3 of 4) - ProSieben

    2 Anfragen kamen zeitgleich an. In der 1. Zeile wird die Karte abgefragt (War viel Verkehr daher bei ~800ms) Nun beantwortet Oscam die 2. Anfrage, die ja zeitgleich eingetroffen ist, auch erst nach 800ms ???

    Vom CSP kenne ich da Zeiten von < 5ms....

    Zum System: Debian Server mit 2GB Arbeitsspeicher (In Verwendung ~400mb) und einer Prozessorauslastung von ~ 5%

    Ich nutze Oscam 1.20 Build 6927.. Der lahme Cache ist mir allerdings auch in der stable Version aufgefallen....

    Liegt es evtl. an meiner Config??

    oscam.conf
    # oscam.conf generated automatically by Streamboard OSCAM 1.20-unstable_svn build #6927
    # Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [global]
    logfile = /var/log/ipc/oscam.log
    clienttimeout = 4000
    nice = -1
    maxlogsize = 2048
    preferlocalcards = 1
    saveinithistory = 1
    dropdups = 1
    lb_mode = 2
    lb_save = 750
    lb_savepath = /var/log/ipc/oscam_lb.log

    [monitor]
    hideclient_to = 15
    monlevel = 0
    appendchaninfo = 1

    [newcamd]
    port = xxxxx@1702:000000
    key = 0102030405060708091011121314
    mgclient = 1

    [cccam]
    port = xxxxx
    reshare = 1
    version = 2.2.1
    keepconnected = 0
    nodeid = XXXXXXXXXX

    [webif]
    httpport = 2255
    httphelplang = de
    httpuser = admin
    httppwd = password
    httpallowed = 127.0.0.1

    oscam.server
    [reader]
    label = s02_01
    protocol = mouse
    device = /dev/ttyUSB0
    services = skyfullhd,skywelt,skyweltextra,skywelthd,skymce,skyfilm,skysport,skybuli,skyfilmhd,skysporthd,!sky3d,!skyselect,!skybluemovie,skyorf,skysonstige,!umbasic,!umplus,!umallstars,!umallstarshd
    boxkey = 1122334455667788
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 1,3
    emmcache = 1,1,2

    [reader]
    label = s02_02
    protocol = mouse
    device = /dev/ttyUSB3
    services = skyfullhd,skywelt,skyweltextra,skywelthd,skymce,skyfilm,skysport,skybuli,skyfilmhd,skysporthd,!sky3d,!skyselect,!skybluemovie,skyorf,skysonstige,!umbasic,!umplus,!umallstars,!umallstarshd
    boxkey = 1122334455667788
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 1,3
    emmcache = 1,1,2

    [reader]
    label = i12_01
    protocol = mouse
    device = /dev/ttyUSB1
    services = skyfullhd,skywelt,skyweltextra,skywelthd,skymce,skyfilm,skysport,skybuli,skyfilmhd,skysporthd,!sky3d,!skyselect,!skybluemovie,!skyorf,skysonstige,umbasic,umplus,!umallstars,!umallstarshd
    boxkey = 1122334455667788
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 2,4,6
    emmcache = 1,1,2

    [reader]
    label = i12_02
    protocol = mouse
    device = /dev/ttyUSB2
    services = skyfullhd,skywelt,skyweltextra,skywelthd,skymce,skyfilm,skysport,skybuli,skyfilmhd,skysporthd,!sky3d,!skyselect,!skybluemovie,!skyorf,skysonstige,umbasic,umplus,!umallstars,!umallstarshd
    boxkey = 1122334455667788
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 2,4,6
    emmcache = 1,1,2

    oscam.user
    [account]
    user = user01
    pwd = pwd
    group = 2
    au = i12_01,i12_02
    betatunnel = 1838.FFFF:1702
    cccmaxhops = 2
    cccreshare = 0

    [account]
    user = user02
    pwd = pwd
    group = 2
    au = i12_01,i12_02
    betatunnel = 1838.FFFF:1702
    cccmaxhops = 2
    cccreshare = 0
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Skyrider79
    Offline

    Skyrider79 Power Elite User

    Registriert:
    28. September 2011
    Beiträge:
    2.374
    Zustimmungen:
    881
    Punkte für Erfolge:
    113
    Beruf:
    Instandhaltungselektroniker
    Ort:
    Franken
    Das stimmt aber so glaube ich nicht :)..Ist mir auch schon aufgefallen der Effekt. Die Antwort aus dem Cache dauerte mit Sicherheit nicht nochmal 800ms....
    Die Angezeigte Zeit ist immer anähernd die Zeit die auch die erste Antwort benötigt hat. Entweder ist die Anzeige falsch rum oder die Zeit ergibt sich deswegen weil die Anfrage eben doch 5-10ms eher oder später einging. Der Cache dauert jedenfalls nich so lange :)...
     
    #2
  4. gooseman
    Offline

    gooseman Elite User

    Registriert:
    17. August 2009
    Beiträge:
    1.567
    Zustimmungen:
    751
    Punkte für Erfolge:
    113
    Ort:
    39°58'59.95"N,117°49'59.52"E
    Das sehe ich genauso wie Skyrider.

    @ Best-Of-Me

    mal was anderes, bist du dir sicher das dein Betatunnel funktioniert??? Du hast ja 1838.FFFF:1702 angegeben!
     
    #3
  5. Best-Of-Me
    Offline

    Best-Of-Me Spezialist

    Registriert:
    22. Dezember 2010
    Beiträge:
    633
    Zustimmungen:
    73
    Punkte für Erfolge:
    28
    Der Betatunnel funktioniert einwandfrei! (Zumindest die Sky HD-Sender werden ohne Probleme entschlüsselt)

    Wieso sollte es denn nicht funktionieren?!
     
    #4
  6. LaPanna
    Offline

    LaPanna Freak

    Registriert:
    2. August 2011
    Beiträge:
    217
    Zustimmungen:
    111
    Punkte für Erfolge:
    43
    Ort:
    Hessen
    Weil 1838 eine UM02 Karte ist und 1702 eine S02 für sat.

    Wahrscheinlich mappen deine user schon bzw regelt das der Autobetatunnel im LB für dich.

    Wieso eigendlich LB-Mode 2 ?
    Nimm mal 1
     
    #5
  7. gooseman
    Offline

    gooseman Elite User

    Registriert:
    17. August 2009
    Beiträge:
    1.567
    Zustimmungen:
    751
    Punkte für Erfolge:
    113
    Ort:
    39°58'59.95"N,117°49'59.52"E
    genau auf das wollte ich hinaus was "LaPanna" gemeint hatte. Ich schätze mal deine User übernehmen das mappen, denn der Eintrag von dir ist meines Wissens nach falsch. Statt 1702 müsste es 1722 heißen
     
    #6
  8. Best-Of-Me
    Offline

    Best-Of-Me Spezialist

    Registriert:
    22. Dezember 2010
    Beiträge:
    633
    Zustimmungen:
    73
    Punkte für Erfolge:
    28
    Tatsächlich war der Betatunnel bei dem einen User falsch eingetragen!!

    Der User hat Zugriff auf die S02 Karte (Caid 1702, war dementsprechend schon richtig) ich habe die Caid für den Betatunnel nun korrigiert!

    Vielen dank dafür!

    Zurück zum Thema: haben sich die Entwickler von Streamboard mal zu dem Thema gemeldet?! Oder kann man es denen melden, dass die sich das mal anschauen?!
     
    #7

Diese Seite empfehlen