1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst Fehler Oscam

Dieses Thema im Forum "IPC" wurde erstellt von susibiker, 20. Mai 2013.

  1. susibiker
    Offline

    susibiker Ist gelegentlich hier

    Registriert:
    29. November 2009
    Beiträge:
    30
    Zustimmungen:
    11
    Punkte für Erfolge:
    8
    Ort:
    Sauerland
    Hallo, habe ein Igel 4210 mit debian 7 und IPC. Beim starten vom Oscam kriege ich folgende Fehlermeldung :

    root@debian ~ > oscam start
    /var/emu/oscam/oscam.x86: error while loading shared libraries: libcrypto.so.0.9.8: cannot open shared object file: No such file or directory
    Fehler beim starten von OScam!
    root@debian ~ >

    Hat einer ein Tipp für mich?
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. ysimmerath
    Online

    ysimmerath Meister

    Registriert:
    5. Dezember 2007
    Beiträge:
    948
    Zustimmungen:
    432
    Punkte für Erfolge:
    63
    Ort:
    31°37'40.96"N
    AW: Fehler Oscam

    das hier schon mal probiert

    Code:
    [COLOR=#333333]apt-get install libssl0.9.8[/COLOR]
     
    #2
    mxer gefällt das.
  4. susibiker
    Offline

    susibiker Ist gelegentlich hier

    Registriert:
    29. November 2009
    Beiträge:
    30
    Zustimmungen:
    11
    Punkte für Erfolge:
    8
    Ort:
    Sauerland
    AW: Fehler Oscam

    Leider ohne Erfolg :

    root@debian ~ > apt-get install libssl0.9.8
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Paket libssl0.9.8 ist nicht verfügbar, wird aber von einem anderen Paket
    referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
    wurde oder nur aus einer anderen Quelle verfügbar ist.


    E: Für Paket »libssl0.9.8« existiert kein Installationskandidat.
    root@debian ~ >
     
    #3
  5. ysimmerath
    Online

    ysimmerath Meister

    Registriert:
    5. Dezember 2007
    Beiträge:
    948
    Zustimmungen:
    432
    Punkte für Erfolge:
    63
    Ort:
    31°37'40.96"N
    AW: Fehler Oscam

    versuche mal das noch

    apt-get install libssl-dev

    Nach der Installations müssen die Links noch erstellt werden

    cd /usr/lib


    ln -s libcrypto.so.0.9.8 libcrypto.so.6
    ln -s libssl.so.0.9.8 libssl.so.6
     
    #4
  6. susibiker
    Offline

    susibiker Ist gelegentlich hier

    Registriert:
    29. November 2009
    Beiträge:
    30
    Zustimmungen:
    11
    Punkte für Erfolge:
    8
    Ort:
    Sauerland
    AW: Fehler Oscam

    Leider auch ohne Erfolg:

    root@debian ~ > apt-get install libssl-dev
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    libssl-dev ist schon die neueste Version.
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
    root@debian ~ > cd /usr/lib
    root@debian /usr/lib > ln -s libcrypto.so.0.9.8 libcrypto.so.6
    root@debian /usr/lib > ln -s libssl.so.0.9.8 libssl.so.6
    root@debian /usr/lib >

    Oscam geht immer noch nicht.
     
    #5
  7. ysimmerath
    Online

    ysimmerath Meister

    Registriert:
    5. Dezember 2007
    Beiträge:
    948
    Zustimmungen:
    432
    Punkte für Erfolge:
    63
    Ort:
    31°37'40.96"N
    AW: Fehler Oscam

    schau mal ob vorhanden ist

    Code:
    find * / |grep libcrypto.so
    vielleicht hast du eine Falsche Binary
     
    #6
  8. einsmann
    Offline

    einsmann Moderator Digital Eliteboard Team

    Registriert:
    7. Februar 2009
    Beiträge:
    1.213
    Zustimmungen:
    462
    Punkte für Erfolge:
    83
    AW: Fehler Oscam

    Hatte ich auch schon.Habe alles nochmal neu aufgesetzt.Nach der Install vom IPC dann meine Reader angeschlossen und o compile durchgeführt.
    Seitdem geht es!!!

    regards
     
    #7
    0800555333 gefällt das.
  9. kallem
    Offline

    kallem Hacker

    Registriert:
    19. August 2009
    Beiträge:
    373
    Zustimmungen:
    80
    Punkte für Erfolge:
    28
    AW: Fehler Oscam

    Hallo susibiker,

    versuche es mal damit.
    apt-get update
    apt-get install libccid libtool libglib2.0-dev libssl-dev libssl0.9.8 libpcsclite1 libpcsclite-dev libusb-dev

    mfg
     
    #8
    susibiker gefällt das.
  10. susibiker
    Offline

    susibiker Ist gelegentlich hier

    Registriert:
    29. November 2009
    Beiträge:
    30
    Zustimmungen:
    11
    Punkte für Erfolge:
    8
    Ort:
    Sauerland
    AW: Fehler Oscam

    Danke kallem jetzt geht es. So jetzt kann ich weiter Basteln.
     
    #9
    kallem gefällt das.
  11. specter13
    Offline

    specter13 Ist gelegentlich hier

    Registriert:
    16. Mai 2009
    Beiträge:
    63
    Zustimmungen:
    5
    Punkte für Erfolge:
    8
    AW: Fehler Oscam

    Hab das gleiche problem mit debian 7.1 und oscam

    und die vorgeschlagenen Lösungen hier klappen nicht.
     
    #10
  12. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.435
    Zustimmungen:
    12.699
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: Fehler Oscam

    Kompilier dir einfach mit o compile selbst eine Oscam-Binary, dann läuft die auch.
     
    #11
    0800555333 und Pilot gefällt das.
  13. 0800555333
    Offline

    0800555333 Hacker

    Registriert:
    9. Juli 2013
    Beiträge:
    327
    Zustimmungen:
    367
    Punkte für Erfolge:
    63
    AW: Fehler Oscam

    Das einfachste ist sich eine OScam Binary selber zu erstellen, dazu gibts bei IPC gleich 2 Möglichkeiten:

    1) Über den Konsolen Befehl: o compile (hilfe aufrufen mit: o compile help)

    2) Über das IPC Web Interface, bei Control den Mauszeiger ein paar Sekunden über die " OScam: " Schrift halten (links neben den Start/Stop Knöpfen)



    [HR][/HR]


    Gewöhnt euch bitte an vorher die Paketinformationen zu aktualisieren damit auch in den aktuellen Paketinformationen gesucht wird... Wenn ihr also heute noch kein "apt-get update" gemacht habt aber was installieren wollt, dann macht ein mal vorher " apt-get update "

    Davon abgesehen gibt es auf aktuellen Linux's keine libssl0.9.8 mehr, die wurde durch libssl1.0.0 ersetzt.. Und somit kann
    Code:
    [COLOR=#333333]ln -s [COLOR=#000000]libcrypto.so.0.9.8[/COLOR] libcrypto.so.6
    ln -s libssl.so.0.9.8 libssl.so.6[/COLOR]
    auch nicht funktionieren weil es keine libcrypto.so.0.9.8 oder libssl.so.0.9.8 Datei gibt..

    Ausserdem ist die Syntax von ' ln ' : ln -s <target> <linkname>

    Wenn kein Target da ist kann auch der Linkname nicht funktionieren (führt ins nichts)


    Das ist keine sinnvolle Syntax - wieso das komplette System nach allem absuchen und die ausgabe dann grepen?

    Sinnvoller wäre:
    Code:
    find / -name libcrypto.so
    das weisst den find Befehl direkt an nach der Datei libcrypto.so zu suchen..
     
    #12
    ysimmerath, Osprey, laila-no1 und 3 anderen gefällt das.

Diese Seite empfehlen