1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

FB7270+OScam+HD+ --> WARNING: pipe header to small !

Dieses Thema im Forum "Fritzbox Archiv" wurde erstellt von noxsid, 24. Juli 2010.

  1. noxsid
    Offline

    noxsid Newbie

    Registriert:
    12. Juli 2008
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    FB7270+OScam+SamrtreaderPlus+HD+ --> Smartreader : couldn't read config descriptor

    Hallo an alle,

    ich habe FB7270+OScam+Smargo+USB-Hub+HD+. Im FB habe ich OSCam gestartet als CCCAM-Server. Ich bin schon fast an der Zielgerade, leider Ziel wird nich näher. In WeBif bekomme ich die Meldungen "WARNING: pipe header to small !". Was jemand was das heißen soll? Läuft es bei mir deswegen noch nicht?

    Danke im Voraus!

    Edit: ich weiss nicht was das war, aber irgendwie hat sich selbst korrigiert
     
    Zuletzt bearbeitet: 25. Juli 2010
    #1
  2. phantom

    Nervigen User Advertisement

  3. noxsid
    Offline

    noxsid Newbie

    Registriert:
    12. Juli 2008
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: FB7270+OScam+HD+ --> Smartreader : couldn't read config descriptor

    Seit gestern abends kann ich den Smartreader nicht zum Laufen kriegen.

    Logausschnitt aus WEBif (Status):
    PHP:
    7311 s   reader started (pid=7317device=001:003,  detect=cdmhz=357cardmhz=357
    7311 s   waiting for local card init 
    7317 r02 Smartreader 
    couldn't read config  descriptor , assuming this is not a smartreader 
    7317 r02 Smartreader device 001:003 not found 
    7317 r02 Cannot open device: 001:003 
    Aus oscam.server
    PHP:
    [reader]
    label cccam_hdplus
    #Protocol = mouse
    Protocol smartreader
    detect 
    CD
    #device = /dev/ttyUSB3
    device 001:003
    group 
    1
    emmcache 
    1,3,2
    #smargopatch = 1
    #aeskey   = 01..........................0f10
    n3_rsakey BF........................D5
    n3_boxkey 
    A................C
    CAID 
    1830
    SamrtReader Plus wird an einem USB-Hub betrieben.
    PHP:
    Mode => Automatisch (auch Fixed mi 3,69 Mhz)
    Kernel => Dreambox (auch normal
    T-Mode => T=0
    EGT 
    => 0
    Aus WEBIf, gescannte USB-Reader
    PHP:
    USB Devices
    BUS
    =001  DEV=001  VID=0000  PID=0000  CLS=09  SCL=00  SPEED='hi'  VER='2.0'  ISOC=0  INUM=1  ICLS1=09  ISCL1=00   
    BUS
    =001  DEV=002  VID=05e3  PID=0608  CLS=09  SCL=00  SPEED='hi'  VER='2.0'  ISOC=0  INUM=1  ICLS1=09  ISCL1=00   
    BUS
    =001  DEV=003  VID=0403  PID=6001  CLS=00  SCL=00  SPEED='full'  VER='2.0'  ISOC=0  INUM=1  ICLS1=255  ISCL1=255   
    BUS
    =001  DEV=004  VID=05e3  PID=0608  CLS=09  SCL=00  SPEED='hi'  VER='2.0'  ISOC=0  INUM=1  ICLS1=09  ISCL1=00   
    BUS
    =001  DEV=005  VID=1976  PID=6025  CLS=00  SCL=00  SPEED='hi'  VER='2.0'  ISOC=0  INUM=1  ICLS1=08  ISCL1=06 
    Bei allen anderen Devicen außer dev=003 bekomme ich sofort die Meldung:
    PHP:
    Smartreader device 001:003 not found 
     
    Zuletzt bearbeitet: 25. Juli 2010
    #2
  4. Graf Orlok
    Offline

    Graf Orlok Hacker

    Registriert:
    26. November 2009
    Beiträge:
    412
    Zustimmungen:
    309
    Punkte für Erfolge:
    0
    Ort:
    Wisborg
    AW: FB7270+OScam+HD+ --> WARNING: pipe header to small !

    Das kann auch nicht funktionieren, da die Smargos mit der OScam aufgrund eines Bugs nicht im nativen Smartreader-Modus laufen. D.h., Du musst in Deiner oscam.server folgende Einträge setzen:

    Code:
    Protocol = mouse 
    smargopatch = 1
    device = /dev/ttyUSB3
    
    Zusätzlich solltest Du noch die richtige Card-Frequenz eintragen:

    Code:
    cardmhz = 368
    
    Viel Erfolg

    Graf Orlok
     
    #3
    noxsid gefällt das.
  5. noxsid
    Offline

    noxsid Newbie

    Registriert:
    12. Juli 2008
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: FB7270+OScam+HD+ --> Smartreader : couldn't read config descriptor

    Danke, Graf Orlok, für schnelle Antwort!
    Geht leider nicht, auch LED am SmartReader+ leuchtet nicht mehr.

    Ausschnitt aus WEBif:
    PHP:
    2010/07/25 11:24:34   5219 s   reader started (pid=5225,  device=/dev/ttyUSB3detect=cdmhz=357cardmhz=368
    2010/07/25 11:24:34   5219 s   waiting for local card init 
    2010
    /07/25 11:24:34   5224 h   HTTP Server listening on port 17001 
    2010
    /07/25 11:24:34   5225 r02 ERROR opening device /dev/ttyUSB3 
    2010
    /07/25 11:24:34   5225 r02 Cannot open device: /dev/ttyUSB3 
    Mit dem auskommetiertem Eintrag cardmhz = 368 geht leider auch nicht

    oscam.server
    PHP:
    [reader]
    label cccam_hdplus
    detect 
    CD
    Protocol 
    mouse
    device 
    = /dev/ttyUSB3
    #Protocol = smartreader
    #device = 001:003
    group 1
    emmcache 
    1,3,2
    smargopatch 
    1
    cardmhz 
    368
    #aeskey   = 01..........................0f10
    n3_rsakey BF........................D5
    n3_boxkey 
    A................C
    CAID 
    1830
     
    Zuletzt bearbeitet: 25. Juli 2010
    #4
  6. Graf Orlok
    Offline

    Graf Orlok Hacker

    Registriert:
    26. November 2009
    Beiträge:
    412
    Zustimmungen:
    309
    Punkte für Erfolge:
    0
    Ort:
    Wisborg
    AW: FB7270+OScam+HD+ --> WARNING: pipe header to small !

    Hi nochmal,

    entferne mal den boxkey und rsakey in Deinem Post. Die dürfen hier nicht veröffentlicht werden.

    Nochmal ne Frage: Hast Du nur die HD+ Karte bei Dir laufen? Dann müsstest Deine oscam.server in etwa so aussehen:

    Code:
    # oscam.server 
     
    [reader] 
    label = cccam_hdplus
    Protocol = mouse 
    smargopatch = 1 
    detect = CD 
    device = /dev/ttyUSB0 
    group = 1 
    emmcache = 1,3,2 
    n3_rsakey= B...
    n3_boxkey   = A...
    CAID = 1830 
    IDENT = 1830:000000,3411,8011
    
    Auf jeden Fall fehlt in Deiner jetzigen oscam.server der IDENT Eintrag.

    Viel Erfolg

    Graf Orlok
     
    #5
    noxsid gefällt das.
  7. noxsid
    Offline

    noxsid Newbie

    Registriert:
    12. Juli 2008
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: FB7270+OScam+HD+ --> WARNING: pipe header to small !

    Ich habe nur HD+ Karte.
    Wenn ich oscam.server (siehe Spoiler unten) ändere, wird mindestens, laut WEBif, karte erkannt, aber nicht aktiviert.
    PHP:
    2010/07/25 13:36:35   4281 s   reader started (pid=4287,  device=/dev/ttyUSB0detect=cdmhz=357cardmhz=368
    2010/07/25 13:36:35   4281 s   waiting for local card init 
    2010
    /07/25 13:36:37   4287 r02 card detected 
    2010
    /07/25 13:36:48   4287 r02 Error activating card
    2010/07/25 13:37:00   4287 r02 Error activating card
    2010/07/25 13:37:11   4287 r02 Error activating card
    oscam.server
    PHP:
    [reader]
    label cccam_hdplus
    detect 
    CD
    smargopatch 
    1
    Protocol 
    mouse
    device 
    = /dev/ttyUSB0
    #Protocol = smartreader
    #device = 001:003
    group 1
    emmcache 
    1,3,2
    cardmhz 
    368
    #aeskey   = 0.......................10
    n3_rsakey B..........................................D5
    n3_boxkey 
    A...........C
    CAID 
    1830
    IDENT 
    1830:000000,3411,8011

    Edit: Auch mit dem auskommentierten Eintrag cardmhz = 368 kommt die gleiche Meldung wie oben
     
    Zuletzt bearbeitet: 25. Juli 2010
    #6
  8. Graf Orlok
    Offline

    Graf Orlok Hacker

    Registriert:
    26. November 2009
    Beiträge:
    412
    Zustimmungen:
    309
    Punkte für Erfolge:
    0
    Ort:
    Wisborg
    AW: FB7270+OScam+HD+ --> WARNING: pipe header to small !

    Ist denn die Karte schon freigeschaltet (sprich: aktiviert) worden? Am besten mal die Karte in einen Deiner Receiver einlegen und z.B. per Scam einmalig aktivieren.

    Viel Erfolg

    Graf Orlok
     
    #7
    noxsid gefällt das.
  9. noxsid
    Offline

    noxsid Newbie

    Registriert:
    12. Juli 2008
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: FB7270+OScam+HD+ --> Smartreader : couldn't read config descriptor

    Die Karte leuft bei mir im Receiver sowohl mit octaCAM__MCAS_E*U und auch mit OSCAM. Ich gehen davon aus dass sie schon aktiviert ist.

    Nachtrag 1:
    Wenn ich die Einstellungen von OScam übernehme kommen die Logmeldungen. Warning: keyword 'smargopatch' in reader section not recognized. Ist das OK?
    LOG-Meldungen:
    PHP:
    Saving settings...done.
    Saving oscam.cfg...done.
    mknod: /dev/ttyUSB0File exists
    mknod
    : /dev/ttyUSB1File exists
    mknod
    : /dev/ttyUSB2File exists
    mknod
    : /dev/ttyUSB3File exists
    mknod
    : /dev/ttyUSB4File exists
    mknod
    : /dev/ttyUSB5File exists
    mknod
    : /dev/ttyUSB6File exists
    mknod
    : /dev/ttyUSB7File exists
    mknod
    : /dev/ttyUSB8File exists
    mknod
    : /dev/ttyUSB9File exists
    mknod
    : /dev/ttyUSB10File exists
    mkdir
    can't create directory '/var/cache/watchdog/': File exists
    Warning: keyword '
    level' in global section not recognized
    Warning: keyword '
    smargopatch' in reader section not recognized
    grep: /var/cache/oscam.log: No such file or directory

    Stoppe OSCam...
    USB-Serial Module entladen
    Watchdog'
    s beendet
    Starte OSCam
    ...
    USB-Serial Module geladen
    Dateien für Watchdog in den Flash kopiert
    OSCam Card
    -Initializing-Error Check aktiviert
    Check 
    if the card was detected correctly...
    It is running correctly.
    OSCam gestartet!
    OSCam-Run Check aktiviert

    Writing 
    /var/flash/freetz...done.
    20992 bytes written.

    Nachtrag2:
    Einstellungen OSCam
    HTML:
    Starttyp   Automatisch 
    USB Comport    
       USB Comport aktivieren  (nur Fritz!Box  mit USB-Host) -->aktiviert   
       FTDI_SIO --> gewählt
    Watchdog
       OSCam Run Check   -->aktiviert
       OSCam Card-Intializing Error Check   -->aktiviert    
    

    Nachtrag3: Ich bin am Ende mit meiner Latein.:ngazzat: Ich habe Smardreader+ mit allen möglichen Kombinatione von Mode => Automatisch (auch Fixed mi 3,69 Mhz)
    Kernel => Dreambox (auch normal)
    T-Mode => T=0 (auch T=1)
    EGT
    => 0
    ausprobiert.
    Auch Update des Samrdreaders+ von 1.03 auf 1.04 hat auch nicht gebracht.:emoticon-0179-headb
     
    Zuletzt bearbeitet: 25. Juli 2010
    #8
  10. Graf Orlok
    Offline

    Graf Orlok Hacker

    Registriert:
    26. November 2009
    Beiträge:
    412
    Zustimmungen:
    309
    Punkte für Erfolge:
    0
    Ort:
    Wisborg
    AW: FB7270+OScam+HD+ --> WARNING: pipe header to small !

    Das ist echt zum heulen mit den Smargos. Mit der FW 1.3 liefen die eigentlich alle noch recht zuverlässig.

    Das Chaos ging erst los, als die FW 1.4 und dann 1.5 für die Argolis Smargos veröffentlicht wurden. Seitdem gibt es Leute, die berichten, dass die 1.3 nicht mehr funzt. Bei den meisten läuft die 1.4 nicht (die 1.4 ist übrigens niemals für Maxdigital-Smargos released worden, sonden nur für Argolis). Naja, und ob die 1.5 wirklich eine echte FW weiß auch so recht niemand. Und dass die FW generell kein Zurückflashen mehr zulässt, macht das Chaos perfekt.

    Mein Vorschlag:

    1.) Poste mal komplett Deine oscam.server, oscam.user und oscam.conf. Wenn dann okay, weiter zu Punkt 2.

    2.) Update des Smargos auf 1.5
    Wenn dann okay, weiter zu Punkt 3.

    3.) Der Watchdog in Deinem Image kann ebenfalls ein Störfaktor sein. Ggf. dann ein Image ohne diesen IMHO überflüssigen Watchdog flashen.

    Viel Erfolg

    Graf Orlok

    P.S. Bitte benutzte zum Posten von Code das Symbol mit der #.
     
    #9
  11. noxsid
    Offline

    noxsid Newbie

    Registriert:
    12. Juli 2008
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: FB7270+OScam+HD+ --> WARNING: pipe header to small !

    Das finde ich auch nicht Ok1

    Hier sind die oscam-Daten.

    oscam.server

    Code:
    #Locale Reader
    
    
    [reader] 
    label = cccam_hdplus
    Protocol = mouse 
    smargopatch = 1
    detect = CD 
    device = /dev/ttyUSB0 
    group = 1 
    emmcache = 1,3,2 
    #cardmhz = 368
    n3_rsakey = B............................5
    n3_boxkey = A..................C
    CAID = 1830
    IDENT = 1830:000000,3411,8011
    
    #[reader]
    #Label          = gbox_fritz
    #Protocol       = gbox
    #Device         = 192.168.2.1,2719,2720
    #Account        = 192.168.2.1,135DC42A
    #Fallback       = 0
    #Group          = 2
    
    #[reader]
    #Label          = premiere
    #Protocol       = mouse
    #Device         = /dev/ttyUSB0
    #CAID           = 1702&FFDF:1702,1833&FFDF:1833
    #EMMCache       = 1,3,2
    #Group          = 1
    #Services = pwhd
    
    [reader]
    #Label          = cs357x
    #Protocol       = camd35
    #Device         = xxxxx.dyndns.org,33458
    #Account        = user,pass
    #CAID           = 1702&FFDF:1702,1833&FFDF:1833
    #CAID           = 1702&FFDF:1702
    #CAID           = 1833&FFDF:1833
    #Fallback       = 0
    #Group          = 3
    
    
    #[reader]
    #Label = newcamd_hdplus
    #Protocol = newcamd
    #Key = 0102030405060708091011121314
    #Device  = 192.168.178.1,12021
    #Account = mpcs,mpcs
    #Group = 1
    #Fallback       = 1
    #CAID = 1830
    #CAID = 1702&FFDF:1702
    

    oscam.config

    Code:
    [global]
    Nice = -1
    WaitForCards = 1
    ClientTimeout = 5
    FallbackTimeout = 5
    ClientMaxIdle = 120
    Level = 15
    CacheDelay = 120
    BindWait = 20
    ResolveDelay = 15
    LogFile = /var/media/ftp/uStor01/logs/oscam.log
    #LogFile = /var/log/oscam.log
    #LogFile = /var/cache/oscam.log
    #LogFile = /dev/null
    PidFile = /var/run/oscam.pid
    Sleep = 0
    
    [monitor]
    port                = 988
    nocrypt             = 0.0.0.0-255.255.255.255
    aulow               = 120
    hideclient_to       = 60
    monlevel            = 2
    appendchaninfo      = 0
    
    [webif]
    httpport            = 17002
    httpuser            = admin
    httppwd             = nixda
    httpcss             = 
    httptpl             = 
    httpscript          = 
    httprefresh         = 0
    httpallowed         = 0.0.0.0-255.255.255.255
    httpdyndns          = 
    httphideidleclients = 0
    httpreadonly        = 0
    
    # Protocols
    # camd35
    #[cs357x]
    #Port = 33461
    
    #[newcamd]
    #Port = 12023@1830:000000
    #key                 = 0102030405060708091011121314
    #allowed             = 0.0.0.0-255.255.255.255
    #keepalive           = 1
    
    [cccam]
    port          = 12021
    version       = 2.1.1
    build         = 2971
    reshare       = 2
    
    

    oscam.user
    Code:
    #oscam.user generated automatically
    
    [account]
    user                = login4
    pwd                 = password4
    #disabled            = 0
    #expdate             = 
    group               = 1
    #hostname            = 
    uniq                = 0
    #sleep               = 0
    #monlevel            = 2
    au                  = hdplus
    #services            = 
    caid                = 1830
    #betatunnel          = 
    ident               = 1830:000000
    #keepalive           = 1
    #numusers            = 0
    #penalty             = 0
    
    #[account]
    #user = login5
    #pwd = password5
    #Group  = 1
    #betatunnel = 1833.FFFF:1702 
    #CAID = 1830
    #au = 1
    #ident = 1830:000000
    #uniq = 1
    
    
    

    Update Smartreader auf die Version 1.05 hat bis jetzt auch nichts gebracht. Ich habe aber noch nicht alle Kombinationen von den Einstellungen des Smartreaders probiert.
     
    #10
  12. Graf Orlok
    Offline

    Graf Orlok Hacker

    Registriert:
    26. November 2009
    Beiträge:
    412
    Zustimmungen:
    309
    Punkte für Erfolge:
    0
    Ort:
    Wisborg
    AW: FB7270+OScam+HD+ --> WARNING: pipe header to small !

    Also, jetzt hab ich das - glaub ich zumindest - verstanden. Wenn Du wirklich nur die HD+ Karte laufen lassen willst, dann geht der Weg so nicht.

    Die Option, die OScam als CCcam-Server laufen zu lassen, macht z.B. dann Sinn, wenn Du Sky über CCcam auf einem Receiver "erhellst" und zusätzlich noch eine HD+ Karte lokal in diesem Receiver laufen lässt, ohne jedes Mal zwischen den Emus hin- und her switchen willst. Also beide Dinge (Sky aus dem Share und HD+ lokal) auf einmal laufen lassen willst.

    Bei der Fritzbox haut das so nicht hin.

    Dem entsprechend sollten Deine Dateien so aussehen:

    # oscam.server
    Code:
    [reader] 
    label = hdplus
    Protocol = mouse 
    smargopatch = 1 
    detect = CD 
    device = /dev/ttyUSB0 
    group = 1 
    emmcache = 1,3,2 
    n3_rsakey= B...
    n3_boxkey   = A...
    cardmhz = 368
    CAID = 1830 
    IDENT = 1830:000000,3411,8011
    
    


    # oscam.user
    Code:
    [account]
    user                = user
    pwd                 = pass
    disabled            = 0
    group               = 1
    uniq                = 0
    sleep               = 0
    monlevel            = 1
    au                  = 1
    caid                = 1830&FFFF
    keepalive           = 0
    numusers            = 0
    penalty             = 0
    
    


    # oscam.conf
    Code:
    [global]
    disablelog          = 0
    disableuserfile     = 0
    usrfileflag         = 0
    clienttimeout       = 5000
    fallbacktimeout     = 2000
    clientmaxidle       = 120
    cachedelay          = 120
    bindwait            = 120
    netprio             = 0
    resolvedelay        = 30
    unlockparental      = 0
    nice                = -1
    serialreadertimeout = 1500
    logfile             = /var/media/ftp/uStor01/logs/oscam.log
    maxlogsize          = 100
    waitforcards        = 1
    preferlocalcards    = 0
    saveinithistory     = 1
    
    [monitor]
    port                = 988
    nocrypt             = 0.0.0.0-255.255.255.255
    aulow               = 120
    hideclient_to       = 30
    monlevel            = 1
    appendchaninfo      = 0
    
    #[newcamd]
    #port                = 34000@1830:003411
    #key                 = 0102030405060708091011121314
    #allowed             = 0.0.0.0-255.255.255.255
    #keepalive           = 0
    
    [webif]
    httpport            = 83
    httpcss             = /var/media/ftp/uStor01/cs/oscam//bluestyle.css
    httprefresh         = 10
    httpallowed         = 0.0.0.0-255.255.255.255
    httphideidleclients = 1
    httpreadonly        = 0
    
    

    Mehr braucht es eigentlich nicht. Die ausgekreuzten (#) newcamd Einträge in der oscam.conf benötigst Du nur, wenn Du auf Deiner Fritzbox auch noch CCcam laufen hast und Dich damit verbinden willst.

    Viel Erfolg

    Graf Orlok
     
    #11
    noxsid gefällt das.
  13. noxsid
    Offline

    noxsid Newbie

    Registriert:
    12. Juli 2008
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: FB7270+OScam+HD+ --> WARNING: pipe header to small !

    @Graf Orlok
    Danke für deine Unterstützung, vielen Dank!

    Aber ich klriege das alles nicht zum laufen, ich bekomme immer noch diese Meldung "Error activating card". Ich werden mal andere HD+ Karte probieren, wenn das auch nicht geht, dann liegt es höchstwarscheinlich an dem Smartreader.

    Aber wie sollen dann die Daten vom Fritzbox (sprich von der Karte) zum Receiver gelanden?
     
    #12
  14. noxsid
    Offline

    noxsid Newbie

    Registriert:
    12. Juli 2008
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: FB7270+OScam+HD+ --> WARNING: pipe header to small !

    Es hat geklappt, es hat funktioniert. Leider wird die Karte immer wieder nicht erkannt.

    Bei Änderungen der Einstellungen des Smartreaders habe ich früher nur OSCam neu gestartet. In dem Forum habe ich gelesen, dass man soll nach jeder Änderunge der Einstelllungen die FB neu starten (nicht OSCam neu starten). Und siehe da, es geht. Leider nicht immer, warum auch immer. Genauso wenn die Karte schon erkannt ist, führt Restart des Oscam meistens immer wieder zur nicht Erkennung der Karte.

    So hat es bei mir funktioniert:
    1) HW:
    * FB 7270 + 7270_04.80freetz-devel-5079M.de_20100615-225314 (von OneStep)
    * 7 Port USB-Hub aktiv [​IMG]
    * USB-Stick mit 512 MB (No name) (wird von FB problemlos erakannt)
    2) SmargoReader+ wie folgt eingestellt:
    Mode => Automatisch
    Kernel => normal
    T-Mode => auch T=1
    EGT
    => 0

    Hinweis 1: Der SmartReader wurd auf die Version 1.05 upgedatet (Grund, siehe meine Posts)
    Hinweis 2: Nach der Änderung der Einstellungen des Smartreaders+, Smartreader+ mit der Karte in Hub einstecken und danach den Restart der FB durchführen
    3) Oscam wurde wie unten dargestellt, konfiguriert:
    oscam.config
    Code:
    [global]
    Nice = -1
    WaitForCards = 1
    ClientTimeout = 5
    FallbackTimeout = 5
    ClientMaxIdle = 120
    Level = 15
    CacheDelay = 120
    BindWait = 20
    ResolveDelay = 15
    LogFile = /var/media/ftp/uStor01/logs/oscam.log
    #LogFile = /var/cache/oscam.log
    #LogFile = /dev/null
    PidFile = /var/run/oscam.pid
    Sleep = 0
    
    [monitor]
    port                = 988
    nocrypt             = 0.0.0.0-255.255.255.255
    aulow               = 120
    hideclient_to       = 60
    monlevel            = 2
    appendchaninfo      = 0
    
    [webif]
    httpport            = 17071
    httpuser            = admin
    httppwd             = nimda
    httpcss             = 
    httptpl             = 
    httpscript          = 
    httprefresh         = 0
    httpallowed         = 0.0.0.0-255.255.255.255
    httpdyndns          = 
    httphideidleclients = 0
    httpreadonly        = 0
    
    [cccam]
    port          = 12021
    version       = 2.1.1
    build         = 2917
    reshare       = 2
    
    
    oscam.server
    Code:
    #Locale Reader
    
    [reader]
    label = HDplus
    Protocol = mouse
    detect = CD
    device = /dev/ttyUSB0
    cardmhz=368
    group = 1
    emmcache = 1,3,2
    smargopatch = 1
    n3_rsakey = B........................5
    n3_boxkey = A................C
    CAID = 1830
    
    
    oscam.user
    Code:
    [account]
    user = login4
    pwd = password4
    group = 1
    AU = HDplus
    CAID = 1830
    
    [account]
    
    5) Kommunikation FB <--> Receiver über CCCam Protokoll

    Bleibt nur zwei Probleme:
    1) Wie kriege ich es hin, dass die Erkennung der Karte stabil bleibt
    2) Wenn das funktioniert, kann ich nur lokal sharen. Über Inernet klappt es leider noch nicht. Hat jemand Rat, an welchen Schrauben ich noch drehen soll.
     
    #13
  15. Graf Orlok
    Offline

    Graf Orlok Hacker

    Registriert:
    26. November 2009
    Beiträge:
    412
    Zustimmungen:
    309
    Punkte für Erfolge:
    0
    Ort:
    Wisborg
    AW: FB7270+OScam+HD+ --> WARNING: pipe header to small !

    Hallo,

    Du scheinst meine Vorschläge in den entscheidenen Punkten zu ignorieren oder ich habe sie unverständlich erklärt. Auf jeden Fall wundere ich mich, dass Du meine für Dich angepassten oscam-Dateien nicht übernehmen wolltest.

    Lies Dir das Ganze nochmal durch. Dann sollte es klarer werden.

    Ich versuchs hier auch nochmal zu erläutern:

    Die Einträge

    Code:
    [cccam]
    port          = 12021
    version       = 2.1.1
    build         = 2917
    reshare       = 2
    
    haben in der oscam.conf, wenn die HD+ Karte in der Fritzbox liegt, nichts zu suchen. Entferne sie bitte. Du benötigst statt dessen [newcamd] Einträge!!!

    Die Logik dahinter sieht so aus:

    Die richtige Variante [Newcamd]:

    1.) Fritzbox mit HD+ Karte: OScam --> oscam.conf --> [Newcamd] --> CCcam.cfg --> CCcam

    Wichtig: In dieser CCcam.cfg sind zwei Arten von "Verbindungseinträgen" enthalten:

    A.) N-Line: Verbindet den Emu OSCam per NEWCAMD mit der CCcam (beides NUR intern auf der Fritzbox!)

    B.) F-Line: Dient zur Verbindung mit Deinem Receiver

    ===================================================================
    ===================================================================

    2.) Dein Receiver ohne HD+ Karte: CCcam.cfg --> CCcam (mehr nicht, kein OSCam oder andere Emus***)

    ===================================================================
    ===================================================================

    ERGEBNIS: Du kannst HD+ auf Deinem Receiver schauen, ohne dass sich darin eine HD+ Karte befindet!

    *** es sei denn, Dein Receiver kann kein CCcam!!!

    Damit haben sich dann vermutlich auch Deine beiden Fragen

    erledigt.

    Viel Erfolg

    Graf Orlok
     
    #14
    noxsid gefällt das.
  16. j__k
    Offline

    j__k Hacker

    Registriert:
    13. März 2009
    Beiträge:
    324
    Zustimmungen:
    194
    Punkte für Erfolge:
    43
    AW: FB7270+OScam+HD+ --> WARNING: pipe header to small !

    Stell doch den Reader auf:
    fixed
    3,69
    normal
    T = 0
    EGT = 0
    und entferne den Eintrag:
    cardmhz=368

    in der oscam.server, dann klappts auch mit der HD+ Karte.

    Blödsinn, die HD+ Karte kannst du genau so per CCcam Protokoll an CCcam Clienten weitergeben. In aktuellen Versionen gibts nur:
    build = 2917
    als Parameter nicht mehr.
     
    #15
    noxsid gefällt das.

Diese Seite empfehlen