1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk EMM's weiterleiten bei Reshare - Geht das?

Dieses Thema im Forum "OScam Archiv" wurde erstellt von ueker123, 4. Juni 2012.

  1. ueker123
    Offline

    ueker123 Ist oft hier

    Registriert:
    17. Dezember 2011
    Beiträge:
    141
    Zustimmungen:
    17
    Punkte für Erfolge:
    0
    Hallo,

    mal angenommen es gibt zwei Oscam Cardserver auf X86 Basis (Debian)
    Ist es möglich die EMM's von einem Client an Server 1 an die Karte welche lokal an Server 2 sind weiterzuleiten?

    Protokoll zwischen den Servern ist CCcam, ließe sich ggf. auch ändern.

    Es hängen folgende Karten am Server:

    HD01 (1830), S02 (1833),I12(1835) und UM02(1838)

    Vielen Dank für eure Hilfe...
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Kermit
    Offline

    Kermit Guest

    Hallo ueker123,

    ja dies ist möglich.
    Entweder bei au = 1 werden die EMMs an alle vorhandenen Reader geschickt oder nimmst explizit den Labelnamen des Readers auf (au = Labelnamen1,Labelnamen2,....).

    Grüße

    Kermit
     
    #2
  4. ueker123
    Offline

    ueker123 Ist oft hier

    Registriert:
    17. Dezember 2011
    Beiträge:
    141
    Zustimmungen:
    17
    Punkte für Erfolge:
    0
    Hey,

    danke erstmal für dier schnell Antwort.
    Also es ist mit dem CCcam Protokoll möglich?

    Leider geht bei mir absolut nix durch.

    Au steht bei den Nutzern auf ON, bei den Readern sowohl bei Server 1 also auch bei Server 2 auf ON.
    Dennoch werden keine EMM's auf die Karten durchgelassen. ACTIVE habe ich bisher nicht gelesen.

    Hier mal die Configs am Beispiel eines S02 Users/Readers:


    Usereinstellung auf Server 1:

    [account]
    user = testaccount
    pwd = testzugang
    group = 1,2,3
    uniq = 3
    monlevel = 0
    au = 1
    services = skysatkomplett,hdplus,orf,austriasat,"sky-um,umbasic,"umallstars,"umallstarshd
    cccmaxhops = 5
    cccreshare = 0
    keepalive = 1

    Reader im Server 1

    [reader]
    label = testreader
    description = testreader
    enable = 1
    protocol = cccam
    device = xxxxx,port
    key =
    user = test
    password = test
    pincode = none
    services = skysatkomplett,!hdplus,!orf,!austriasat,!sky-um,!umbasic,!umallstars,!umallstarshd
    inactivitytimeout = 30
    reconnecttimeout = 30
    fallback = 0
    cacheex = 0
    cacheex_maxhop = 0
    logport = 0
    caid = 1702,1833
    ecmwhitelist =
    ident =
    chid =
    class =
    aeskeys =
    group = 1
    emmcache = 0,0,0
    blockemm-unknown = 0
    blockemm-u = 0
    blockemm-s = 0
    blockemm-g = 0
    saveemm-unknown = 0
    saveemm-u = 0
    saveemm-s = 0
    saveemm-g = 0
    blockemm-bylen =
    lb_weight = 100
    savenano =
    blocknano =
    cccversion = 2.3.0
    cccmaxhops = 10
    cccmindown = 0
    cccwantemu = 0
    ccckeepalive = 1
    cccreshare = -1
    cccreconnect = 0
    audisabled = 0
    auprovid =

    Usereinstellungen im Server 2

    [account]
    user = test
    pwd = test
    group = 2
    uniq = 3
    monlevel = 0
    au = 1
    services = skysatkomplett,!hdplus,!orf,!austriasat,!sky-um,!umbasic,!umallstars,!umallstarshd
    caid = 1702,1833
    betatunnel = 1833.FFFF:1702
    cccreshare = 1
    cccignorereshare = 1
    keepalive = 1

    Die Readereinstellungen in Server 2 sollten egal sein, da direkte Nutzer auf Server 1 EMM's ja senden.
    Es scheint an der Übermittlung zu liegen.
     
    Zuletzt von einem Moderator bearbeitet: 4. Juni 2012
    #3
  5. Kermit
    Offline

    Kermit Guest

    Hi,

    ich habe was die au Funktion angeht bessere Erfahrungen gemacht, wenn ich den Label des Readers angebe bei dem jeweiligem User.
    Als kleiner Tipp noch am Rande. Stell in der oscam.conf im Abschnitt [webif] den Paramter
    httpsavefullcfg = 0
    ein. Damit werden die Paramter, die nicht verwendet werden oder Default Werte enthalten in den Konfgis nicht angezeigt und die ganze Geschichte ist übersichtlicher.

    Grüße

    Kermit
     
    #4
  6. ueker123
    Offline

    ueker123 Ist oft hier

    Registriert:
    17. Dezember 2011
    Beiträge:
    141
    Zustimmungen:
    17
    Punkte für Erfolge:
    0
    Habs geändert, aber das ändert natürlich nix an meinem Problem....
     
    #5
  7. Kermit
    Offline

    Kermit Guest

    Aber lokal werden EMMs geschrieben oder wie schaut es da aus?

    Grüße

    Kermit
     
    #6
  8. ueker123
    Offline

    ueker123 Ist oft hier

    Registriert:
    17. Dezember 2011
    Beiträge:
    141
    Zustimmungen:
    17
    Punkte für Erfolge:
    0
    Jop wenn die User lokal zugreifen läufts einwandfrei, nur wenn die Anfragen über den V Server laufen kommt nix durch.
     
    #7

Diese Seite empfehlen