1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst Einrichtung Freetz Devel 10629, OSCAM, SMARGO 1.7, Fritte 7270, V13 sky inkl. HD+,

Dieses Thema im Forum "Fritzbox Talk" wurde erstellt von Azghul, 31. Juli 2013.

  1. Azghul
    Offline

    Azghul Newbie

    Registriert:
    28. Juli 2013
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Hallo liebes Forum,

    mal wieder ein Anfänger CS-Thread...aber ich weiß micht mehr weiter.
    Client soll 1x Ferguson Ariva werden (lokal) und 1x vermutlich Diablo Wifi an Humas HD+fox (via Internet).
    Der Ferguson benötigs ja afaik CCcam und ich geh davon aus, dass die Clienteinrichtung das kleinere Übel sein wird.

    Bevor ich euch jetzt mit Logs vollballer, 2 Logikprobleme, mit denen ich seid 1 Woche kämpfe.

    1) Benötige ich auf der Fritte CCcam? oder kann OSCam das "emulieren"? Falls nicht, muss ich ja erst Chroot installieren und CCcam.
    Chroot sollte ich hinbekommen, bei CCcam hängt. Zumindest die Chroot files sind schon auf dem Stick und sollten sich pet Telnet installieren lassen.

    2) mir wird das Log von OSCAM nicht mehr angezeigt. Ich hatte es bevor ich die Fritte neu aufgesetzt habe unter "/ustor01/logs", irgendwie wills da nicht mehr hin. Soviel ich weiss, erkenne ich ja an dem Log, ob die Karte erkannt wird, oder nicht.


    Klar, wäre es mir am liebsten, wenn mir jemand eine idiotensichere Step by Step Anleitung vorkauen würde, aber da ist der Lerneffekt ja gleich 0, insofern würde ich nach jedem Häppchen ein wenig rumdoktorn und mich bei Bedarf wieder melden.


    Schonmal vielen Dank.

    Grüße
    Azze
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. 4real999
    Offline

    4real999 Freak

    Registriert:
    6. Juni 2009
    Beiträge:
    226
    Zustimmungen:
    37
    Punkte für Erfolge:
    28
    AW: Einrichtung Freetz Devel 10629, OSCAM, SMARGO 1.7, Fritte 7270, V13 sky inkl. HD+

    Oscam only auf dem Server reicht vollkommen aus.
    Oscam configs (.config, .server, .user) vorconfigurieren.
    Oscam starten über WebInterface.... Gucken ob Oscam läuft.... dann configs zum laufen bekommen.....
     
    #2
  4. Azghul
    Offline

    Azghul Newbie

    Registriert:
    28. Juli 2013
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Einrichtung Freetz Devel 10629, OSCAM, SMARGO 1.7, Fritte 7270, V13 sky inkl. HD+

    Hi,
    Danke für die Infos, muss die Fritte wohl nochmal zurücksetzen. Bekomme keinen Zugriff aufs Webinterface und die Box lässt sich nicht rebooten.
     
    #3
  5. Azghul
    Offline

    Azghul Newbie

    Registriert:
    28. Juli 2013
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Einrichtung Freetz Devel 10629, OSCAM, SMARGO 1.7, Fritte 7270, V13 sky inkl. HD+

    Heureka.
    Smargo wird ekannt, auf Server kann zugegriffen werden, allerdings erkennt der Reader, soweit ich das erkennen kann, keine Karte.

    Jetzt komm ich wohl doch nicht umher, mal ein paar logs zu posten.


    OSCAM.conf

    [global]
    serverip = xxx.xxx.xxx.x
    logfile = /var/log/oscam.log
    fallbacktimeout = 2000
    nice = -1
    maxlogsize = 1000
    preferlocalcards = 1

    [serial]
    device = Reader_1

    [cccam]
    port = xxxx
    serverip = xxx.xxx.xxx.xxx
    nodeid = 7EFB7D501012149C
    version = 2.1.4

    [monitor]
    port = 988
    nocrypt = 192.168.0.0-192.168.255.255
    aulow = 120
    monlevel = 1
    hideclient_to = 30

    [webif]
    httpport = 83
    httpuser = xxx
    httppwd = xxx
    httpcss = /var/media/ftp/uStor01/service/oscam/style.css
    httprefresh = 10
    httphideidleclients = 1
    httpallowed = 192.168.0.0-192.168.255.255
    aulow = 120
    hideclient_to = 30

    OSCAM.server

    [reader]
    label = Reader-1
    description = Sky
    protocol = smartreader
    device = Serial:Reader_1
    services = sky_de
    caid = 09C4
    detect = cd
    group = 1

    OSCAM.user

    [account]
    user = user
    pwd = pass
    caid = 09C4
    monlevel = 1
    au = 1
    group = 1
    cccmaxhops = 1
    cccreshare = 1

    Wenn ich ins webinterface schaue steht da:
    [TABLE="class: status, width: 100%"]
    [TR="class: r"]
    [TD="class: statuscol1"]0x4dc120[/TD]
    [TD="class: statuscol2"]r[/TD]
    [TD="class: statuscol3"]1[/TD]
    [TD="class: statuscol4"]Reader-1[/TD]
    [TD="class: statuscol5"]

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    [/TD]
    [TD="class: statuscol6"]OFF[/TD]
    [TD="class: statuscol7"]127.0.0.1[/TD]
    [TD="class: statuscol8"]0[/TD]
    [TD="class: statuscol9"]smartreader[/TD]
    [TD="class: statuscol10"][/TD]
    [TD="class: statuscol11"][/TD]
    [TD="class: statuscol12"]0000:0000[/TD]
    [TD="class: statuscol13"][/TD]
    [TD="class: statuscol14"]

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    [/TD]
    [TD="class: statuscol15"]00:08:17[/TD]
    [TD="class: statuscol16"]OFF

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    [/TD]
    [/TR]
    [/TABLE]

    und in dem Log im Webinterface kommt permanent:
    2013/07/31 19:27:10 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build r8557 (mipsel-linux-uclibc-ssl-libusb-static)
    2013/07/31 19:27:10 0 s creating pidfile /tmp/.oscam/oscam.pid with pid 6284
    2013/07/31 19:27:10 0 s services reloaded: 0 services freed, 3 services loaded, rejected 0
    2013/07/31 19:27:10 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2013/07/31 19:27:10 0 s signal handling initialized
    2013/07/31 19:27:10 0 s 116 service-id's loaded in 8ms
    2013/07/31 19:27:10 0 s 116 tier-id's loaded
    2013/07/31 19:27:10 0 s 3 provid's loaded
    2013/07/31 19:27:10 0 s 22 lengths for caid guessing loaded
    2013/07/31 19:27:10 0 s monitor: initialized (fd=7, port=988, ip=192.168.178.1)
    2013/07/31 19:27:10 0 s cccam: initialized (fd=8, port=4711, ip=192.168.178.1)
    2013/07/31 19:27:10 0 s Reader-1 [smartreader] creating thread for device Serial:Reader_1
    2013/07/31 19:27:10 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2013/07/31 19:27:10 4DC120 r Reader-1 [smartreader] Using 0x01/0x82 as endpoint for smartreader hardware detection
    2013/07/31 19:27:10 0 s waiting for local card init
    2013/07/31 19:27:10 4E7510 h webif: decompressed 52670 bytes back into 150580 bytes
    2013/07/31 19:27:10 4E7510 h HTTP Server listening on port 83
    2013/07/31 19:27:10 4DC120 r Found reader with serial Reader_1 at 001:004
    2013/07/31 19:27:10 4DC120 r Found smartreader device Serial:Reader_1
    2013/07/31 19:27:10 4DC120 r Reader-1 [smartreader] Reader initialized (device=Serial:Reader_1, detect=cd, mhz=357, cardmhz=357)
    2013/07/31 19:27:11 0 s init for all local cards done
    2013/07/31 19:27:11 0 s anti cascading disabled
    2013/07/31 19:27:13 513468 c encrypted cccam-client 192.168.178.21 granted (user, au=auto (1 reader))
    2013/07/31 19:27:37 513468 c user disconnected from 192.168.178.21
    2013/07/31 19:27:37 5166B0 c encrypted cccam-client 192.168.178.21 granted (user, au=auto (1 reader))

    Ich hoffe mit dne Infos könnt ihr was anfangen.

    Grüße
    Azze

    Ich hatte die group falsch gesetzt.
    Jetzt kommen folgende Fehlermeldungen

    2013/07/31 19:27:10 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build r8557 (mipsel-linux-uclibc-ssl-libusb-static)
    2013/07/31 19:27:10 0 s creating pidfile /tmp/.oscam/oscam.pid with pid 6284
    2013/07/31 19:27:10 0 s services reloaded: 0 services freed, 3 services loaded, rejected 0
    2013/07/31 19:27:10 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2013/07/31 19:27:10 0 s signal handling initialized
    2013/07/31 19:27:10 0 s 116 service-id's loaded in 8ms
    2013/07/31 19:27:10 0 s 116 tier-id's loaded
    2013/07/31 19:27:10 0 s 3 provid's loaded
    2013/07/31 19:27:10 0 s 22 lengths for caid guessing loaded
    2013/07/31 19:27:10 0 s monitor: initialized (fd=7, port=988, ip=192.168.178.1)
    2013/07/31 19:27:10 0 s cccam: initialized (fd=8, port=4711, ip=192.168.178.1)
    2013/07/31 19:27:10 0 s Reader-1 [smartreader] creating thread for device Serial:Reader_1
    2013/07/31 19:27:10 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2013/07/31 19:27:10 4DC120 r Reader-1 [smartreader] Using 0x01/0x82 as endpoint for smartreader hardware detection
    2013/07/31 19:27:10 0 s waiting for local card init
    2013/07/31 19:27:10 4E7510 h webif: decompressed 52670 bytes back into 150580 bytes
    2013/07/31 19:27:10 4E7510 h HTTP Server listening on port 83
    2013/07/31 19:27:10 4DC120 r Found reader with serial Reader_1 at 001:004
    2013/07/31 19:27:10 4DC120 r Found smartreader device Serial:Reader_1
    2013/07/31 19:27:10 4DC120 r Reader-1 [smartreader] Reader initialized (device=Serial:Reader_1, detect=cd, mhz=357, cardmhz=357)
    2013/07/31 19:27:11 0 s init for all local cards done
    2013/07/31 19:27:11 0 s anti cascading disabled
    2013/07/31 19:27:13 513468 c encrypted cccam-client 192.168.178.21 granted (user, au=auto (1 reader))
    2013/07/31 19:27:37 513468 c user disconnected from 192.168.178.21
    2013/07/31 19:27:37 5166B0 c encrypted cccam-client 192.168.178.21 granted (user, au=auto (1 reader))
     
    Zuletzt bearbeitet: 21. August 2013
    #4
  6. 4real999
    Offline

    4real999 Freak

    Registriert:
    6. Juni 2009
    Beiträge:
    226
    Zustimmungen:
    37
    Punkte für Erfolge:
    28
    AW: Einrichtung Freetz Devel 10629, OSCAM, SMARGO 1.7, Fritte 7270, V13 sky inkl. HD+

    1. Oscam.server (für den Anfang mal ohne serials, alle usb ports testen)
    [reader]
    label = sky
    enable = 1
    protocol = mouse
    device = /dev/ttyUSB0
    services = sky_de #hier unter oscam.services die services auch drin (ansonsten komplett weg lassen
    smargopatch = 1
    device_out_endpoint = 0x82
    caid = 09C4
    boxid = 12345678
    detect = cd
    mhz = 357
    cardmhz = 357
    group = 1
    emmcache = 1,3,2
    2. Smargo auf Auto/normal/T=0/0 stellen und -> reboot
    3. FDTI auswählen
    hacken USB Comport mit einem Treiber aktivieren

    Dann noch mal log posten
     
    #5
  7. Azghul
    Offline

    Azghul Newbie

    Registriert:
    28. Juli 2013
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Guten Morgen,

    hier das log.

    2013/08/01 07:41:26 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build r8557 (mipsel-linux-uclibc-ssl-libusb-static)
    2013/08/01 07:41:26 0 s creating pidfile /tmp/.oscam/oscam.pid with pid 7753
    2013/08/01 07:41:26 0 s services reloaded: 0 services freed, 2 services loaded, rejected 0
    2013/08/01 07:41:26 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2013/08/01 07:41:26 0 s signal handling initialized
    2013/08/01 07:41:26 0 s 199 service-id's loaded in 12ms
    2013/08/01 07:41:26 0 s 199 tier-id's loaded
    2013/08/01 07:41:26 0 s 13 provid's loaded
    2013/08/01 07:41:26 0 s 22 lengths for caid guessing loaded
    2013/08/01 07:41:26 0 s monitor: initialized (fd=7, port=988, ip=192.168.178.1)
    2013/08/01 07:41:26 0 s cccam: initialized (fd=8, port=4711, ip=192.168.178.1)
    2013/08/01 07:41:26 0 s sky [mouse] creating thread for device /dev/ttyUSB0
    2013/08/01 07:41:26 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2013/08/01 07:41:26 0 s waiting for local card init
    2013/08/01 07:41:26 4DD560 h webif: decompressed 52670 bytes back into 150580 bytes
    2013/08/01 07:41:26 4DD560 h HTTP Server listening on port 83
    2013/08/01 07:41:26 50CC20 r sky [mouse] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
    2013/08/01 07:41:27 50CC20 r sky [mouse] card detected
    2013/08/01 07:41:30 50CC20 r sky [mouse] ATR: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    2013/08/01 07:41:30 50CC20 r sky [mouse] Init card protocol T0, FI=1, F=372, D=1, N=3
    2013/08/01 07:41:30 50CC20 r sky [mouse] Setting baudrate to 9600 bps
    2013/08/01 07:41:30 50CC20 r sky [mouse] Calculated work ETU is 104.20 us
    2013/08/01 07:41:31 50CC20 r sky [mouse] ATR Fsmax is: 5 Mhz, clocking card to wanted user cardspeed of 3.57 Mhz (specified in reader->mhz)
    2013/08/01 07:41:32 50CC20 r sky [mouse] Card type: P1TV
    2013/08/01 07:41:32 50CC20 r sky [mouse] Rom version: 10A7
    2013/08/01 07:41:33 50CC20 r sky [mouse] parental lock setting: FF FF FF FF
    2013/08/01 07:41:33 50CC20 r sky [mouse] type: VideoGuard Sky Germany (09C4), caid: 09C4
    2013/08/01 07:41:33 50CC20 r sky [mouse] serial: ########, BoxID: ########, baseyear: 2004
    2013/08/01 07:41:33 50CC20 r sky [mouse] ready for requests
    2013/08/01 07:41:33 50CC20 r sky [mouse] found card system videoguard2
    2013/08/01 07:41:33 50CC20 r sky [videoguard2] card detected
    2013/08/01 07:41:33 50CC20 r sky [videoguard2] type: VideoGuard Sky Germany (09C4)
    2013/08/01 07:41:33 50CC20 r sky [videoguard2] tier: 2712, expiry date: 2013/06/13-01:01:00



    Services sehen so aus:

    [HD +]

    caid = 09c4,1830,1843
    srvid = 126e,126f,1519,151a,157c,157f,2e9b,5273,5274,ef10,ef11,ef14,ef15,ef74,ef75,ef76,ef77

    [Sky Deutschland]

    caid = 098C,09C4,1702,1833
    srvid = 0008,0009,000a,000b,000c,000d,000e,0010,0011,0012,0013,0014,0015,0016,0017,0018,0019,001a,001b,001c,001d,001e,0021,0022,0023,0024,0025,0026,0027,0029,002a,002b,0032,0034,0037,0038,0039,003a,003b,0066,0069,006a,006b,006c,006d,006e,006f,0070,0071,0072,0073,0074,0075,0076,0077,0078,0079,007a,007b,007c,007d,007e,007f,0080,0081,0082,0083,0084,00a8,00c9,00ca,00cb,00cc,00cd,00ce,00cf,00d0,00d1,00d2,00d4,00d5,00d8,00d9,00da,00db,00dc,00dd,00de,00df,00e0,00e1,00e2,00e3,00e4,00f1,00f2,00fb,00fc,00fe,0105,0106,0107,010c,010f,0110,0111,0116,0119,011a,011b,0120,0123,0124,0125,012a,012d,012e,012f,0130,0131,0137,0138,0141,0142,014b,014c,014e,0159,0163,016d,0191,0192,0193,0195,019b,019c,019f,01a0,0201,0203,0204,0206,07ff,0ab4,125d,126e,126f,1519,151a,152d,157f,2efe,3331,3335,33ac,4461,4462,4ef3,5273,5274,527d,527e,6fb8,6fb9,7001,700a,ef10,ef11,ef14,ef15,ef74,ef75,ef76,ef77

    Oleee Oleee!

    Meine Sender werden hell ;)
    Jetzt gehts noch ans optimieren.
    Werde die ganze Geschichte nun mit dem Smartreaderprotokoll testen, wegen der geringeren Latenz.

    Wie schaut es denn aus, wenn ich via dyndns arbeiten möchte? Einfach einen 2ten Server eingeben?

    Grüße
    Azze

    Ok, alles erledigt, Server läuft.

    Vielen Dank für die passende Hilfe, nach den Startschwierigkeiten passt alles und die ganzen Parameter machen nun auch auf einmal Sinn.

    Grüße
    Azze
     
    Zuletzt bearbeitet: 21. August 2013
    #6
  8. fussballgotttt
    Offline

    fussballgotttt Freak

    Registriert:
    11. Dezember 2008
    Beiträge:
    269
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    Beruf:
    Callboy
    Ort:
    127.0.0.1
    AW: Einrichtung Freetz Devel 10629, OSCAM, SMARGO 1.7, Fritte 7270, V13 sky inkl. HD+

    ist dir aufgefallen, dass du deinen CARD-ATR gepostet hast? mach den mal ganz schnell weg.
     
    #7
  9. Azghul
    Offline

    Azghul Newbie

    Registriert:
    28. Juli 2013
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Einrichtung Freetz Devel 10629, OSCAM, SMARGO 1.7, Fritte 7270, V13 sky inkl. HD+

    Erledigt und Danke
     
    #8

Diese Seite empfehlen