1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk dvbapi problem mit TT-6400 und FF-Karte

Dieses Thema im Forum "CS VDR-SC" wurde erstellt von Karlsdorf, 21. Juli 2013.

  1. Karlsdorf
    Offline

    Karlsdorf Newbie

    Registriert:
    16. April 2011
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Ich betreibe VDR 2.0.2 mit neusestem oscam und dvbapi. In meinem System habe ich eine TT-6400 als adapter0+1 und eine FF SD-Karte als adapter2.

    Alles funktioniert mit adapter0+1 aber wenn adapter2 verwendet wird, wird es nicht hell. Da ein ca0 in /dev/dvb/adapter2/ existiert

    Code:
    vdr01 ~ # ll /dev/dvb/adapter2/
    total 0
    drwxr-xr-x 2 root root      200 Jul 21 16:23 .
    drwxr-xr-x 5 root root      100 Jul 21 16:23 ..
    crw-rw---- 1 root video 212, 14 Jul 21 16:23 audio0
    crw-rw---- 1 root video 212, 15 Jul 21 16:23 ca0
    crw-rw---- 1 root video 212, 11 Jul 21 16:23 demux0
    crw-rw---- 1 root video 212, 12 Jul 21 16:23 dvr0
    crw-rw---- 1 root video 212, 18 Jul 21 16:23 frontend0
    crw-rw---- 1 root video 212, 17 Jul 21 16:23 net0
    crw-rw---- 1 root video 212, 16 Jul 21 16:23 osd0
    crw-rw---- 1 root video 212, 13 Jul 21 16:23 video0
    vdr01 ~ #
    

    starte ich wie im README beschrieben das dvbapi-plugin mit der option "-B2" um den budget mode zu aktivieren, was auch klappt:
    Code:
    vdr01 conf # tail -f /var/log/messages | grep 'dvbapi' -i
    Jul 21 16:23:50 [root] Starting /usr/bin/vdr  --localedir=/etc/vdr/locale --vfat -u root -w 15 --config=/etc/vdr --shutdown='/_config/bin/vdrshutdown' --epgfile=/var/vdr/epg.data --log=3 --video=/video --record='/tmp/vdr/vdr_record' --lib=/usr/lib/vdr/plugins  --plugin='dvd -C/dev/dvd' --plugin='music ' --plugin='mplayer --mplayer=/etc/vdr/plugins/mplayer/mplayer.sh --mount=/etc/vdr/plugins/mp3/mount.sh' --plugin='osdteletext -d /tmp/osdteletext -n 20' --plugin='epgsearch ' --plugin='extrecmenu ' --plugin='skinenigmang --epgimages=/var/vdr/epgimages' --plugin='filebrowser ' --plugin='yacoto ' --plugin='admin ' --plugin='dvbhddevice ' --plugin='remote --input=/dev/input/by-path/pci-0000:05:00.0-event-ir' --plugin='femon ' --plugin='fritzbox ' --plugin='osdserver ' --plugin='vodcatcher --cache=/tmp/vodcatcher' --plugin='streamdev-server ' --plugin='dvbapi -B2'
    Jul 21 16:23:50 [vdr] [20893] loading plugin: /usr/lib/vdr/plugins/libvdr-dvbapi.so.2.0.0
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: loading library: libvdr-dvbsddevice.so.2.0.0
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: VDR dvbsddevice plugin loaded as subplugin
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: loading library: libvdr-dvbhddevice.so.2.0.0
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: VDR dvbhddevice plugin loaded as subplugin
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: loading library: libdvbapi-dvbhddevice.so.2.0.0
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: loading library: libdvbapi-dvbsddevice.so.2.0.0
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: Probe: capturing device 1/0 (subsystem ID 13c2300a)
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: creating standard device 1/0
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: Using software decryption on card 1/0
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: SCCIAdapter: built caid table with 32 caids for 745 channels
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: Probe: capturing device 2/0 (subsystem ID 13c20000)
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: creating SD-FF device 2/0
    [B]Jul 21 16:23:50 [vdr] [20893] DVBAPI: Budget mode forced on card 2/0[/B]
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: Using software decryption on card 2/0
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: SCCIAdapter: built caid table with 32 caids for 745 channels
    Jul 21 16:23:50 [vdr] [20893] initializing plugin: dvbapi (1.0.5): DVBAPI type SOFTCAM
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: plugin version 1.0.5 initializing (VDR 2.0.2)
    Jul 21 16:23:50 [vdr] [20893] starting plugin: dvbapi
    Jul 21 16:23:50 [vdr] [20893] DVBAPI: plugin started
    Jul 21 16:23:51 [vdr] [20893] DVBAPI: 1.0: doReply changed, reset triggered
    Jul 21 16:23:51 [vdr] [20893] DVBAPI: 1.0: now using CAIDs version 16843009
    Jul 21 16:23:51 [vdr] [20893] DVBAPI: 1.0: status 'present'
    Jul 21 16:23:51 [vdr] [20893] DVBAPI: 2.0: doReply changed, reset triggered
    Jul 21 16:23:51 [vdr] [20893] DVBAPI: 2.0: now using CAIDs version 16843009
    Jul 21 16:23:51 [vdr] [20893] DVBAPI: 2.0: status 'present'
    Jul 21 16:23:51 [vdr] [20907] DVBAPI: 1.0: status 'reset'
    Jul 21 16:23:51 [vdr] [20913] DVBAPI: 2.0: status 'reset'
    Jul 21 16:23:51 [vdr] [20893] DVBAPI: 1.0: status 'ready'
    Jul 21 16:23:52 [vdr] [20893] DVBAPI: 2.0: status 'ready'
    Jul 21 16:23:52 [vdr] [20907] DVBAPI: CaInfo: 1.0 sending CA info
    Jul 21 16:23:52 [vdr] [20913] DVBAPI: CaInfo: 2.0 sending CA info
    Jul 21 16:23:53 [vdr] [20893] DVBAPI: 2.0 set CAM decrypt (SID 33, caLm 4, HasCaDescriptors 0)
    Jul 21 16:23:54 [vdr] [20893] DVBAPI: 2.0 set CAM decrypt (SID 33, caLm 5, HasCaDescriptors 1)
    Jul 21 16:23:54 [vdr] [20893] DVBAPI: 2.0 set CAM decrypt (SID 33, caLm 4, HasCaDescriptors 1)
    
    Für verschlüsselte SD-Kanäle wird vorzugsweise adapter2 verwendet, was aber nicht funktioniert. Wenn ich durch Aufnahme eines unverschlüsselten SD-Kanals mit adapter2 das System zwinge einen adapter der TT-6400 zu verwenden wird es hell.


    Wenn ich auf einen SD Kanal schalte (dunkel, FF-SD-Karte wird verwendet):
    Code:
    vdr01 conf # tail -f /var/log/messages
    Jul 21 16:53:54 [vdr] [20893] switching to channel 43
    Jul 21 16:53:54 [vdr] [24944] osdteletext-receiver thread ended (pid=20893, tid=24944)
    Jul 21 16:53:54 [vdr] [20893] buffer stats: 0 (0%) used
    Jul 21 16:53:54 [vdr] [24946] TS buffer on device 1 thread ended (pid=20893, tid=24946)
    Jul 21 16:53:54 [vdr] [24945] buffer stats: 3760 (0%) used
    Jul 21 16:53:54 [vdr] [24945] receiver on device 1 thread ended (pid=20893, tid=24945)
    Jul 21 16:53:54 [vdr] [20893] DVBAPI: 2.0 set CAM decrypt (SID 11, caLm 4, HasCaDescriptors 1)
    Jul 21 16:53:54 [vdr] [25379] receiver on device 3 thread started (pid=20893, tid=25379, prio=high)
    Jul 21 16:53:54 [vdr] [25380] osdteletext-receiver thread started (pid=20893, tid=25380, prio=high)
    Jul 21 16:53:54 [vdr] [25381] TS buffer on device 3 thread started (pid=20893, tid=25381, prio=high)
    
    Wenn ich auf einen HD-Kanal schalte (hell, weil TT-6400 verwendet wird):

    Code:
    Jul 21 16:54:21 [vdr] [20893] switching to channel 26
    Jul 21 16:54:22 [vdr] [20893] DVBAPI: 2.0 set CAM decrypt (SID 11, caLm 4, HasCaDescriptors 1)
    Jul 21 16:54:22 [vdr] [25380] osdteletext-receiver thread ended (pid=20893, tid=25380)
    Jul 21 16:54:22 [vdr] [20893] DVBAPI: 2.0 set CAM decrypt (SID 11, caLm 5, HasCaDescriptors 1)
    Jul 21 16:54:22 [vdr] [20893] buffer stats: 0 (0%) used
    Jul 21 16:54:22 [vdr] [20893] DVBAPI: 1.0 set CAM decrypt (SID 106, caLm 4, HasCaDescriptors 1)
    Jul 21 16:54:22 [vdr] [25444] osdteletext-receiver thread started (pid=20893, tid=25444, prio=high)
    Jul 21 16:54:22 [vdr] [25443] receiver on device 2 thread started (pid=20893, tid=25443, prio=high)
    Jul 21 16:54:22 [vdr] [25445] TS buffer on device 2 thread started (pid=20893, tid=25445, prio=high)
    Jul 21 16:54:22 [vdr] [25381] TS buffer on device 3 thread ended (pid=20893, tid=25381)
    Jul 21 16:54:22 [vdr] [25379] buffer stats: 80840 (1%) used
    Jul 21 16:54:22 [vdr] [25379] receiver on device 3 thread ended (pid=20893, tid=25379)
    

    Kann mir bitte jemand helfen das Problem zu lokalisieren?
     
    Zuletzt von einem Moderator bearbeitet: 21. Juli 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. paust55
    Offline

    paust55 Newbie

    Registriert:
    14. Juli 2010
    Beiträge:
    23
    Zustimmungen:
    4
    Punkte für Erfolge:
    3
    AW: dvbapi problem mit TT-6400 und FF-Karte

    Du könntest mal das dvbapi-Plugin ohne diese Option testen oder auch mal "-B0 -B1 -B2" probieren.

    Paust55
     
    #2
    Karlsdorf gefällt das.
  4. Karlsdorf
    Offline

    Karlsdorf Newbie

    Registriert:
    16. April 2011
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Hallo Paust55,

    danke für den Tipp. Leider bringt das spielen mit den Optionen nichts. Mit "-B0 -B1 -B2" ist das Ergebniss und das Log identisch.

    Beim start ohne Option fehlt die Ausgabe "Using software decryption on card 2/0" aber ansonsten verhält sich alles so als ob decryption mit adapter2 möglich wäre. Es bleibt aber dunkel.

    Wenn ich ca0 lösche kommt zusätzlich die Meldung "Card 2/0 is a full-featured card but no ca device found!". Ansonsten gleiches Ergebnis.

    Das ganze ist noch viel schlimmer: Der 1. Tuner der TT-6400 wird überhaupt nicht zur decryption herangezogen. Im Log kommt adapter0 gar nicht vor, sieht man schon im Log oben. Wenn ich mit adapter1 eine Aufnahme eines verschlüsselten HD-Senders starte überspringt er beim zappen viele verschlüsselte HD-Sender, adapter1 wird also gar nicht verwendet.

    Also:
    - Adapter0 erscheint gar nicht.
    - Decryption funktioniert nur mit adapter1.
    - Adapter2 wird angeblich für decryption verwendet, geht aber nicht.

    Was ist da los?

    update

    Ich verwende nun auch die neueste Firmware der TT6400. Außer vermehrten Tonknacksern beim Umschalten gibt es keine Änderung.

    update

    Ich habe gelesen, dass die Entschlüsselung mit beiden Tunern der TT6400 nur mit dem DAG-Patch zuverlässig funktioniert. Leider kann ich keine Quelle zu besagtem Patch finden. Kann mir bitte jemand weiterhelfen?

    update

    Hurra! Die Entschlüsselung zweier HD-Sender geht jetzt! Ich lade dvbapi nun vor dvbhddevice:

    Code:
    vdr01 ~ # tail -f /var/log/messages | grep -i dvbapi
    Jul 22 22:47:02 [root] Will build: /etc/vdr.d/1010-dvbapi
    Jul 22 22:47:02 [root] Starting /usr/bin/vdr  --localedir=/etc/vdr/locale --vfat -u root -w 15 --config=/etc/vdr --shutdown='/_config/bin/vdrshutdown' --epgfile=/var/vdr/epg.data --log=3 --video=/video --record='/tmp/vdr/vdr_record' --lib=/usr/lib/vdr/plugins  --plugin='music ' --plugin='mplayer --mplayer=/etc/vdr/plugins/mplayer/mplayer.sh --mount=/etc/vdr/plugins/mp3/mount.sh' --plugin='osdteletext -d /tmp/osdteletext -n 20' --plugin='epgsearch ' --plugin='extrecmenu ' --plugin='skinenigmang --epgimages=/var/vdr/epgimages' --plugin='filebrowser ' --plugin='yacoto ' --plugin='admin ' --plugin='dvbapi -B2' --plugin='dvbhddevice ' --plugin='remote --input=/dev/input/by-path/pci-0000:05:00.0-event-ir' --plugin='femon ' --plugin='fritzbox ' --plugin='osdserver ' --plugin='vodcatcher --cache=/tmp/vodcatcher' --plugin='streamdev-server '
    Jul 22 22:47:02 [vdr] [12581] loading plugin: /usr/lib/vdr/plugins/libvdr-dvbapi.so.2.0.0
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: loading library: libvdr-dvbsddevice.so.2.0.0
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: VDR dvbsddevice plugin loaded as subplugin
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: loading library: libvdr-dvbhddevice.so.2.0.0
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: VDR dvbhddevice plugin loaded as subplugin
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: loading library: libdvbapi-dvbhddevice.so.2.0.0
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: loading library: libdvbapi-dvbsddevice.so.2.0.0
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: Probe: capturing device 0/0 (subsystem ID 13c2300a)
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: creating HD-FF device 0/0
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: Card 0/0 is a full-featured card but no ca device found!
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: Using software decryption on card 0/0
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: SCCIAdapter: built caid table with 32 caids for 745 channels
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: Probe: capturing device 1/0 (subsystem ID 13c2300a)
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: creating standard device 1/0
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: Using software decryption on card 1/0
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: SCCIAdapter: built caid table with 32 caids for 745 channels
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: Probe: capturing device 2/0 (subsystem ID 13c20000)
    Jul 22 22:47:02 [vdr] [12581] DVBAPI: creating SD-FF device 2/0
    Jul 22 22:47:03 [vdr] [12581] DVBAPI: Budget mode forced on card 2/0
    Jul 22 22:47:03 [vdr] [12581] DVBAPI: Using software decryption on card 2/0
    Jul 22 22:47:03 [vdr] [12581] DVBAPI: SCCIAdapter: built caid table with 32 caids for 745 channels
    Jul 22 22:47:03 [vdr] [12581] initializing plugin: dvbapi (1.0.5): DVBAPI type SOFTCAM
    Jul 22 22:47:03 [vdr] [12581] DVBAPI: plugin version 1.0.5 initializing (VDR 2.0.2)
    Jul 22 22:47:03 [vdr] [12581] starting plugin: dvbapi
    Jul 22 22:47:03 [vdr] [12581] DVBAPI: plugin started
    Jul 22 22:47:04 [vdr] [12581] DVBAPI: 1.0: doReply changed, reset triggered
    Jul 22 22:47:04 [vdr] [12581] DVBAPI: 1.0: now using CAIDs version 16843009
    Jul 22 22:47:04 [vdr] [12581] DVBAPI: 1.0: status 'present'
    Jul 22 22:47:04 [vdr] [12593] DVBAPI: 1.0: status 'reset'
    Jul 22 22:47:04 [vdr] [12589] DVBAPI: 0.0: doReply changed, reset triggered
    Jul 22 22:47:04 [vdr] [12589] DVBAPI: 0.0: now using CAIDs version 16843009
    Jul 22 22:47:04 [vdr] [12589] DVBAPI: 0.0: status 'present'
    Jul 22 22:47:04 [vdr] [12598] DVBAPI: 2.0: doReply changed, reset triggered
    Jul 22 22:47:04 [vdr] [12598] DVBAPI: 2.0: now using CAIDs version 16843009
    Jul 22 22:47:04 [vdr] [12598] DVBAPI: 2.0: status 'present'
    Jul 22 22:47:04 [vdr] [12581] DVBAPI: 2.0: status 'reset'
    Jul 22 22:47:04 [vdr] [12581] DVBAPI: 0.0: status 'reset'
    Jul 22 22:47:05 [vdr] [12593] DVBAPI: 1.0: status 'ready'
    Jul 22 22:47:05 [vdr] [12589] DVBAPI: 0.0: status 'ready'
    Jul 22 22:47:05 [vdr] [12598] DVBAPI: 2.0: status 'ready'
    Jul 22 22:47:05 [vdr] [12593] DVBAPI: CaInfo: 1.0 sending CA info
    Jul 22 22:47:05 [vdr] [12589] DVBAPI: CaInfo: 0.0 sending CA info
    Jul 22 22:47:05 [vdr] [12598] DVBAPI: CaInfo: 2.0 sending CA info
    Jul 22 22:47:06 [vdr] [12581] DVBAPI: 0.0 set CAM decrypt (SID 11, caLm 4, HasCaDescriptors 0)
    Jul 22 22:47:09 [vdr] [12581] DVBAPI: 0.0 set CAM decrypt (SID 11, caLm 4, HasCaDescriptors 1)
    Jul 22 22:47:09 [vdr] [12581] DVBAPI: 0.0 set CAM decrypt (SID 11, caLm 5, HasCaDescriptors 1)
    Jul 22 22:47:09 [vdr] [12581] DVBAPI: 0.0 set CAM decrypt (SID 11, caLm 4, HasCaDescriptors 1)
    
    

    Ich habe jetzt 3 CAMs. Leider entschlüsselt adapter2, die FF-SD Karte, immer noch nicht :emoticon-0120-doh:

    update

    Ich vermute ich benötige eine gepatchte firmware für meine FF-SD Karte (AV7110). Kann das jemand bestätigen? Falls ja, woher bekomme ich die?
     
    Zuletzt von einem Moderator bearbeitet: 22. Juli 2013
    #3
  5. paust55
    Offline

    paust55 Newbie

    Registriert:
    14. Juli 2010
    Beiträge:
    23
    Zustimmungen:
    4
    Punkte für Erfolge:
    3
    AW: dvbapi problem mit TT-6400 und FF-Karte

    Wenn ich mich recht entsinne, dann gab es tatsächlich für die "alte" FF-SD-Karte eine spezielle gepatchte Firmware, damit damals das Entschlüsseln der Sender funktionierte. Das ist ja alles schon so viele jahre her, dass ich die FF-SD-Karten aus meinem VDR geschmissen habe. das ich das vergessen hatte.
    In den Tiefen des Internets gibt es sicherlich diese Firmware noch, so z. B. findest Du diese bei den Sourcen für das sc-Plugin unter "

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    "

    Paust55
     
    #4
    Karlsdorf gefällt das.
  6. frodo.
    Offline

    frodo. Freak

    Registriert:
    27. April 2011
    Beiträge:
    283
    Zustimmungen:
    48
    Punkte für Erfolge:
    28
    AW: dvbapi problem mit TT-6400 und FF-Karte

    Ob die FF-SD Karte mit dvbapi funktioniert kann ich dir nicht sagen Du benötigst aber auf jedenfall die gepatchte Firmware und eine zusätzliche Library libdvbapi-dvbsddevice.so.2.0.0 welche das dvbapi Device mitbringen sollte. Dazu muss dieses aber unter Verwendung der Plugin Sourcen dvbhddevice und dvbsddevice gebaut werden.

    Das bei der TT-6400 nur ein Tuner mit dvbapi verwendet wird habe ich auch beobachtet. Du wirst dies auch recht schnell feststellen wenn Du einen verschlüsselten HD Sender aufnimmst und einen zweiten auf einem anderen Transponder gleichzeitig anschauen möchtest. Leider hat der Plugin Entwickler des dvbhddevices den ersten Tuner nicht als Budget Tuner eingebaut sondern diesen mit audio, video und osd verknüpft, hierdurch muss man nun entweder in die Sourcen des Plugins eingreifen oder das Verhalten umgehen. Theoretisch sollte dies gelöst sein durch die zusätzlichen Library libdvbapi-dvbhddevice.so.2.0.0.
    Leider klappte es bei mir hiermit nicht, ich musste das dvbhddevice mit dem dag Patch patchen um beide Tuner mit verschlüsselten Sendern nutzen zu können.

    Unabhängig von den Problemen die hier bereits beschrieben wurden funktioniert bei mir dvbapi mit der TT-6400 nicht zufriedenstellen, auch mit einer Cine S2 6.0 bekomme ich bei diversen verschlüsselten Sendern häufig Pixelfehler.

    Unter Verwendung des vdr-sc Plugins und des dag-Patches für das dvbhddevice Plugin treten keine der Probleme auf, weshalb ich vorerst wieder dieses verwende. Wobei mir persönlich es lieber wäre wenn das dvbapi Plugin fehlerfrei funktionieren würde.
     
    #5
  7. Karlsdorf
    Offline

    Karlsdorf Newbie

    Registriert:
    16. April 2011
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: dvbapi problem mit TT-6400 und FF-Karte

    Hallo Paust55,

    danke für den Link. Leider ändert die gepatchte Firmware nichts. Die SD-FF Karte entschlüsselt nicht. Schade.
     
    #6
  8. Karlsdorf
    Offline

    Karlsdorf Newbie

    Registriert:
    16. April 2011
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: dvbapi problem mit TT-6400 und FF-Karte

    Hallo frodo,

    nach einigem Hin und Her entschlüsseln meine 2 Empfänger der TT-6400 Karte nun simultan mit dvbapi (siehe oben). Ich verwende neueste Oscam, dvbapi und firmware. Zusätzlich lade ich das Plugin dvbapi vor dvbhddevice. Und schon gehts! Allerdings kann ich noch nicht sagen ob es keine Probleme mehr gibt. Dazu muss ich das System mal einige Zeit nutzen.

    Beim übersetzen von dvbapi erhalte ich 3 so-Dateien:
    1.) libdvbapi-dvbhddevice.so.2.0.0
    2.) libdvbapi-dvbsddevice.so.2.0.0
    3.) libvdr-dvbapi.so.2.0.0
    Alle Dateien liegen in /usr/lib/patches. Für was sind die beiden libdvbapi-Dateien? Wird libdvbapi-dvbhddevice.so.2.0.0 anstatt libvdr-dvbhddevice.so.2.0.0 verwendet? Oder ist es so gedacht, dass man die Dateien austauschen soll?

    dvbsddevice verwende ich übrigends nicht, da ich nur über die TT-6400 das Bild ausgebe.
     
    #7
  9. frodo.
    Offline

    frodo. Freak

    Registriert:
    27. April 2011
    Beiträge:
    283
    Zustimmungen:
    48
    Punkte für Erfolge:
    28
    AW: dvbapi problem mit TT-6400 und FF-Karte

    Im Prinzip ersetzen die von dvbapi erzeugten Libraries die Original Plugin-Libraries. Im syslog sieht man, dass das dvbapi Plugin die Libraries libdvbapi-dvbhddevice.so.2.0.0 und libdvbapi-dvbsddevice.so.2.0.0 nachlädt. Das dvbhddevice Plugin müsste nicht geladen werden, allerdings benötigt man es um Einstellungen über das OSD für die TT-6400 durchführen zu können.

    Die Dateien müssen damit das Plugin libvdr-dvbapi.so.2.0.0 diese nachladen kann im gleichen Verzeichnis liegen wie die anderen VDR Plugins.

    Ansonsten muss das dvbapi Plugin vor dem dvbhddevice geladen werden.

    Verwendest Du den dag-Patch für das dvbhddevice?
     
    #8
  10. Karlsdorf
    Offline

    Karlsdorf Newbie

    Registriert:
    16. April 2011
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: dvbapi problem mit TT-6400 und FF-Karte

    Richtig. Im Log sieht das dann so aus:

    Code:
    Jul 26 21:05:51 [vdr] [3361] loading plugin: /usr/lib/vdr/plugins/libvdr-dvbapi.so.2.0.0
    Jul 26 21:05:51 [vdr] [3361] DVBAPI: loading library: libvdr-dvbsddevice.so.2.0.0
    Jul 26 21:05:51 [vdr] [3361] DVBAPI: VDR dvbsddevice plugin loaded as subplugin
    Jul 26 21:05:51 [vdr] [3361] DVBAPI: loading library: libvdr-dvbhddevice.so.2.0.0
    Jul 26 21:05:51 [vdr] [3361] DVBAPI: VDR dvbhddevice plugin loaded as subplugin
    Jul 26 21:05:51 [vdr] [3361] DVBAPI: loading library: libdvbapi-dvbhddevice.so.2.0.0
    Jul 26 21:05:51 [vdr] [3361] DVBAPI: loading library: libdvbapi-dvbsddevice.so.2.0.0
    
    Nein, ich verwende die neuste Firmware v0.4.0 von Regel (

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    ).

    Ich habe auch nur über den Patch gelesen und noch keine src gefunden.
     
    #9
  11. legenwaitforitdary
    Offline

    legenwaitforitdary Meister

    Registriert:
    12. November 2011
    Beiträge:
    748
    Zustimmungen:
    147
    Punkte für Erfolge:
    43
    AW: dvbapi problem mit TT-6400 und FF-Karte

    Probier doch mal die fertigen Pakete aus

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    , da scheint der Patch enthalten zu sein
     
    #10
  12. frodo.
    Offline

    frodo. Freak

    Registriert:
    27. April 2011
    Beiträge:
    283
    Zustimmungen:
    48
    Punkte für Erfolge:
    28
    AW: dvbapi problem mit TT-6400 und FF-Karte

    Wenn es bei Karlsdorf auch ohne den Patch funktioniert, würde ich nichts ändern.
     
    #11
  13. legenwaitforitdary
    Offline

    legenwaitforitdary Meister

    Registriert:
    12. November 2011
    Beiträge:
    748
    Zustimmungen:
    147
    Punkte für Erfolge:
    43
    AW: dvbapi problem mit TT-6400 und FF-Karte

    Da hast du vermutlich recht, vor allem, da ich keine FullFeatured Karte besitze oder je besessen hab, wollte nur darauf hinweisen, da die Pakete in diesem PPA diesen dag-Patch eben enthalten.
     
    #12
  14. Karlsdorf
    Offline

    Karlsdorf Newbie

    Registriert:
    16. April 2011
    Beiträge:
    13
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: dvbapi problem mit TT-6400 und FF-Karte

    Danke für den Link. Der dag Patch ist wohl tatsächlich im

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    enthalten. Beim probieren hatte ich allerdings mehrere Fehler und habe schlussentlich aufgegeben, da ich ja eigentlich nur noch mit der SD-FF Karte probleme habe.

    Trotzdem ist der Link interessant, danke.
     
    #13
  15. frodo.
    Offline

    frodo. Freak

    Registriert:
    27. April 2011
    Beiträge:
    283
    Zustimmungen:
    48
    Punkte für Erfolge:
    28
    AW: dvbapi problem mit TT-6400 und FF-Karte

    Der Patch ist nicht im dvbapi Plugin sondern im dvbhddevice.

    Nur je nachdem wie das dvbhddevice vorgefunden wird wird das dvbapi Plugin kompiliert.

    Vermutlich ist aber der einzige Unterschied das mit DAG Patch keine extra Library erzeugt wird.
     
    #14

Diese Seite empfehlen