1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Dreambox, Oscam + Smargo funzt nicht

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von tagchen2, 27. Februar 2013.

  1. tagchen2
    Offline

    tagchen2 Ist gelegentlich hier

    Registriert:
    14. September 2010
    Beiträge:
    38
    Zustimmungen:
    3
    Punkte für Erfolge:
    0
    Hi,

    ich habe das Problem, dass ich 3x Smardcards verwende. (D02+V13+HD02) somit der interne Reader mit 2x Cards belegt ist.
    Ich nun also noch eine Smargo gekauft habe.

    Version war 1.3 und ist nun auf 1.5.
    ftsoi Treiber installiert und auch mal ohne.

    ABER:
    binde ich diesen in Oscam ein, hat er Probleme mit "protocol = xxxxx", heißt der nächste Reader wird überschrieben.
    Also wenn es als Beispiel protocol= internal wäre, beim nächsten Reader, steht im Webinterface smargo da. Aber der Smargo wird auch nicht als Reader angezeigt.
    Stelle ich die Settings in der oscam.server ganz unten hin, werden keine oscam.user mein gelesen.


    Probiert.

    [reader]
    label = HD02
    detect = cd
    protocol = smargo
    device = /dev/ttyUSB0
    #device = Serial:Reader Cxxxxx
    smargopatch = 1
    services = hdplus
    rsakey =BF358xxxxCA4DD5
    boxkey = A76xx
    mhz = 368
    cardmhz = 368
    caid = 1843
    group = 3
    emmcache = 1,3,2
    lb_weight = 300

    Smargo als:

    Fixed, 3,69, 0, 0
    Auto, Normal, 0,0
    Auto, Dreambox, 0,0

    protocol = mouse, smartreader, smargo, internal

    Mit cccam läuft der Reader ohne Probleme, aber Cccam ist sehr instabil und kann die D02 HD nicht, daher will ich oscam only weiter laufen lassen.
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Kermit
    Offline

    Kermit Guest

    AW: Dreambox, Oscam + Smargo funzt nicht

    Hi,

    wenn du das Protokoll mouse verwendest ist es zwingend, dass du das Device /dev/ttyUSB0 verwendest und es muß dann auch der ftdio Treiber aktiviert sein.
    Im Falles des Protokolls smartreader ist der Smargo über die iSerial3 anzusprechen und deine OScam muß mit libusb Unterstützung kompiliert worden sein.
    Das Protokoll internal geht nur bei den internen Readern eines Receivers.

    Grüße

    Kermit
     
    #2
  4. tagchen2
    Offline

    tagchen2 Ist gelegentlich hier

    Registriert:
    14. September 2010
    Beiträge:
    38
    Zustimmungen:
    3
    Punkte für Erfolge:
    0
    AW: Dreambox, Oscam + Smargo funzt nicht

    ich bin gerade etwas überfragt.

    ich verwende OSCAM 1.20-unstable_svn build #7943, des GP3 images.

    wenn ich z.B.

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    diese verwende startet die Oscam nicht mehr. Scheint also nicht zu laufen.
    Was fehlt mir?
     
    Zuletzt bearbeitet: 27. Februar 2013
    #3
  5. nsane
    Offline

    nsane Hacker

    Registriert:
    2. Februar 2012
    Beiträge:
    413
    Zustimmungen:
    122
    Punkte für Erfolge:
    43
    AW: Dreambox, Oscam + Smargo funzt nicht

    Starte die oscam mal über die console (mit z.B. putty) dann sollte ein Fehler ausgegeben werden. Nur um auszuschließen, dass du einfach chmod vergessen hast :)
     
    #4
  6. tagchen2
    Offline

    tagchen2 Ist gelegentlich hier

    Registriert:
    14. September 2010
    Beiträge:
    38
    Zustimmungen:
    3
    Punkte für Erfolge:
    0
    AW: Dreambox, Oscam + Smargo funzt nicht

    Recht setzte ich mit Totalcommander immer auf 755, wenn ich z.b. die oscam datei im Ordner austausche.
    vorher nenne ich die datei in oscam_1.20 um.

    Mit welcher Eingabe starte ich die Oscam über putty?

    /usr/bin/oscam -b
    klappt nicht (not found)

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    diese 2 laufen z.b. aber was ist der Unterschied zu der oben im Post? Aber eben immer noch mit meinem Fehler.
     
    Zuletzt bearbeitet: 27. Februar 2013
    #5
  7. tagchen2
    Offline

    tagchen2 Ist gelegentlich hier

    Registriert:
    14. September 2010
    Beiträge:
    38
    Zustimmungen:
    3
    Punkte für Erfolge:
    0
    AW: Dreambox, Oscam + Smargo funzt nicht

    also wenn ich das nun richtig verstehen fehlt mit z.b. libusb mipsel?
    Ich habe mit libusb mal nach installiert (libusb_0-1-r20_mipsel.ipk)


    lsusb -v | grep Serial ging noch nicht
    mit
    cat /proc/bus/usb/devices kommt :

    T: Bus=04 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
    D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
    P: Vendor=0403 ProdID=6001 Rev= 4.00
    S: SerialNumber=Reader Cxxxxx
    C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
    I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=ftdi_sio
    E: Ad=01(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
    E: Ad=82(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

    /dev/ttyUSB0 ist auf chmod 666 gesetzt

    hat jemand diese Datein für mich?
    smargo-util_0.1-r0_mipsel.ipk
    usbutils_0.70-r0_mipsel.ipk
     
    Zuletzt bearbeitet: 28. Februar 2013
    #6

Diese Seite empfehlen