1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem CS mit Oscam: ECM antwortzeit erhöht sich fortlaufend

Dieses Thema im Forum "OScam Archiv" wurde erstellt von mschultzi, 22. Januar 2012.

  1. mschultzi
    Offline

    mschultzi Newbie

    Registriert:
    20. Dezember 2011
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    nach endlosen Seiten mittlerweile gelesen habe, habe ich endlich mein CS server am laufen jedoch gibt es immer noch ein groesseres Problem.

    Ich bin dabei mir einen kleinen Homesharing server aufzubauen (UBUNTU 11.10 mit easymouse 2) mit denen ich meine dreamboxen füttern will.
    Im Moment versuch ich meine Dreambox HD800SE im Netzwerk mit einer HD02 Karte ans laufen zu kriegen. Auf Server und Dreambox lauft Oscam 1.2 und über das CAMD35 Protokoll wird geshart; Nachdem ich Oscam gestartet habe kriege ich alle HD+ Sender Hell mit guten ECM Antwortzeiten von unter 0.5 Sek. Jedoch erhöhen sich diese Zeiten kontinoirlich ins endlose (bei 13 Sek nach ein paar stunden hab ich abgeschaltet). Es muss sich meiner meinung nach nur um eine Kleinigkeit halten, ich komme jedoch leider nicht dahinter

    Hier sind die Konfigfiles für den Server:

    oscam.conf:
    [global]
    nice = -1
    WaitForCards = 1
    ClientTimeout = 5
    CacheDelay = 300
    saveinithistory = 1
    PreferLocalCards = 1

    #[newcamd]
    #Key = 0102030405060708091011121314
    #Port = 34000@1843:003411

    [Camd35]
    port = 10000

    [webif]
    httpport = 8888
    httpuser = user
    httppwd = pw
    httprefresh = 10
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255

    [cccam]
    port = 12000
    reshare = 1
    forward_origin_card = 0
    ignorereshare = 0
    version = 2.1.4
    minimizecards = 0
    keepconnected = 1
    stealth = 0
    reshare_mode = 0
    updateinterval = 240

    oscam.server

    [reader]
    label = hd+
    description = HD PLUS
    protocol = mouse
    device = /dev/ttyUSB0
    services = hdplus
    smargopatch = 1
    caid = 1843
    rsakey = BFXXXD5
    boxkey = A7XXX7C
    detect = cd
    mhz = 357
    cardmhz = 357
    group = 1
    emmcache = 1,3,2
    ccchop = 2

    oscam.services
    [hhdp]
    caid = 1843
    provid =
    srvid = EF10,EF11,EF14,EF15,EF74,EF75,EF76,EF77,5273,5274,1519

    [hdplus]
    caid = 1843
    provid =
    srvid = EF10,EF11,EF14,EF15,EF74,EF75,EF76,EF77,5273,5274,1519

    oscam.user

    [account]
    user = user
    pwd = pw
    group = 1
    uniq = 1
    monlevel = 1
    au = 1
    services = hdplus
    caid = 1843
    ident = 1843:000000,003411,008011
    cccmaxhops = 2
    cccreshare = 1

    An der Dreambox habe ich folgende Configuration laufen:

    oscam.conf

    [global]
    nice = -1
    WaitForCards = 1
    ClientTimeout = 5
    CacheDelay = 0
    saveinithistory = 1
    PreferLocalCards = 1


    [Camd35]
    port = 10000

    [webif]
    httpport = 8888
    httpuser = user
    httppwd = pw
    httprefresh = 10
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255


    [dvbapi]
    enabled = 1
    user = user
    #socket = /tmp/camd.socket
    boxtype = dreambox
    prnt_mode = 0

    oscam.server
    [reader]
    label = hd+
    enable = 1
    protocol = camd35
    device = 192.168.2.205,10000
    account = user,pwr
    group = 1

    oscam.user

    [account]
    user = user
    group = 1
    au = 1

    LOG:

    2012/01/22 14:17:40 0 s can't open file "/var/keys/oscam.provid" (err=2 No such file or directory), no provids's loaded
    2012/01/22 14:17:40 0 s can't open file "/var/keys/oscam.ird" (errno=2 No such file or directory) irdeto guessing not loaded
    2012/01/22 14:17:40 0 s can't open whitelist file /var/keys/oscam.whitelist
    2012/01/22 14:17:40 0 s Starting listener 0
    2012/01/22 14:17:40 0 s monitor: disabled
    2012/01/22 14:17:40 0 s Starting listener 0
    2012/01/22 14:17:40 0 s camd35: initialized (fd=5, port=10000)
    2012/01/22 14:17:40 0 s Starting listener 0
    2012/01/22 14:17:40 0 s cs378x: disabled
    2012/01/22 14:17:40 0 s Starting listener 0
    2012/01/22 14:17:40 0 s newcamd: disabled
    2012/01/22 14:17:40 0 s Starting listener 0
    2012/01/22 14:17:40 0 s cccam: initialized (fd=6, port=12000, crypted)
    2012/01/22 14:17:40 0 s Starting listener 0
    2012/01/22 14:17:40 0 s pandora: disabled
    2012/01/22 14:17:40 0 s Starting listener 0
    2012/01/22 14:17:40 0 s csp: disabled
    2012/01/22 14:17:40 0 s Starting listener 0
    2012/01/22 14:17:40 0 s radegast: disabled
    2012/01/22 14:17:40 0 s starting thread http
    2012/01/22 14:17:40 0 s http thread started
    2012/01/22 14:17:40 0 s starting thread reader check
    2012/01/22 14:17:40 0 s reader check thread started
    2012/01/22 14:17:40 0 s starting thread check
    2012/01/22 14:17:40 885B20 h HTTP Server listening on port 8888
    2012/01/22 14:17:40 0 s check thread started
    2012/01/22 14:17:40 0 s creating thread for device /dev/ttyUSB0
    2012/01/22 14:17:40 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2012/01/22 14:17:40 0 s waiting for local card init
    2012/01/22 14:17:43 88AF30 r reader hd+ initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
    2012/01/22 14:17:43 88AF30 r hd+ card detected
    2012/01/22 14:17:47 88AF30 r ATR: 3F ......
    2012/01/22 14:17:49 88AF30 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
    2012/01/22 14:17:50 88AF30 r detect native nagra card
    2012/01/22 14:17:50 88AF30 r [nagra-reader] type: NAGRA, caid: 1843, IRD ID: FF FF FF FF
    2012/01/22 14:17:50 88AF30 r [nagra-reader] ProviderID: 00 00 34 11
    2012/01/22 14:17:50 88AF30 r [nagra-reader] active to: 2012/03/14 11:59
    2012/01/22 14:17:51 88AF30 r -----------------------------------------
    2012/01/22 14:17:51 88AF30 r |id |tier |valid from |valid to |
    2012/01/22 14:17:51 88AF30 r +----+--------+------------+------------+
    2012/01/22 14:17:51 88AF30 r |8011|0066 |2011/10/03 |2012/10/03 |
    2012/01/22 14:17:51 88AF30 r |8011|0067 |2010/01/19 |2010/01/20 |
    2012/01/22 14:17:51 88AF30 r -----------------------------------------
    2012/01/22 14:17:51 88AF30 r WARNING: For NAGRA2 cards you will have to set 'cardmhz = 368' in oscam.server
    2012/01/22 14:17:51 88AF30 r found cardsystem nagra
    2012/01/22 14:17:51 88AF30 r ROM: D N A S P 1 8 0
    2012/01/22 14:17:51 88AF30 r REV: M e r 0 0 0
    2012/01/22 14:17:51 88AF30 r SER: 4xxxD
    2012/01/22 14:17:51 88AF30 r CAID: 1843
    2012/01/22 14:17:51 88AF30 r Prv.ID: 00 00 34 11 (sysid)
    2012/01/22 14:17:51 88AF30 r Prv.ID: 00 00 00 00
    2012/01/22 14:17:51 88AF30 r Prv.ID: 00 00 80 11
    2012/01/22 14:17:51 88AF30 r [nagra-reader] ready for requests
    2012/01/22 14:17:52 0 s init for all local cards done
    2012/01/22 14:17:52 0 s anti cascading disabled

    2012/01/22 14:19:19 8D1600 c encrypted camd35-client 192.168.2.204 granted (user, au=auto (1 reader))
    2012/01/22 14:19:19 8D1600 c user emm-request sent (reader=hd+, caid=1843, auprovid=003411)
    2012/01/22 14:19:19 8D1600 c user (1843&000000/EF75/89:4324): found (399 ms) by hd+
    2012/01/22 14:19:24 8D1600 c user (1843&000000/EF75/89:EB16): found (395 ms) by hd+
    2012/01/22 14:19:31 8D1600 c user (1843&000000/EF75/89:61F5): found (394 ms) by hd+
    2012/01/22 14:19:38 8D1600 c user (1843&000000/EF75/89:DC04): found (400 ms) by hd+
    2012/01/22 14:19:45 8D1600 c user (1843&000000/EF75/89:151C): found (399 ms) by hd+
    2012/01/22 14:19:52 8D1600 c user (1843&000000/EF75/89:B3FC): found (405 ms) by hd+
    2012/01/22 14:19:59 8D1600 c user (1843&000000/EF75/89:3999): found (420 ms) by hd+
    2012/01/22 14:20:06 8D1600 c user (1843&000000/EF75/89:BE37): found (409 ms) by hd+
    2012/01/22 14:20:13 8D1600 c user (1843&000000/EF75/89:B0B9): found (406 ms) by hd+
    2012/01/22 14:20:20 8D1600 c user (1843&000000/EF75/89:923E): found (412 ms) by hd+
    2012/01/22 14:20:27 8D1600 c user (1843&000000/EF75/89:F4CD): found (412 ms) by hd+
    2012/01/22 14:20:34 8D1600 c user (1843&000000/EF75/89:1CCC): found (416 ms) by hd+
    ....

    Die Zeit geht weiter stetig ins unendliche

    Habe es mit dem CCCAM protokoll versucht, da springt die Zeit nach ein Paar Sekunden sofort auf 3000 ms.

    Hat irgendwer einen Plan woran das liegen könnte ?????
     
    Zuletzt von einem Moderator bearbeitet: 22. Januar 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. stinker2010
    Offline

    stinker2010 Freak

    Registriert:
    13. August 2010
    Beiträge:
    247
    Zustimmungen:
    79
    Punkte für Erfolge:
    28
    Die Konfig sieht soweit gut aus.

    Auf dem Server:
    cardmhz = 368

    Hast du es mal mit der 1.1 stable versucht? Kompilierst du die oscam selbst?

    Gruß
     
    #2
  4. mschultzi
    Offline

    mschultzi Newbie

    Registriert:
    20. Dezember 2011
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: CS mit Oscam: ECM antwortzeit erhöht sich fortlaufend

    Ich habe OScam auf dem Server mit der letzten Version selbst compiliert.
    Ich versuche trotzdem mal eine vorkompilierte version 1.1 stable
     
    #3
  5. stinker2010
    Offline

    stinker2010 Freak

    Registriert:
    13. August 2010
    Beiträge:
    247
    Zustimmungen:
    79
    Punkte für Erfolge:
    28
    Im Server:
    - smargopatch löschen

    Dann würde ich mal mit einer grundkonfig anfangen, also ohne idents, caid, Services, etc. eben nur das nötigste.
     
    #4
  6. mschultzi
    Offline

    mschultzi Newbie

    Registriert:
    20. Dezember 2011
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: CS mit Oscam: ECM antwortzeit erhöht sich fortlaufend

    Stinker2010 vielen Dank,

    Dein tipp mit der version 1.10 war gold wert.
    Habe auf die Box und auf den Server version 1.10 draufgesetzt und das Ding schnurt jetzt wie ein Kätzchen under 0.4 Sek
    Problem gelöst, Danke für die Hilfe
     
    #5

Diese Seite empfehlen