1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Clients verbinden sich, aber Bild bleibt dunkel

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von ricohs, 6. Januar 2013.

  1. ricohs
    Offline

    ricohs Ist gelegentlich hier

    Registriert:
    21. September 2009
    Beiträge:
    82
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    Hallo,

    ich habe jetzt lange ausprobiert um von CCCam auf oscam zu wechseln, ich habe jetzt das problem, das die clients zwar conectet sind aber das Bild bleibt Dunkel, ich benutze einen smardcardreader.
    meine config:
    [global]
    logfile = /var/media/ftp/uStor01/oscam.log
    clienttimeout = 2000
    fallbacktimeout = 1000
    bindwait = 5
    nice = -5
    preferlocalcards = 1
    saveinithistory = 1
    lb_mode = 1
    lb_save = 100
    lb_savepath = /var/media/ftp/uStor01/cs/oscam/stat
    lb_max_readers = 1
    lb_auto_betatunnel = 0

    [cs357x]
    port = 12000

    [webif]
    httpport = 16000
    httprefresh = 7
    httpallowed = 192.168.179.1-192.168.179.255

    [cccam]
    port = 12000
    reshare = 1
    ignorereshare = 0
    version = 2.2.1
    reshare_mode = 1
     
    Zuletzt von einem Moderator bearbeitet: 6. Januar 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. Kermit
    Offline

    Kermit Guest

    AW: Clients verbinden sich, aber Bild bleibt dunkel

    Hi,

    zur Konfig gehört nicht nur die oscam.conf sondern auch die oscam.server und die oscam.user. Um dir helfen zu können solltest du diese Angaben noch posten und das Logfile ebenso.

    Grüße

    Kermit
     
    #2
  4. ricohs
    Offline

    ricohs Ist gelegentlich hier

    Registriert:
    21. September 2009
    Beiträge:
    82
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    AW: Clients verbinden sich, aber Bild bleibt dunkel

    hier meine oscam.server:
    # oscam.server generated automatically by Streamboard OSCAM 1.20-unstable_by_EasyBuild_svn build #6586
    # Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [reader]
    label = sky
    protocol = mouse
    device = /dev/ttyUSB0
    services = sky,!sky,sky-hd,!sky-hd,sky-ppv,!sky-ppv,sky-bb,!sky-bb,fta,!fta,sky-3d,austriasat,!austriasat
    smargopatch = 1
    caid = 09C4
    boxid = 12345678
    boxkey = 1122334455667788
    detect = cd
    nagra_read = 1
    mhz = 500
    cardmhz = 500
    group = 1
    emmcache = 1,3,2


    und hier meine oscam.user:

    # oscam.user generated automatically by Streamboard OSCAM 1.20-unstable_by_EasyBuild_svn build #6586
    # Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [account]
    user = uxxxxxxx
    pwd = pxxxxxx
    group = 1
    monlevel = 4
    au = 1

    [account]
    user = cxxxxxx
    pwd = axxxxxx
    group = 1
    monlevel = 4
    cccignorereshare = 0

    ich hoffe das mit dem Spoiler hat jetzt funktioniert.

    ricohs

    - - - Aktualisiert - - -

    hier noch ein paar daten:

    das bringt er wenn ich oscam starte:

    rm: can't remove '/dev/ttyUSB0': No such file or directory rm: can't remove '/dev/ttyUSB1': No such file or directory rm: can't remove '/dev/ttyUSB2': No such file or directory rm: can't remove '/dev/ttyUSB3': No such file or directory rm: can't remove '/dev/ttyUSB4': No such file or directory rm: can't remove '/dev/ttyUSB5': No such file or directory rm: can't remove '/dev/ttyUSB6': No such file or directory rm: can't remove '/dev/ttyUSB7': No such file or directory rm: can't remove '/dev/ttyUSB8': No such file or directory rm: can't remove '/dev/ttyUSB9': No such file or directory Starte oscam... USB-Serial Module geladen oscam erfolgreich gestartet !

    und das sind Logfiles aus dem Webinterface:

    2013/01/06 09:10:10 0 s starting thread log_list_thread
    2013/01/06 09:10:10 0 s log_list_thread thread started
    2013/01/06 09:10:10 0 s >> OSCam << cardserver started, version 1.20-unstable_by_EasyBuild_svn, build #6586 (mipsel-router-linux-uclibc929)
    2013/01/06 09:10:10 0 s version=1.20-unstable_by_EasyBuild_svn, build #6586, system=mipsel-router-linux, nice=-5
    2013/01/06 09:10:10 0 s client max. idle=120 sec, debug level=0
    2013/01/06 09:10:10 0 s max. logsize=10 Kb, loghistorysize=4096 bytes
    2013/01/06 09:10:10 0 s client timeout=2000 ms, fallback timeout=1000 ms, cache delay=0 ms
    2013/01/06 09:10:10 0 s WARNING: fallbacktimeout adjusted to 1600 ms (must be greater than serialreadertimeout (1500 ms))
    2013/01/06 09:10:11 0 s services reloaded: 0 services freed, 8 services loaded, rejected 0
    2013/01/06 09:10:11 0 s userdb reloaded: 9 accounts loaded, 0 expired, 0 disabled
    2013/01/06 09:10:11 0 s signal handling initialized (type=sysv)
    2013/01/06 09:10:11 0 s 144 service-id's loaded in 98ms
    2013/01/06 09:10:11 0 s 116 tier-id's loaded
    2013/01/06 09:10:11 0 s 56 provid's loaded
    2013/01/06 09:10:11 0 s 22 lengths for caid guessing loaded
    2013/01/06 09:10:12 0 s can't open whitelist file /var/media/ftp/uStor01/cs/oscam/oscam.whitelist
    2013/01/06 09:10:12 0 s can't open cacheex-matcher file /var/media/ftp/uStor01/cs/oscam/oscam.cacheex
    2013/01/06 09:10:12 0 s Starting listener 0
    2013/01/06 09:10:12 0 s monitor: disabled
    2013/01/06 09:10:12 0 s Starting listener 0
    2013/01/06 09:10:12 0 s camd33: disabled
    2013/01/06 09:10:12 0 s Starting listener 0
    2013/01/06 09:10:12 0 s camd35: initialized (fd=7, port=12000)
    2013/01/06 09:10:12 0 s Starting listener 0
    2013/01/06 09:10:12 0 s cs378x: disabled
    2013/01/06 09:10:12 0 s Starting listener 0
    2013/01/06 09:10:12 0 s newcamd: disabled
    2013/01/06 09:10:12 0 s Starting listener 0
    2013/01/06 09:10:12 0 s cccam: initialized (fd=8, port=12000, crypted)
    2013/01/06 09:10:12 0 s Starting listener 0
    2013/01/06 09:10:12 0 s pandora: disabled
    2013/01/06 09:10:12 0 s Starting listener 0
    2013/01/06 09:10:12 0 s csp: disabled
    2013/01/06 09:10:12 0 s Starting listener 0
    2013/01/06 09:10:12 0 s radegast: disabled
    2013/01/06 09:10:12 0 s starting thread http
    2013/01/06 09:10:12 0 s http thread started
    2013/01/06 09:10:12 0 s starting thread reader check
    2013/01/06 09:10:12 0 s reader check thread started
    2013/01/06 09:10:12 0 s starting thread check
    2013/01/06 09:10:12 0 s check thread started
    2013/01/06 09:10:12 0 s creating thread for device /dev/ttyUSB0
    2013/01/06 09:10:12 0 s loadbalancer: can't read from file /var/media/ftp/uStor01/cs/oscam/stat
    2013/01/06 09:10:12 0 s waiting for local card init
    2013/01/06 09:10:12 5D06E0 h HTTP Server listening on port 16000
    2013/01/06 09:10:12 5CEEE8 r ERROR opening device /dev/ttyUSB0 (errno=19 No such device)
    2013/01/06 09:10:12 5CEEE8 r Cannot open device: /dev/ttyUSB0
    2013/01/06 09:11:12 5CEEE8 r ERROR opening device /dev/ttyUSB0 (errno=19 No such device)
    2013/01/06 09:11:12 5CEEE8 r Cannot open device: /dev/ttyUSB0
    2013/01/06 09:12:12 5CEEE8 r ERROR opening device /dev/ttyUSB0 (errno=19 No such device)
    2013/01/06 09:12:12 5CEEE8 r Cannot open device: /dev/ttyUSB0

    ich hoffe das reicht
     
    #3
  5. Kermit
    Offline

    Kermit Guest

    AW: Clients verbinden sich, aber Bild bleibt dunkel

    Hi,
    mit deinem Reader bin ich nicht ganz einverstanden. Für den Anfang lass die Services weg und versuch es mal mit dem Reader
    [reader]
    label = sky
    protocol = mouse
    device = /dev/ttyUSB0
    caid = 09C4
    boxid = 12345678
    detect = cd
    mhz = 357
    cardmhz = 357
    group = 1
    emmcache = 1,1,2

    Grüße

    Kermit

    Edit:
    Auf was für einer Plattform läuft OScam? Da fehlt der passende Treiber ftdi_sio oder den Samrgo über das samrtreader Protokoll ansprechen mit dem passendem Device.
     
    Zuletzt von einem Moderator bearbeitet: 6. Januar 2013
    #4
  6. 4gx35
    Offline

    4gx35 VIP

    Registriert:
    18. Mai 2010
    Beiträge:
    16.777
    Zustimmungen:
    4.587
    Punkte für Erfolge:
    113
    AW: Clients verbinden sich, aber Bild bleibt dunkel

    wichtig: entferne mal alle services aus dem reader,
    du hast die Verwendung von Services noch nicht verstanden,
     
    #5
  7. ricohs
    Offline

    ricohs Ist gelegentlich hier

    Registriert:
    21. September 2009
    Beiträge:
    82
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    AW: Clients verbinden sich, aber Bild bleibt dunkel

    Erstmal danke das ihr mir da ein bischen unter die Arme greift. Bisher habe ich über CCCam HS gemacht was wunderbar ging, jetzt kam meine HD+ karte (HD01) die ich einbinden wollte. Ich habe 2 Smargo reader und folgendes Image:

    freetz-devel-8879

    ich habe den oscam.server jetzt wie folgt eingetragen:

    [reader]
    label = sky
    protocol = mouse
    device = /dev/ttyUSB0
    caid = 09C4
    boxid = 12345678
    detect = cd
    mhz = 357
    cardmhz = 357
    group = 1
    emmcache = 1,1,2

    und das steht in der config übersicht:
    USB Comport (Treiberauswahl) USB Comport mit einem Treiber aktivieren
    FDD_SIOI Modul waehlen

    FTDI + PL2303 Treiber gemeinsam

    Card-Reader-Treiber neu laden

    ricohs

    - - - Aktualisiert - - -

    ich meine OSCAM übersicht
     
    #6

Diese Seite empfehlen