1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Card non letta

Dieses Thema im Forum "OScam (Italiana)" wurde erstellt von kelsall, 6. November 2012.

  1. kelsall
    Offline

    kelsall Newbie

    Registriert:
    17. Oktober 2012
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Salve a tutti, finora ho usato la oscam 4929 per un inet 300 e non ho avuto alcun problema, però se metto quelle superiori la card locale s*y non viene letta dalla Oscam.
    Una volta installato il binario se avvio la oscam da decoder non ci sono problemi ma se faccio un reboot la locale non viene letta.

    Dopo varie configurazioni mi sono reso conto che la card viene letta solo con oscam pura.
    Fino alla 4929 è tutto ok con oscam-cccam, con quelle successive, almeno con le configurazioni usate, la card non viene letta con l'accoppiata, ma solo usando il dvbapi...
    Qualche suggerimento?

    La configurazione è questa:

    Conf.

    [global]
    nice = -1
    WaitForCards = 0
    ClientTimeout = 5
    CacheDelay = 120
    saveinithistory = 1
    PreferLocalCards = 1

    [webif]
    httpport = 16002
    #httpuser = xxxxxx
    #httppwd = pass
    httprefresh = 5
    httpallowed = 127.0.0.1,192.168.1.1-192.168.1.200

    [cs357x]
    port=35000@093b:000000
    server = 192.168.1.100


    [reader]
    Enable = 1
    Label = sky093b
    Protocol = internal
    device = /dev/sci0
    #Mhz = 1200
    #Cardmhz = 357
    Group = 1
    Caid = 093b
    Ident = 093b:000000
    EmmCache = 1,3,2
    boxid = 01020304
    blockemm-u = 1
    blockemm-unknown = 1
    blockemm-s = 1
    blockemm-g = 1


    [account]
    user = sala
    pwd = pass
    group = 1
    uniq = 4
    monlevel = 0
    au = skyitalia
    caid = 093B
    ident = 093B:000000

    Questo è l'errore:

    1/11/2012 08:40:43 10183670 r skyitalia [internal] ERROR: Opening device /dev/sci0 (errno:16 Device or resource busy)
    1/11/2012 08:40:43 10183670 r skyitalia [internal] Cannot open device: /dev/sci0
     
    Zuletzt von einem Moderator bearbeitet: 7. November 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Card non letta

    Metti queste configs -->

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Devi solo cambiare il caid!
     
    #2
  4. kelsall
    Offline

    kelsall Newbie

    Registriert:
    17. Oktober 2012
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Card non letta

    Con questa configurazione non solo non legge la card ma non vedo neanche gli user.




     
    Zuletzt bearbeitet: 6. November 2012
    #3
  5. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Card non letta

    Posta un oscam LOG.
     
    #4
  6. kelsall
    Offline

    kelsall Newbie

    Registriert:
    17. Oktober 2012
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Card non letta

    ciao, qusto è il log:

    Code:
    >> OSCam <<  cardserver started at Thu Jan  1 01:00:22 1970
    -------------------------------------------------------------------------------
    1/01/1970 01:00:22        0 s starting thread log_list_thread
     1/01/1970 01:00:22        0 s log_list_thread thread started
     1/01/1970 01:00:22        0 s >> OSCam <<  cardserver  started, version 1.20-unstable_svn, build #7855  (powerpc-tuxbox-linux-gnu), compiled by DAX
     1/01/1970 01:00:22        0 s version=1.20-unstable_svn, build #7855, system=powerpc-tuxbox-linux-gnu, nice=-19
     1/01/1970 01:00:22        0 s client max. idle=120 sec, debug level=0, filter_sensitive=1
     1/01/1970 01:00:22        0 s max. logsize=50 Kb, loghistorysize=4096 bytes
     1/01/1970 01:00:22        0 s client timeout=5000 ms, fallback timeout=2000 ms, cache delay=120 ms
     1/01/1970 01:00:22        0 s The current system time is smaller than  the build date (Nov  4 2012). Waiting up to 60 seconds for time to  correct
     8/11/2012 06:40:54        0 s services reloaded: 0 services freed, 27 services loaded, rejected 0
     8/11/2012 06:40:54        0 s userdb reloaded: 6 accounts loaded, 0 expired, 0 disabled
     8/11/2012 06:40:54        0 s signal handling initialized (type=sysv)
     8/11/2012 06:40:54        0 s 1162 service-id's loaded in 57ms
     8/11/2012 06:40:54        0 s 53 tier-id's loaded
     8/11/2012 06:40:54        0 s ERROR: Cannot open file "/var/tuxbox/config/oscam.provid" (errno=2 No such file or directory)
     8/11/2012 06:40:54        0 s ERROR: Cannot open file "/var/tuxbox/config/oscam.guess" (errno=2 No such file or directory)
     8/11/2012 06:40:54        0 s ERROR: Cannot open file "/var/tuxbox/config/oscam.ird" (errno=2 No such file or directory)
     8/11/2012 06:40:54        0 s ERROR: Cannot open file "/var/tuxbox/config/oscam.whitelist" (errno=2 No such file or directory)
     8/11/2012 06:40:54        0 s ERROR: Cannot open file "/var/tuxbox/config/oscam.cacheex" (errno=2 No such file or directory)
     8/11/2012 06:40:54        0 s Starting listener 0
     8/11/2012 06:40:54        0 s monitor: disabled
     8/11/2012 06:40:54        0 s Starting listener 0
     8/11/2012 06:40:54        0 s camd35: initialized (fd=5, port=35000)
     8/11/2012 06:40:54        0 s Starting listener 0
     8/11/2012 06:40:54        0 s cs378x: disabled
     8/11/2012 06:40:54        0 s Starting listener 0
     8/11/2012 06:40:54        0 s newcamd: initialized (fd=6, port=34000, crypted)
     8/11/2012 06:40:54        0 s -> CAID: 09CD PROVID: 000000
     8/11/2012 06:40:54        0 s Starting listener 1
     8/11/2012 06:40:54        0 s newcamd: initialized (fd=7, port=34001, crypted)
     8/11/2012 06:40:54        0 s -> CAID: 093B PROVID: 000000
     8/11/2012 06:40:54        0 s Starting listener 2
     8/11/2012 06:40:54        0 s newcamd: initialized (fd=8, port=34002, crypted)
     8/11/2012 06:40:54        0 s -> CAID: 183D PROVID: 005411, 000000
     8/11/2012 06:40:54        0 s Starting listener 3
     8/11/2012 06:40:54        0 s newcamd: initialized (fd=9, port=34003, crypted)
     8/11/2012 06:40:54        0 s -> CAID: 0500 PROVID: 042700, 041700, 042200, 040810
     8/11/2012 06:40:54        0 s Starting listener 4
     8/11/2012 06:40:54        0 s newcamd: initialized (fd=10, port=34004, crypted)
     8/11/2012 06:40:54        0 s -> CAID: 1702 PROVID: 000000
     8/11/2012 06:40:54        0 s Starting listener 0
     8/11/2012 06:40:54        0 s cccam: initialized (fd=11, port=12000, crypted)
     8/11/2012 06:40:54        0 s Starting listener 0
     8/11/2012 06:40:54        0 s pandora: disabled
     8/11/2012 06:40:54        0 s Starting listener 0
     8/11/2012 06:40:54        0 s csp: disabled
     8/11/2012 06:40:54        0 s Starting listener 0
     8/11/2012 06:40:54        0 s radegast: disabled
     8/11/2012 06:40:54        0 s starting thread http
     8/11/2012 06:40:54        0 s http thread started
     8/11/2012 06:40:54        0 s starting thread reader check
     8/11/2012 06:40:54        0 s reader check thread started
     8/11/2012 06:40:54        0 s starting thread check
     8/11/2012 06:40:54        0 s check thread started
     8/11/2012 06:40:54        0 s skyitalia [internal] creating thread for device /dev/sci0
     8/11/2012 06:40:54        0 s pippo [cccam] creating thread for devicexxxxxx.zzzzzz.com
     8/11/2012 06:40:54        0 s pluto [cccam] creating thread for device  yyyyyy.yyyyyy.org:
     8/11/2012 06:40:54        0 s loadbalancer: can't read from file /tmp/.oscam/stat
     8/11/2012 06:40:54        0 s anti cascading disabled
     8/11/2012 06:40:54 101B31C0 h HTTP Server listening on port 16003
     8/11/2012 06:40:54 10184670 r skyitalia [internal] ERROR: Opening device /dev/sci0 (errno:16 Device or resource busy)
     8/11/2012 06:40:54 10184670 r skyitalia [internal] Cannot open device: /dev/sci0
     8/11/2012 06:40:54 10185ED0 p xxxxxx.zzzzzz.com: resolved ip=qqq.343.248.19
     8/11/2012 06:40:54 10185ED0 p pippo[cccam] connecting to xxxxxx.zzzzzz.com:12000
     8/11/2012 06:40:54 101B1960 p yyyyy.yyyyy.org: resolved ip=23.43.yy.yyy
     8/11/2012 06:40:54 101B1960 p pluto [cccam] connecting to yyyyyy.yyyyyy.org:45040
     8/11/2012 06:40:54 10185ED0 p pippo [cccam] proxy initialized, server xxxxxx.zzzzzz.com:12000
     8/11/2012 06:40:54 101B1960 p pluto [cccam] proxy initialized, server yyyyyy.yyyyyy.org:45040
     8/11/2012 06:40:58 101D0A18 c yyyyyy.yyyyyy.org: resolved ip=23.43.yy.yyy
     8/11/2012 06:40:58 101D0A18 c encrypted cccam-client 23.43.yy.yyy granted (pluto, au=auto (3 reader))
     8/11/2012 06:41:01 101D81C8 c encrypted camd35-client 192.168.1.100 granted (salone, au=auto (3 reader))
     8/11/2012 06:41:02 101D81C8 c salone (183D&000000/0000/2140/8C:539D): found (210 ms) by pluto
     
    Zuletzt von einem Moderator bearbeitet: 8. November 2012
    #5
  7. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Card non letta

    Che neanche non vedi gli user non puo essere, altrimenti non ci sarebbe questo:

    Code:
    8/11/2012 06:40:58 101D0A18 c [COLOR=#ff0000]encrypted cccam-client[/COLOR] 23.43.yy.yyy granted (pluto, au=auto (3 reader))
     8/11/2012 06:41:01 101D81C8 c [COLOR=#ff0000]encrypted camd35-client[/COLOR] 192.168.1.100 granted (salone, au=auto (3 reader))
    Ma che hai due carte? Come sono collegati?

    Code:
    8/11/2012 06:40:54        0 s newcamd: initialized (fd=6, port=34000, crypted)
      8/11/2012 06:40:54        0 s -> CAID: [COLOR=#ff0000]09CD[/COLOR] PROVID: 000000
      8/11/2012 06:40:54        0 s Starting listener 1
      8/11/2012 06:40:54        0 s newcamd: initialized (fd=7, port=34001, crypted)
      8/11/2012 06:40:54        0 s -> CAID: [COLOR=#ff0000]093B[/COLOR] PROVID: 000000
     
    #6
  8. kelsall
    Offline

    kelsall Newbie

    Registriert:
    17. Oktober 2012
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Card non letta

    Ciao chiedo scusa se rispondo solo ora, ma non ho avuto tmpo per collegarmi.
    Ho fatto un po di prove e ho notato che:

    1) Installo il binario dll'oscam, la rinomino e riavvio da telecomando la nuova oscam ed è tutto ok, nel senso che sia la locale che la remoto vengono riconosciute e lette.
    2) Ora se faccio un reboot del dec la locale non viene riconosciuta mentre per la remoto non ci sono problmi.Per la locale sulla webinf appare unknowen(no entitlemnts).

    3) Dopo il reboot, quindi locale non ltta dalla oscam, disabilito da telecomando la 3C rilancio la oscam e a questo punto la card viene riconosciuta e riavviando di nuovo la 3C la visione è Ok.

    Deduco quindi che facendo il rboot anche se la oscam si avvia prima della 3C, quest'ultima prende il sopravvento sulla lettura della card e quindi l'errore che da il log dell'oscam

    1/11/2012 08:40:43 10183670 r skyitalia [internal] ERROR: Opening device /dev/sci0 (errno:16 Device or resource busy)
    1/11/2012 08:40:43 10183670 r skyitalia [internal] Cannot open device: /dev/sci0

    è normale. La traduzione infatti è questa: (err. no: 16 Dispositivo o risorsa occupata) proprio perchè la 3C lgge per prima la card locale.

    L'ultima oscam che non da i problemi su descritti è qusta:eek:scam-1.00-trunk-svn4929-ppc.tar.gz.
    Come posso rimediare?

    Provo a darmi una risposta da solo:
    servirebbe uno script d'avvio che ritardi l'avvio della 3C e quindi dia il tempo alla oscam di leggere la card.
     
    Zuletzt bearbeitet: 11. November 2012
    #7
  9. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Card non letta

    Posta perfavore il script che fa avviare la oscam/cccam.

    penso che li il parametro sleep e troppo basso.
     
    #8
  10. kelsall
    Offline

    kelsall Newbie

    Registriert:
    17. Oktober 2012
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Card non letta

    Ciao
    mi servirebbe uno scriptt della oscam che sincronizzi l'orario prima che parta il binario...


    start)
    /var/bin/ntpdate ntp1.inrim.it >/dev/null &
    sleep 1
    /var/bin/oscam_r6454 -b -c /var/tuxbox/config -r 2 &

    Questo è lo script, ma vorrei capire quale cartelle modificare per far sincronizzare l'ora prima che si avvii l'oscam...
     
    #9
  11. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Card non letta

    Per l´orario non ti posso aiutare. Pero non capisco perche voui sincronizzare l´orario? Viene gia fatto dal transponder!
     
    #10
  12. kelsall
    Offline

    kelsall Newbie

    Registriert:
    17. Oktober 2012
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Card non letta

    Si viene fatto dal transponder ma solo dopo che si avvia l'oscam e non trovando l'orario giusto non legge la card e a questo punto la cccam prende il sopravvento, si tratta di attimi.
    Lo script dovrebbe invece far partire prima la sincronizzazione dell'orario e poi l'avvio dell'oscam.
     
    #11
  13. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Card non letta

    L´orario non a niente che fare con il script.

    Ma il script per avviare la oscam / cccam lo puoi postare?

    Quello che mi hai postato non e il scipt per avviare.

    Un Startscript e per esempio cosi:

    Code:
    #!/bin/sh
    CAMD_ID=1793
    CAMD_NAME="OSCam"
    CAMD_BIN=oscam
     
    INFOFILE_A=ecm0.info
    INFOFILE_B=ecm1.info
    INFOFILE_C=ecm2.info
    INFOFILE_D=ecm3.info
    #Expert window
    INFOFILE_LINES=1111111111000000
    #Zapp after start
    REZAPP=0
     
    ########################################
     
    logger $0 $1
    echo $0 $1
     
    remove_tmp () {
      rm -rf /tmp/*.info* /tmp/*.tmp*
    }
     
    case "$1" in
        start)
            remove_tmp
            /usr/bin/$CAMD_BIN -c /var/keys &
            ;;
        stop)
            killall -9 $CAMD_BIN 2>/dev/null
            sleep 2
            remove_tmp
            ;;
        *)
            $0 stop
            exit 0
            ;;
    esac
    exit 0
    
     
    #12
  14. kelsall
    Offline

    kelsall Newbie

    Registriert:
    17. Oktober 2012
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Card non letta

    Questo per avviare l'oscam

    Code:
    #!/bin/sh
    #emuname=Oscam r6454
    #ecminfofile=ecm.info
    
    case "$1" in 
     start)
     #/var/bin/ntpdate ntp1.inrim.it >/dev/null &
     #sleep 1 
    /var/bin/oscam_r6454 -b -c /var/tuxbox/config -r 2 &
                 sleep 3
     ;;        
     stop)
      killall -9 oscam_r6454
      sleep 2
     ;;
     *)
      $0 stop
      exit 1
     ;;
    esac
    exit 1
    
    e questo per la 3C:

    Code:
    #!/bin/sh
    #emuname=CCcam 2.2.1
    #ecminfofile=ecm.info
    remove_tmp () {
     rm -rf /tmp/ecm.info /tmp/ecm0.info /tmp/pid.info /tmp/cardinfo
    }
    case "$1" in
     start)
     remove_tmp
     sleep 1  #1
     /bin/CCcam_2.2.1 &
     sleep 3 #3
     ;;
     stop)
     touch /tmp/CCcam.kill
     sleep 3  #3
     killall -9 CCcam_2.2.1 2>/dev/null
     sleep 2   #2
     remove_tmp
     ;;
     *)
     $0 stop
     exit 5  #1
     ;;
     
    esac
    exit 0
     
    Zuletzt von einem Moderator bearbeitet: 14. November 2012
    #13
  15. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Card non letta

    Metti cosi:


    Code:
    #!/bin/sh
     
    CAMNAME="CCcam/OScam"
    USERNAME=""
    ZAPTIME=6
    CAMID=6371
    DVBSET=0
    INFOFILE="ecm.info"
    INFOFILELINES=
    # end
     
    remove_tmp () {
      rm -rf /tmp/*.info* /tmp/*.tmp*
    }
     
    case "$1" in
      start)
      echo "[SCRIPT] $1: $CAMNAME"
      remove_tmp
      /var/bin/oscam_r6454 &
      sleep 15
      /var/bin/CCcam_2.2.1 &
      ;;
      stop)
      echo "[SCRIPT] $1: $CAMNAME"
      kill `pidof oscam_1.00 `
      killall oscam_r6454 CCcam_2.2.1 2>/dev/null
      sleep 2
      remove_tmp
      ;;
      *)
      $0 stop
      exit 0
      ;;
    esac
     
    exit 0
     
    
     
    #14
  16. kelsall
    Offline

    kelsall Newbie

    Registriert:
    17. Oktober 2012
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: Card non letta

    Nemmeno così legge la card..., cmq ho risolto mettendo nel config. della cccam SCIDEVICES:0.
     
    #15

Diese Seite empfehlen