1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst Autostart abschalten geht nicht in 11.5

Dieses Thema im Forum "IPC" wurde erstellt von sp3ct3r, 13. Dezember 2012.

  1. sp3ct3r
    Offline

    sp3ct3r Ist oft hier

    Registriert:
    23. Juni 2009
    Beiträge:
    126
    Zustimmungen:
    9
    Punkte für Erfolge:
    0
    Irgendwie lässt sich der Autostart der EMUs nicht abschalten.
    Hier mal die rc.local
    Code:
    #!/bin/sh -e
    #
    # rc.local
    #
    # Zum Autostarten eines Emu's einfach "#" am Anfang der Zeile entfernen
    
    #Camd3 starten
    /bin/camd3 start &
    
    #OScam starten
    /bin/oscam start &
    
    #CCcam starten
    #/bin/cccam start &
    
    #NewCS starten
    #/bin/newcs start &
    
    #sBox starten
    #/bin/sbox start &
    
    
    exit 0
    
    
    CCCam, NewCS und sBoxwerden trotzdem gestartet. Bearbeitet hab ich die rc.local mit putty "ipc as".
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. jensebub
    Offline

    jensebub Stamm User

    Registriert:
    8. Mai 2010
    Beiträge:
    1.059
    Zustimmungen:
    1.717
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    hab ich
    Ort:
    abvomweltlichen
    AW: Autostart abschalten geht nicht in 11.5

    Das liegt nicht am Autostart, sondern wahrscheinlich am jeweiligen watchdog, der das CAM nach einer Minute wieder startet.

    Code:
    i jobs
    ist der Befehl, um in den crontab zu kommen, und da müsstest du die jeweiligen watchdogs deaktiviere.

    Gruß
    jensebub
     
    #2
    al-x83, szonic, bombadil und 3 anderen gefällt das.
  4. sp3ct3r
    Offline

    sp3ct3r Ist oft hier

    Registriert:
    23. Juni 2009
    Beiträge:
    126
    Zustimmungen:
    9
    Punkte für Erfolge:
    0
    AW: Autostart abschalten geht nicht in 11.5

    Danke! Du hattest recht. Das sollte evtl in die Help als Hinweis beim Punkt Autostart mit aufgenommen werden.
     
    #3
  5. jensebub
    Offline

    jensebub Stamm User

    Registriert:
    8. Mai 2010
    Beiträge:
    1.059
    Zustimmungen:
    1.717
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    hab ich
    Ort:
    abvomweltlichen
    AW: Autostart abschalten geht nicht in 11.5

    Es liegt eher an deiner Vorgehensweise, es ist eigentlich angedacht die CAM's, die man nicht verwendet, über i cams abzuschalten,... dabei werden dann auch die Einträge in i as und i jobs automatisch deaktiviert.

    Für den speziellen Anwendungsfall, wie du ihn verwendest, setzt man doch eher das Wissen vorraus, das man weiß, was man macht, dazu gehören auch die watchdogs,...

    Gruß
    jensebub
     
    #4
  6. sp3ct3r
    Offline

    sp3ct3r Ist oft hier

    Registriert:
    23. Juni 2009
    Beiträge:
    126
    Zustimmungen:
    9
    Punkte für Erfolge:
    0
    AW: Autostart abschalten geht nicht in 11.5

    Über i cams wird ja aber gefragt welche Cams installiert sein sollen? Ich will sie ja installiert haben, nur nicht starten. Das 2 verschiedene Dinge in meinen Augen. Oder sind die Cams bei IPC Grundsätzlich alle immer dabei und werden nur auskommentiert?

    Autostart abschalten ist ist doch nix spezielles eher das die Crons standarmässig schon eingerichtet sind ;)
     
    #5
  7. jensebub
    Offline

    jensebub Stamm User

    Registriert:
    8. Mai 2010
    Beiträge:
    1.059
    Zustimmungen:
    1.717
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    hab ich
    Ort:
    abvomweltlichen
    AW: Autostart abschalten geht nicht in 11.5

    aber speziell ist, das CAM's in betrieb sein sollen, und NICHT beim Autostart mitgestartet werden sollen, und auch nicht vom watchdog überwacht werden sollen,...es entspricht ja nicht dem Normalbetrieb, wenn etwas installiert ist und doch nicht verwendet wird,...

    die nicht istallierten CAM's befinden sich im Ordner /var/emu/BACKUP/ und werden beim istallen von i cams in die richtigen Verzeichnisse kopiert.

    Gruß
    jensebub
     
    #6
    bombadil, al-x83 und sp3ct3r gefällt das.
  8. sp3ct3r
    Offline

    sp3ct3r Ist oft hier

    Registriert:
    23. Juni 2009
    Beiträge:
    126
    Zustimmungen:
    9
    Punkte für Erfolge:
    0
    AW: Autostart abschalten geht nicht in 11.5

    zu 1. da hast du natürlich Recht. Hab die nicht benutzen Cams nur zu testzwecken mit drauf, ansonsten macht es natülich keinen Sinn was zu installieren was man nicht nutzt.

    zu 2. danke für den Hinweis

    -gelöst-
     
    #7
    jensebub gefällt das.
  9. aragorn
    Offline

    aragorn Guest

    AW: Autostart abschalten geht nicht in 11.5

    ..wenn du mit newcs oder sbox usw irgendwas testen willst, kannst du die ja problemlos über i cams jüst aktivieren, deine tests durchführen und dann wieder über i cams deaktivieren


    die dateien werden nur verschoben, dh die information wo die datei liegt verändert sich - dadurch wird also so wenig wie möglich auf dem laufwerk herrum geschrieben und auch kein unnötiger traffic erzeugt..
     
    #8
  10. King_Piet
    Offline

    King_Piet Ist gelegentlich hier

    Registriert:
    8. April 2012
    Beiträge:
    40
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Re: AW: Autostart abschalten geht nicht in 11.5

    wie funktioniert das genau mit den jobs? davon habe ich noch keinen schimmer.. habe aber wie gesagt, das problem, dass alle cams gestartet werden, brauche aber nur oscam.
     
    #9
  11. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.421
    Zustimmungen:
    12.684
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: Autostart abschalten geht nicht in 11.5

    Dann führe für deine Fall i cams aus, wähle mit den Pfeiltasten und der Leertaste nur oscam aus, dann auf OK und mit der Eingabetaste speichern.

    Den Anhang 66400 betrachten
     
    #10

Diese Seite empfehlen