1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Automatischer Start von Oscam

Dieses Thema im Forum "Fritzbox Archiv" wurde erstellt von retsi, 15. August 2010.

  1. retsi
    Offline

    retsi Ist gelegentlich hier

    Registriert:
    6. September 2008
    Beiträge:
    47
    Zustimmungen:
    3
    Punkte für Erfolge:
    8
    Hi zusammen,

    ich habe folgende Kleinigeit, die doch ab und an etwas nervig ist. Speziell wenn die FB doch mal unerwarteterweise abstürzen und neustarten sollte:

    Oscam startet nicht automatisch. Obwohl im Freetz unter Dienter>Oscam der Starttyp auf Automatisch steht.

    Wenn ich dann das Paket manuell starte startet es ohne Probleme. Allerdings auch insofern ungewöhnlich, als das das Webinterface ewig läd und der keine Meldung bringt, dass er nun fertig ist mit Laden. Obwohl Oscam schon längst läuft und funktioniert. Das wäre aber halb so wild, es läuft ja schließlich.

    Aber vllt. hängt das zusammen.

    Jetzt nochmal zum Autostart:
    Unter Status>Logdateien steht folgendes:

    Code:
    rc.mod version freetz-devel-4178M
    crond is disabled
    telnetd is disabled
    Starting Freetz webinterface...done.
    Starting syslogd...done.
    Disk spindown is disabled
    /etc/init.d/rc.callmonitor: readonly: line 2: APPLET: is read only
    Starting dropbear SSH server...done.
    Starting Privoxy...done.
    Starting ftp server...done.
    Setting up SSH authorized_keys for root...initialized.
    camd3 is disabled
    newcs is disabled
    gbox is disabled
    mbox is disabled
    apache is disabled
    cccam is disabled
    Starte OSCam...
    mknod: /dev/ttyUSB0: File exists
    USB-Serial Module geladen
    mkdir: cannot create directory '/var/cache/watchdog/': No such file or directory
    cp: cannot stat '/var/media/ftp/uStor01/watchdog/oscam/*': No such file or directory
    Dateien für Watchdog in den Flash kopiert
    nohup: /var/media/ftp/uStor01/cs/oscam/oscam: No such file or directory
    OSCam gestartet!
    swap is disabled
    
    Ich vermute, damit hängt es zusammen, dass er nicht automatisch startet oder? Wie bekomm ich es nun hin, dass er es tut. Wenn ich die Verzeichnisse manuell per FTP anlege, dann macht er das auch nicht.

    Danke schonmal für euere Hilfe.

    Gruß retsi
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. toso01
    Offline

    toso01 Hacker

    Registriert:
    22. Mai 2010
    Beiträge:
    371
    Zustimmungen:
    240
    Punkte für Erfolge:
    0
    AW: Automatischer Start von Oscam

    Hallo retsi,

    mache bitte folgendes:
    stelle im Freetzmenü bei "Pakete - oscam" starttyp auf manuell
    trage bei "Einstellungen - rc.custom" folgendes ein /etc/init.d/rc.oscam start
    Mit diesem Eintrag startet die oscam automatisch bei jedem FB-Neustart/Reboot.

    Ich starte jede Nacht meine FB neu per crond, und über rc.custom werden bei mir die newcs und cccam dann automatisch gestartet.
     
    #2
    Pilot und retsi gefällt das.
  4. retsi
    Offline

    retsi Ist gelegentlich hier

    Registriert:
    6. September 2008
    Beiträge:
    47
    Zustimmungen:
    3
    Punkte für Erfolge:
    8
    AW: Automatischer Start von Oscam

    Prima. Hat geklappt. So einfach gehts also. Danke :)
     
    #3

Diese Seite empfehlen