1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem 2x S02 AU Problem

Dieses Thema im Forum "OScam Archiv" wurde erstellt von xtraxion, 4. Oktober 2011.

  1. xtraxion
    Offline

    xtraxion Ist gelegentlich hier

    Registriert:
    3. September 2009
    Beiträge:
    32
    Zustimmungen:
    2
    Punkte für Erfolge:
    8
    moin zusammen.

    Ich hab bei mir ne Seagate Dockstar als CS Server am laufen.

    Als ABO Karten habe ich: 1x Sky1 (Film, Welt,HD) 1x Sky2(Komplett) 1xORF und 1x HD+

    Oscam version: OSCAM 1.20-unstable_svn build #5863

    Jetzt zu meinem Problem:

    die 1. Sky Karte bekommt sauber alle EMMs(Shared,Global, unique) und läuft jetzt schon mit ausnahme seltener OSCAM hänger sauber durch.
    Die 2. Sky Karte (komplett Abo) bekommt allerdings nur die Global EMMS was zur folge hat das die Karte alle paar wochen dunkel wird und ich diese Manuell am Reciever updaten muss.

    Es läuft kein Loadbalancer, ich hab eine saubere Gruppentrennung drin, 3 Clients greiffen nur auf Gruppe 1,2,3 zu(Sky1,HD+, ORF) und 2 Clients auf Gruppe 2,3,4(Sky2,HD+,ORF) zu.
    Alle Clienten connecten per MGcamd mit dem Newcamd protokoll und haben ALLE die selbe mgcamd config und version.

    Hier noch keine Configs:

    Oscam.config:

    Code:
    [global]
    serverip                      = 192.168.123.247
    usrfile                       = /mnt/sda1/oscam-user.log
    logfile                       = /mnt/sda1/oscam.log
    cwlogdir                      = /mnt/sda1/cw.log
    disableuserfile               = 0
    fallbacktimeout               = 2000
    clientmaxidle                 = 60
    cachedelay                    = 20
    bindwait                      = 60
    nice                          = -1
    maxlogsize                    = 5120
    preferlocalcards              = 1
    saveinithistory               = 1
    lb_mode                       = 1
    lb_savepath                   = 
    
    [monitor]
    port                          = 1002
    nocrypt                       = 0.0.0.0-255.255.255.255
    hideclient_to                 = 15
    monlevel                      = 4
    appendchaninfo                = 1
    
    [newcamd]
    port                          = 10001@1702:000000;10002@1830:000000;10003@0D95:000004,000008,00000C,000010;10005@098E:000000
    serverip                      = 192.168.123.247
    key                           = x
    keepalive                     = 0
    mgclient                      = 1
    
    [cs357x]
    port                          = 24110
    
    [cccam]
    port                          = 10000
    reshare                       = 0
    version                       = 2.1.1
    
    [webif]
    httpport                      = 1001
    httpuser                      = x
    httppwd                       = x
    httprefresh                   = 10
    httpallowed                   = 0.0.0.0-255.255.255.255
    httphideidleclients           = 1

    Oscam.user:

    Code:
    
    [account]
    user                          = user1
    pwd                           = user1
    description                   = 
    group                         = 1,2,3
    uniq                          = 2
    au                            = 1
    services                      = sky_welt,sky_welt_extra,sky_film,sky_sport,sky_buli,sky_hd,sky_select,sky_erotik,sky_sonstige,sky_radio,orf1,hdplus1
    caid                          = 1702,1830,0D95,1833
    cccreshare                    = 1
    keepalive                     = 0
    
    [account]
    user                          = user2
    pwd                           = user2
    group                         = 1,2,3
    uniq                          = 2
    au                            = 1
    caid                          = 1702,1830,0D05,0D95
    cccreshare                    = 1
    keepalive                     = 0
    
    [account]
    user                          = user3
    pwd                           = user3
    group                         = 1,2,3
    services                      = sky_welt,sky_welt_extra,sky_film,!sky_sport,!sky_buli,sky_hd,sky_select,sky_erotik,sky_sonstige,sky_radio,orf1,hdplus1
    caid                          = 1702,1830,0D05,0D95
    cccreshare                    = 1
    keepalive                     = 0
    
    [account]
    user                          = user4
    pwd                           = user4
    group                         = 2,3,4
    au                            = 1
    services                      = sky_welt,sky_welt_extra,sky_film,sky_sport,sky_buli,sky_hd,sky_select,!sky_erotik,sky_sonstige,sky_radio,orf1,hdplus1
    caid                          = 1702,1830,0D05,0D95,1833
    cccreshare                    = 1
    keepalive                     = 0
    
    [account]
    user                          = user5
    pwd                           = user5
    group                         = 2,3,4
    au                            = 1
    services                      = sky_welt,sky_welt_extra,sky_film,sky_sport,sky_buli,sky_hd,sky_select,sky_erotik,sky_sonstige,sky_radio,orf1,hdplus1
    caid                          = 1830,0D05,0D95,1702,1833
    cccreshare                    = 1
    keepalive                     = 0

    Oscam.server:


    Code:
    [reader]
    label                         = hdplus
    protocol                      = mouse
    device                        = /dev/ttyUSB3
    services                      = !sky_welt,!sky_welt_extra,!sky_film,!sky_sport,!sky_buli,!sky_hd,!sky_select,!sky_erotik,!sky_sonstige,!sky_radio,!orf1,hdplus1,!kabelbw
    caid                          = 1830
    rsakey                        = Bxxxxxxxxxxxxxxxxx5
    boxkey                        = AxxxxxxxC
    detect                        = cd
    mhz                           = 368
    cardmhz                       = 368
    group                         = 2
    emmcache                      = 1,3,-1
    
    [reader]
    label                         = sky1
    protocol                      = mouse
    device                        = /dev/ttyUSB0
    services                      = sky_welt,sky_welt_extra,sky_film,!sky_sport,!sky_buli,sky_hd,sky_select,sky_erotik,sky_sonstige,sky_radio,!orf1,!hdplus1,!kabelbw
    caid                          = 1702,1833
    boxkey                        = 1122334455667788
    detect                        = cd
    mhz                           = 600
    cardmhz                       = 600
    group                         = 1
    emmcache                      = 1,3,-1
    
    [reader]
    label                         = sky2
    protocol                      = mouse
    device                        = /dev/ttyUSB1
    services                      = sky_welt,sky_welt_extra,sky_film,sky_sport,sky_buli,sky_hd,sky_select,sky_erotik,sky_sonstige,sky_radio,!orf1,!hdplus1,!kabelbw
    caid                          = 1702,1833
    boxkey                        = 1122334455667788
    detect                        = cd
    mhz                           = 600
    cardmhz                       = 600
    group                         = 4
    emmcache                      = 1,3,-1
    
    [reader]
    label                         = orf
    protocol                      = mouse
    device                        = /dev/ttyUSB2
    services                      = !sky_welt,!sky_welt_extra,!sky_film,!sky_sport,!sky_buli,!sky_hd,!sky_select,!sky_erotik,!sky_sonstige,!sky_radio,orf1,!hdplus1,!kabelbw
    caid                          = 0D95
    detect                        = cd
    mhz                           = 368
    cardmhz                       = 368
    group                         = 3
    emmcache                      = 1,3,-1
    deprecated                    = 1


    ich denk die services, provid usw muss ich nicht noch anhängen^^

    Ich hoffe mir kann einer helfen da mich dieser fehler schon seid mehreren monaten nervt und ich einfach nix gefunden habe.

    PS.: Ich habe auch schon diverse OScam versionen durchprobiert und den Loadbalancer eingestellt mit zwei Benutzern die auf beide Karten zugreiffen dürfen, ergab allerdings auch keine änderungen
     
    Zuletzt von einem Moderator bearbeitet: 4. Oktober 2011
    #1
  2. phantom

    Nervigen User Advertisement

  3. tecfreak
    Offline

    tecfreak Hacker

    Registriert:
    13. September 2010
    Beiträge:
    418
    Zustimmungen:
    128
    Punkte für Erfolge:
    43
    AW: 2x S02 AU Problem

    Das ist kein Fehler! Die Config stimmt auch soweit.

    Dein Problem ist, dass kein Protokoll in der Lage ist zwei "identische" SC zu aktualisieren, da immer nur die Seriennummer der ersten Smartcard übertragen wird wenn sich der Client verbindet und die SN ist nötig um Shared- und Unique-EMMs zu empfangen. Deswegen kommen auf der zweiten SC nur Global-EMMs an.

    Einzige Ausnahme unter den ganzen Protokollen ist camd33/35 (mein Favorit) welches bei jedem Wechsel der Smartcard (durch Zappen, Loadbalancer, Services oder was auch immer) immer stehts die Seriennummer an den Client übermittelt. So klappt das AU immer mit einer beliebigen Anzahl an gleichen Smartcards. man muss nur zusehen, dass OScam den Client auch auf die jeweilige Karte derigiert, da immer nur die Karte Shared- und Unique-EMMs bekommt, die auch gerade zum Entschlüsseln genutzt wird.
    Global-EMMs landen dagegen immer auf allen Karten des gleichen Typs (gleiche CAID und gleiche ROM-version).

    Also heißt das für dich einen deiner Clients mit camd35 auszustatten und diesen das AU machen lassen.
     
    #2
  4. xtraxion
    Offline

    xtraxion Ist gelegentlich hier

    Registriert:
    3. September 2009
    Beiträge:
    32
    Zustimmungen:
    2
    Punkte für Erfolge:
    8
    Nach dem Motto: its not a bug, its a feature;)

    Super, dank dir für die info,jetzt weiss ich wenigstens woran es liegt und wie ich das beheben kann.

    Dann werd ich einen client der 2. Karte über die camd35 anbinden.

    Ich bekomm die Mgcamd einfach nicht ans laufen :-/
    weder mit TCP noch mit UDP,
    cs378x geht garnicht erst durch bis zum server
    und mit
    cs357x://test1:test2@192.168.123.247:11000
    kommt immer parse error
    wenn ich dann die Line auf cs357x://test1:test2@192.168.123.247:11000?1702:000000=1702:000000&1722:000000=1702:000000
    erweiter kommt im OSCAM :
    incomplete request !
    checksum error (wrong password ?)

    woran kann das liegen?, is das was größers? wenn ja mach ich besser n eigenen Thread auf
     
    Zuletzt von einem Moderator bearbeitet: 11. Oktober 2011
    #3

Diese Seite empfehlen