1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

2 Smargos mit HD+ 01 und S02 über Speedport W900

Dieses Thema im Forum "Fritzbox Archiv" wurde erstellt von RedTiger2407, 9. Oktober 2011.

  1. RedTiger2407
    Offline

    RedTiger2407 Spezialist

    Registriert:
    1. Januar 2010
    Beiträge:
    661
    Zustimmungen:
    14
    Punkte für Erfolge:
    18
    Hallo,

    bin gerade dabei auf meinen Speedport mit aktuellem Freetz Image von hier mit oscam anzulegen.

    Aber anscheinend sind bei den configs noch einige Fehler drin.

    Meine Karten: S02 und HD+ (weisse Karte) mit 2 Cardreader

    Hier mal meine Configs momentan:


    oscam.server
    Code:
    [reader]
    label                         = skyde
    protocol                      = smargo
    device                        = /dev/ttyUSB0
    services                      = skywelt,skymusicchoiceextra,skycinema,skysport,skybundesliga,skyhd,skyweltextra,bluemovie,skysonstige
    caid                          = 1702,1833
    boxkey                        = 1122334455667788
    detect                        = cd
    mhz                           = 357
    cardmhz                       = 357
    ident                         = 1702:000000
    group                         = 1
    emmcache                      = 1,3,2
    
    
    [reader]
    label                         = hdplus
    protocol                      = smargo
    device                        = /dev/ttyUSB1
    services                      = hdplus
    caid                          = 1830
    rsakey                        = BXXXXXXXXXXXXXXX5
    boxkey                        = AXXXXXXXXXXXXXC
    detect                        = cd
    mhz                           = 368
    cardmhz                       = 368
    group                         = 2
    emmcache                      = 1,3,2
    
    oscam.config
    Code:
    [global]
    #logfile = /var/media/ftp/uStor01/OScam.log
    disablelog = 0
    disableuserfile = 0
    usrfileflag = 0
    clienttimeout = 5000
    fallbacktimeout = 2500
    clientmaxidle = 120
    cachedelay = 120
    bindwait = 120
    netprio = 0
    clientdyndns = 0
    resolvedelay = 30
    unlockparental = 0
    nice = -1
    serialreadertimeout = 1500
    maxlogsize = 2480
    waitforcards = 1
    preferlocalcards = 0
    saveinithistory = 1
    readerrestartseconds = 5
    resolvegethostbyname = 0
    
    [monitor]
    port = 988
    aulow = 120
    hideclient_to = 0
    monlevel = 4
    appendchaninfo = 1
    
    # protocols
    #[camd35]
    #Port = 3333
    
    [newcamd]
    key = 0102030405060708091011121314
    port = 34000@1830:003411
    keepalive = 1
    mgclient = 0
    
    
    [webif]
    httpport                      = ????
    httpcss                       = /var/media/ftp/uStor01//cs/oscam//proflinux_ddcstyle.css
    httprefresh                   = 10
    httpallowed                   = 127.0.0.1,192.168.0.0-192.168.255.255
    httphideidleclients           = 0
    httpreadonly                  = 0
    httpsavefullcfg               = 0
    
    oscam.user
    Code:
    [account]
    user                          = user1
    pwd                           = pass
    monlevel                      = 0
    au                            = skyde
    cccmaxhops                    = 2
    cccreshare                    = 2
    keepalive                     = 1
    
    [account]
    user                          = user2
    pwd                           = pass
    group                         = 2
    monlevel                      = 0
    au                            = hdplus
    caid                          = 1830
    cccmaxhops                    = 2
    cccreshare                    = 2
    keepalive                     = 1
    
    [account]
    user                          = dbox2
    pwd                           = dbox2
    group                         = 1
    cccmaxhops                    = 2
    cccreshare                    = 0
    
    [account]
    user                          = vuplustest
    pwd                           = vuplustest
    group                         = 1,2
    cccmaxhops                    = 2
    cccreshare                    = 0
    
    Hier mal der Log von Oscam WebIF:

    Code:
             2011/10/09 10:53:54        0 s >> OSCam  <<  cardserver started, version 1.20 -DEB-Freetz--Prof.Linux- ,  build #5865 (mipsel-router-linux-uclibc929)         
            2011/10/09 10:53:54        0 s version=1.20 -DEB-Freetz--Prof.Linux- , build #5865, system=mipsel-router-linux, nice=-1         
            2011/10/09 10:53:54        0 s client max. idle=120 sec, debug level=0         
            2011/10/09 10:53:54        0 s max. logsize=2480 Kb, loghistorysize=4096 bytes         
            2011/10/09 10:53:54        0 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=120 ms         
            2011/10/09 10:53:54        0 s services reloaded: 0 services freed, 11 services loaded, rejected 0         
            2011/10/09 10:53:54        0 s userdb reloaded: 9 accounts loaded, 0 expired, 0 disabled         
            2011/10/09 10:53:54        0 s signal handling initialized (type=sysv)         
            2011/10/09 10:53:54        0 s 122 service-id's loaded in 21ms         
            2011/10/09 10:53:54        0 s 116 tier-id's loaded         
            2011/10/09 10:53:54        0 s 3 provid's loaded         
            2011/10/09 10:53:54        0 s 22 lengths for caid guessing loaded         
            2011/10/09 10:53:54        0 s monitor: initialized (fd=6, port=988)         
            2011/10/09 10:53:54        0 s camd35: disabled         
            2011/10/09 10:53:54        0 s cs378x: disabled         
            2011/10/09 10:53:54        0 s newcamd: initialized (fd=7, port=34000, crypted)         
            2011/10/09 10:53:54        0 s -> CAID: 1830 PROVID: 003411         
            2011/10/09 10:53:54        0 s radegast: disabled         
            2011/10/09 10:53:54        0 s http thread started         
            2011/10/09 10:53:54        0 s reader check thread started         
            2011/10/09 10:53:54        0 s check thread started         
            2011/10/09 10:53:54        0 s creating thread for device /dev/ttyUSB0         
            2011/10/09 10:53:54        0 s creating thread for device /dev/ttyUSB1         
            2011/10/09 10:53:54        0 s loadbalancer: can't read from file /tmp/.oscam/stat         
            2011/10/09 10:53:54        0 s waiting for local card init         
            2011/10/09 10:53:54   594D10 h HTTP Server listening on port 666         
            2011/10/09 10:53:54   591F00 r smargo init         
            2011/10/09 10:53:54   593608 r smargo init         
            2011/10/09 10:53:54   593608 r reader hdplus initialized (device=/dev/ttyUSB1, detect=cd, mhz=368, cardmhz=368)         
            2011/10/09 10:53:54   591F00 r reader skyde initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)         
            2011/10/09 10:53:55        0   hdplus card detected         
            2011/10/09 10:54:05   593608 r ATR: 3B 9F 21 0E 49 52 44 45 54 4F 20 41 43 53 03 84 55 FF 80 6D          
            2011/10/09 10:54:05   593608 r Maximum frequency for this card is formally 6 Mhz, clocking it to 3.68 Mhz         
            2011/10/09 10:54:06   593608 r detect irdeto tunneled nagra card         
            2011/10/09 10:54:06   593608 r rsa key configured -> using nagra mode         
            2011/10/09 10:54:09   593608 r detect irdeto card         
            2011/10/09 10:54:12   593608 r card system not supported         
            2011/10/09 10:54:12   593608 r Normal mode failed, reverting to Deprecated Mode         
            2011/10/09 10:54:27   593608 r ATR is malformed, it reports 14 historical bytes but there are only 8         
            2011/10/09 10:54:27   593608 r ATR: 3B 0E 49 52 45 54 4F 20 43 80          
            2011/10/09 10:54:27   593608 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.68 Mhz         
            2011/10/09 10:54:28   593608 r card system not supported         
            2011/10/09 10:54:28   593608 r card initializing error         
            2011/10/09 10:54:29        0 s init for all local cards done         
        
    
    Wo liegen die Grundlegenden Fehler noch?????
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. IDDQD
    Offline

    IDDQD Board Guru

    Registriert:
    6. Februar 2008
    Beiträge:
    1.416
    Zustimmungen:
    635
    Punkte für Erfolge:
    113
    Beruf:
    IT'ler
    Ort:
    Zone
    AW: 2 Smargos mit HD+ 01 und S02 über Speedport W900

    die s02 wird mit 6mhz gelesen nicht mit 3,57 ist so das erste was mir auffällt :)
    und bei hd+ habe ich 3,57 nicht 3,68

    [reader]
    label = hd+
    protocol = mouse
    device = /dev/HDplus
    services = hdplus
    caid = 1830
    rsakey = BXXXXXXB$
    boxkey = AXXXXC
    detect = cd
    mhz = 357
    cardmhz = 357
    group = 1
    emmcache = 1,3,2

    so siehts bei bei mir
     
    #2
  4. RedTiger2407
    Offline

    RedTiger2407 Spezialist

    Registriert:
    1. Januar 2010
    Beiträge:
    661
    Zustimmungen:
    14
    Punkte für Erfolge:
    18
    AW: 2 Smargos mit HD+ 01 und S02 über Speedport W900

    mh ok.... bin mir auch nicht sicher, ob die device so stimmt.
    Denn ich hab die Smargos über die Toolbox mit einem Label beschrieben. zb SKY und HD+

    Muss ich das dann oscam.server auch ändern? bzw wo sehe ich die genaue device von meinem 2 Smargos?

    lt Freetz

    Code:
    
     Symbolische Links werden erstellt   Die Bibliotheken für das SMARTREADER-TOOL wurden geladen   Überprüfe, ob srptools im Pfad /var/media/ftp/uStor01//tools/smargo   vorhanden sind ...   Starte srptools ...   Die Treiber für die SMARTREADER+ Kartenleser sind bereits geladen   SMARTREADER+ S/N D57C2EF an /dev/ttyUSB0 erkannt   SMARTREADER+ S/N D8B8359 an /dev/ttyUSB1 erkannt
    
     
    #3
  5. IDDQD
    Offline

    IDDQD Board Guru

    Registriert:
    6. Februar 2008
    Beiträge:
    1.416
    Zustimmungen:
    635
    Punkte für Erfolge:
    113
    Beruf:
    IT'ler
    Ort:
    Zone
    AW: 2 Smargos mit HD+ 01 und S02 über Speedport W900

    wenn du die reader mit udevregeln "umbenannt" hast dann solltest du auch diese deviceeinträge im oscam nutzen :) spart dir viel ärger
     
    #4
  6. RedTiger2407
    Offline

    RedTiger2407 Spezialist

    Registriert:
    1. Januar 2010
    Beiträge:
    661
    Zustimmungen:
    14
    Punkte für Erfolge:
    18
    AW: 2 Smargos mit HD+ 01 und S02 über Speedport W900

    Sonst noch krasse Fehler enthalten?
     
    #5
  7. märklin
    Online

    märklin Guest

    AW: 2 Smargos mit HD+ 01 und S02 über Speedport W900

    dann sollte es aber so aussehen mit der Zuordnung

    protocol = smartreader
    device = Serial:Reader D57C2EF

    und

    protocol = smartreader
    device = Serial:Reader D8B8359

    Der smargo muss für das smartreader Protocoll auf Autoswich eingestellt sein und ftdi Treiber deaktivieren
     
    #6
  8. RedTiger2407
    Offline

    RedTiger2407 Spezialist

    Registriert:
    1. Januar 2010
    Beiträge:
    661
    Zustimmungen:
    14
    Punkte für Erfolge:
    18
    AW: 2 Smargos mit HD+ 01 und S02 über Speedport W900

    So hier mal die geänderten Daten:

    oscam.server
    Folgender Log momentan:

    Smargo Einstellungn bei beiden: Autoswitch, 1, 0, Kernel normal

    WIe kann ich ftdi Treiber deaktiveren? Hab im FreetzWebIF nur unter Card*Reader Treiber neu laden ein Häkchen gemacht.

    USB Comport (Treiberauswahl) USB Comport mit einem Treiber aktivieren
    Modul waehlen
    FTDI + PL2303 Treiber gemeinsam
    Card-Reader-Treiber neu laden
     
    Zuletzt bearbeitet: 10. Oktober 2011
    #7
  9. HDskyFreak
    Offline

    HDskyFreak Newbie

    Registriert:
    2. Oktober 2011
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    AW: 2 Smargos mit HD+ 01 und S02 über Speedport W900

    Mir ist noch aufgefallen, du machst dies ja über NewCamd machst, da musst du jeden Readern einen eigenen Port geben!

    Code:
    [global]
    
    [newcamd]
    key = 0102030405060708091011121314
    port = 34000@1830:003411;[COLOR=#ff0000]33000@1702,1833:000000
    [/COLOR]keepalive = 1
    mgclient = 0
    
    
     
    #8
  10. RedTiger2407
    Offline

    RedTiger2407 Spezialist

    Registriert:
    1. Januar 2010
    Beiträge:
    661
    Zustimmungen:
    14
    Punkte für Erfolge:
    18
    AW: 2 Smargos mit HD+ 01 und S02 über Speedport W900

    Naja stimmt. eigentlich brauch ich nur cccam für den Client.
    Könnt newcamd ja komplett löschen und cccam einfügen.

    Aber ich habe heute sky s02 Karte zum laufen bekommen mit protocol "mouse" und konfiguration. Auto Dream 1 0

    Leider will die HD+ weisse Karte mit mouse noch nicht und Auto, Dream, 0,0
     
    #9

Diese Seite empfehlen