1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk 10mbit Netzwerk und langsame Platte?

Dieses Thema im Forum "Raspberry Pi" wurde erstellt von dendon, 12. Juni 2013.

  1. dendon
    Offline

    dendon Ist oft hier

    Registriert:
    18. Mai 2013
    Beiträge:
    127
    Zustimmungen:
    25
    Punkte für Erfolge:
    28
    Hi,

    ich habe heute mal einen Raspi neu aufgesetzt mit OScam, Samba und Pyload.
    Leider ist mir aufgefallen das dieser sehr langsame Netzwerkkommunikationen hat!

    Ich habe mit "iperf -s" mal nachgesehen und war erschrocken. nur knapp 8mbit von 100.
    Die CPU Auslastung ist auch ok mit bis zu 2% und am USB hängt eine Easymouse2 per aktiv Hub.

    ipferf Ausgabe:
    iperf -s
    ------------------------------------------------------------
    Server listening on TCP port 5001
    TCP window size: 85.3 KByte (default)
    ------------------------------------------------------------
    [ 4] local 192.168.178.100 port 5001 connected with 192.168.178.22 port 57610
    [ ID] Interval Transfer Bandwidth
    [ 4] 0.0-10.0 sec 9.44 MBytes 7.90 Mbits/sec

    Desweiteren ist die NTFS-Platte ungewöhnlich langsam mit < 1mbit...
    habe mal mit hdparm nachgemessen:

    sudo hdparm -tT /dev/sda1


    /dev/sda1:
    Timing cached reads: 2 MB in 2.15 seconds = 951.48 kB/sec
    Timing buffered disk reads: 4 MB in 4.33 seconds = 946.75 kB/sec


    Habt ihr eine Idee woran das liegen könnte und Verbesserungsvorschläge?


    Gruß,
    dendon
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. DoubleDom
    Offline

    DoubleDom Hacker

    Registriert:
    11. Mai 2013
    Beiträge:
    385
    Zustimmungen:
    97
    Punkte für Erfolge:
    28
    AW: 10mbit Netzwerk und langsame Platte?

    Wie hängt denn die Platte am RasPi? per Hub oder direkt? 2.5" oder 3.5"? aktiv, passiv?
    ntfs-3g Treiber installiert?
    Grundsätzlich sind ntfs platten ungeeignet für der den RasPI... :fie: formatier' sie lieber in ext3 oder ext4

    Gruß,
    Dom
     
    #2
  4. dendon
    Offline

    dendon Ist oft hier

    Registriert:
    18. Mai 2013
    Beiträge:
    127
    Zustimmungen:
    25
    Punkte für Erfolge:
    28
    AW: 10mbit Netzwerk und langsame Platte?

    Ich habe das Problem gefunden. Der Pi kann einfach nicht schneller...
    Die SD-Karte wird vom Pi einfach nicht schneller als 8mbit verarbeitet. Somit kann der Rest so schnell sein wie er will, wenn das Grundsystem so langsam ist. :(

    Bin aktuell noch am schauen ob ich an der SD-Karte was machen kann das die schneller wird. Ansonsten halt neue SD-Karte und nochmal versuchen :)

    Gruß,
    dendon

    Edit: Alles klar, Problem steht noch aus. Gerade die SD-Karte durchgetestet und die rennt wie verrückt! Muss man Einstellungen tätigen oder so, damit man <8mbit übertragen kann? Ich hatte das Problem noch nie! :(

    Edit2: Image neu aufspielen hat das Problem beseitigt! Habe aber leider nicht rausfinden können, woran es lag. Ich habe mit NTFS eine Schreibgeschwindigkeit von 5,5MB/s
     
    Zuletzt bearbeitet: 13. Juni 2013
    #3

Diese Seite empfehlen